summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMartin Schlemmer <azarah@gentoo.org>2002-03-26 00:48:55 +0000
committerMartin Schlemmer <azarah@gentoo.org>2002-03-26 00:48:55 +0000
commitc23f4a1a40e520092568ee8d4f502573e5b1d5d7 (patch)
tree28b0cbd2d17935e5b99c423d7302e29c9e49c506 /sys-devel/automake/files
parentstamp fix (diff)
downloadhistorical-c23f4a1a40e520092568ee8d4f502573e5b1d5d7.tar.gz
historical-c23f4a1a40e520092568ee8d4f502573e5b1d5d7.tar.bz2
historical-c23f4a1a40e520092568ee8d4f502573e5b1d5d7.zip
add more compadible version
Diffstat (limited to 'sys-devel/automake/files')
-rw-r--r--sys-devel/automake/files/am-wrapper.pl-1.552
-rw-r--r--sys-devel/automake/files/digest-automake-1.5d-r12
2 files changed, 54 insertions, 0 deletions
diff --git a/sys-devel/automake/files/am-wrapper.pl-1.5 b/sys-devel/automake/files/am-wrapper.pl-1.5
new file mode 100644
index 000000000000..c42858ee88c1
--- /dev/null
+++ b/sys-devel/automake/files/am-wrapper.pl-1.5
@@ -0,0 +1,52 @@
+#!/usr/bin/perl
+#
+#
+# Guillaume Cottenceau (gc@mandrakesoft.com)
+#
+# Copyright 2001 MandrakeSoft
+#
+# This software may be freely redistributed under the terms of the GNU
+# public license.
+#
+# You should have received a copy of the GNU General Public License
+# along with this program; if not, write to the Free Software
+# Foundation, Inc., 675 Mass Ave, Cambridge, MA 02139, USA.
+#
+#
+# Executes the correct autoconf version.
+#
+# - defaults to automake-1.4
+# - runs automake-1.5x if it exists and...
+# - envvar WANT_AUTOMAKE_1_5 is set to `1'
+# -or-
+# - configure.ac is present
+# -or-
+# - `configure.in' contains AC_PREREQ and the value's 3 first letters
+# are stringwise greater than '2.1'
+#
+
+#use MDK::Common;
+
+sub cat_ { local *F; open F, $_[0] or return; my @l = <F>; wantarray ? @l : join '', @l }
+
+my $binary = "$0-1.4";
+my $binary_new = "$0-1.5x";
+
+if (!$ENV{WANT_AUTOMAKE_1_4}) {
+ if (-x $binary_new # user may have only 2.13
+ && ($ENV{WANT_AUTOMAKE_1_5}
+ || -r 'configure.ac'
+ || (cat_('configure.in') =~ /^\s*AC_PREREQ\(([^\)]{3})[^\)]*\)/m ? $1 : '') gt '2.1'
+ || (cat_('aclocal.m4') =~ /^\s*AC_PREREQ\(([^\)]{3})[^\)]*\)/m ? $1 : '') gt '2.1')) {
+ $ENV{WANT_AUTOMAKE_1_5} = 1; # to prevent further "cats" and to enhance consistency (possible cwd etc)
+ $binary = $binary_new;
+ } else {
+ $ENV{WANT_AUTOMAKE_1_4} = 1; # for further consistency
+ }
+}
+
+$ENV{WANT_AMWRAPPER_DEBUG} and print STDERR "am-wrapper: will execute <$binary>\n";
+
+exec $binary, @ARGV;
+
+die "am-wrapper: ouch, couldn't call binary ($binary).\n";
diff --git a/sys-devel/automake/files/digest-automake-1.5d-r1 b/sys-devel/automake/files/digest-automake-1.5d-r1
new file mode 100644
index 000000000000..feb51fd9db4a
--- /dev/null
+++ b/sys-devel/automake/files/digest-automake-1.5d-r1
@@ -0,0 +1,2 @@
+MD5 78b3eb4d3d593ceaa32c1d33d6abcdf6 automake-1.5d.tar.bz2 455041
+MD5 e10679bba411f8602eed004012d915e3 automake-1.4-p5.tar.gz 376992