summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLisa M. Seelye <lisa@gentoo.org>2005-06-15 12:52:17 +0000
committerLisa M. Seelye <lisa@gentoo.org>2005-06-15 12:52:17 +0000
commit01364e31d63fb57f68880733066ddeb67e5fc90c (patch)
tree406a09d6e0fbcfe35de53e2de472fb56ad1b4082 /sys-devel/distcc
parentSecurity removal, see bug 84659 (diff)
downloadhistorical-01364e31d63fb57f68880733066ddeb67e5fc90c.tar.gz
historical-01364e31d63fb57f68880733066ddeb67e5fc90c.tar.bz2
historical-01364e31d63fb57f68880733066ddeb67e5fc90c.zip
Did a little jiggeypokery with the Gnome/GTK+ monitor: mv distccmon-gnome -> distccmon-gui and a symlink for backwards compatability. It seems a bit silly to have the gtk+ monitor called distccmon-gnome (when it isn't).
Package-Manager: portage-2.0.51.22-r1
Diffstat (limited to 'sys-devel/distcc')
-rw-r--r--sys-devel/distcc/ChangeLog11
-rw-r--r--sys-devel/distcc/Manifest6
-rw-r--r--sys-devel/distcc/distcc-2.16-r3.ebuild165
-rw-r--r--sys-devel/distcc/distcc-2.18.3-r7.ebuild162
-rw-r--r--sys-devel/distcc/files/digest-distcc-2.16-r31
-rw-r--r--sys-devel/distcc/files/digest-distcc-2.18.3-r71
6 files changed, 344 insertions, 2 deletions
diff --git a/sys-devel/distcc/ChangeLog b/sys-devel/distcc/ChangeLog
index 6f90c6c43927..fdea53c2553b 100644
--- a/sys-devel/distcc/ChangeLog
+++ b/sys-devel/distcc/ChangeLog
@@ -1,6 +1,15 @@
# ChangeLog for sys-devel/distcc
# Copyright 2000-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/distcc/ChangeLog,v 1.140 2005/05/18 10:44:10 lisa Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/distcc/ChangeLog,v 1.141 2005/06/15 12:52:17 lisa Exp $
+
+*distcc-2.18.3-r7 (15 Jun 2005)
+*distcc-2.16-r3 (15 Jun 2005)
+
+ 15 Jun 2005; Lisa Seelye <lisa@gentoo.org> +distcc-2.16-r3.ebuild,
+ +distcc-2.18.3-r7.ebuild:
+ Did a little jiggeypokery with the Gnome/GTK+ monitor: mv distccmon-gnome ->
+ distccmon-gui and a symlink for backwards compatability. It seems a bit
+ silly to have the gtk+ monitor called distccmon-gnome (when it isn't).
*distcc-2.18.3-r6 (18 May 2005)
diff --git a/sys-devel/distcc/Manifest b/sys-devel/distcc/Manifest
index de2c4b8a5df0..b70e97740416 100644
--- a/sys-devel/distcc/Manifest
+++ b/sys-devel/distcc/Manifest
@@ -1,8 +1,12 @@
-MD5 d3d8cd60e179bf216a370dafd0952fb4 ChangeLog 25760
+MD5 64ffaae46d18587ee6c57d2487012c34 ChangeLog 26147
MD5 02847d17d77f9fa6b67c232400108e44 distcc-2.16-r2.ebuild 4856
+MD5 c36658372614594d61c3b940583da450 distcc-2.18.3-r7.ebuild 4920
+MD5 de278aaedd21a3852f8700ceda593eb9 distcc-2.16-r3.ebuild 5182
MD5 c04441917ccb5e5f9790642545c1f469 metadata.xml 375
MD5 64e0afe30accc560225a5c48fc49119d distcc-2.18.3-r6.ebuild 4593
MD5 c462167d99c154e9f8b9f94022ed2a71 files/digest-distcc-2.16-r2 64
+MD5 fa3f7ab9f7829ba28b454f624b11da53 files/digest-distcc-2.18.3-r7 66
+MD5 c462167d99c154e9f8b9f94022ed2a71 files/digest-distcc-2.16-r3 64
MD5 fec77b3be8d8bd8f2d6e5a708cb35717 files/distcc-config 4874
MD5 ec06b50c03c5002d4df60e49b9798445 files/distcc-gentoo-multilib-r1.patch 4245
MD5 687a622f11f457581b267ce5fb3c2721 files/distcc-gentoo-multilib.patch 3784
diff --git a/sys-devel/distcc/distcc-2.16-r3.ebuild b/sys-devel/distcc/distcc-2.16-r3.ebuild
new file mode 100644
index 000000000000..858f32a228f0
--- /dev/null
+++ b/sys-devel/distcc/distcc-2.16-r3.ebuild
@@ -0,0 +1,165 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/distcc/distcc-2.16-r3.ebuild,v 1.1 2005/06/15 12:52:17 lisa Exp $
+
+# If you change this in any way please email lisa@gentoo.org and make an
+# entry in the ChangeLog (this means you spanky :P). (2004-04-11) Lisa Seelye
+
+inherit eutils flag-o-matic gnuconfig toolchain-funcs
+
+PATCHLEVEL="2.17"
+
+DESCRIPTION="a program to distribute compilation of C code across several machines on a network"
+HOMEPAGE="http://distcc.samba.org/"
+SRC_URI="http://distcc.samba.org/ftp/distcc/distcc-${PV}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="x86 ppc sparc mips alpha ~hppa ~ia64 ~amd64 ppc64 ~s390 ~arm"
+
+IUSE="gnome gtk selinux ipv6"
+
+DEPEND=">=sys-apps/portage-2.0.49-r6
+ >=sys-devel/gcc-config-1.3.1
+ sys-apps/shadow
+ dev-util/pkgconfig"
+RDEPEND="
+ !arm? ( !s390? (
+ gnome? (
+ >=x11-libs/gtk+-2.0.0
+ >=gnome-base/libgnome-2.0.0
+ >=gnome-base/libgnomeui-2.0.0.0
+ >=gnome-base/libglade-2.0.0
+ x11-libs/pango
+ >=gnome-base/gconf-2.0.0
+ )
+ gtk? (
+ >=x11-libs/gtk+-2.0.0
+ x11-libs/pango
+ )
+ ) )
+ selinux? ( sec-policy/selinux-distcc )"
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ gnuconfig_update
+}
+
+src_compile() {
+ local myconf="--with-included-popt "
+ #Here we use the built in parse-options package. saves a dependancy
+
+ #not taking any chances here, guessing which takes precedence in the
+ #configure script, so we'll just make the distinction here:
+ #gnome takes precedence over gtk if both are specified (gnome pulls
+ #in gtk anyways...)
+ use gtk && ! use gnome && myconf="${myconf} --with-gtk"
+ use gtk && use gnome && myconf="${myconf} --with-gnome"
+
+ [ `gcc-major-version` -eq 2 ] && filter-lfs-flags
+
+ if use ipv6; then
+ ewarn "To use IPV6 you must have IPV6 compiled into your kernel"
+ ewarn "either via a module or compiled code"
+ myconf=" ${myconf} --enable-rfc2553 "
+ epause 5
+ fi
+
+ econf ${myconf} || die "econf ${myconf} failed"
+ emake || die "emake failed"
+}
+
+src_install() {
+ make DESTDIR="${D%/}" install
+
+ insinto /usr/share/doc/${PN}
+ doins "${S}/survey.txt"
+
+ exeinto /usr/bin
+ doexe "${FILESDIR}/distcc-config"
+
+ insinto /etc/conf.d
+ newins "${FILESDIR}/${PATCHLEVEL}/conf" distccd
+
+ exeinto /etc/init.d
+ newexe "${FILESDIR}/${PATCHLEVEL}/init" distccd
+
+ # create and keep the symlink dir
+ dodir /usr/lib/distcc/bin
+ keepdir /usr/lib/distcc/bin
+
+ # create the distccd pid directory
+ dodir /var/run/distccd
+ keepdir /var/run/distccd
+
+ if [ `use gnome` -o `use gtk` ]; then
+ einfo "Renaming /usr/bin/distccmon-gnome to /usr/bin/distccmon-gui"
+ einfo "This is to have a little sensability in naming schemes between distcmon programs"
+ mv ${D}/usr/bin/distccmon-gnome ${D}/usr/bin/distccmon-gui
+ dosym /usr/bin/distccmon-gui /usr/bin/distccmon-gnome
+ fi
+}
+
+pkg_preinst() {
+ # non-/ installs don't require us to do anything here
+ [ "${ROOT}" != "/" ] && return 0
+
+ # stop daemon since script is being updated
+ [ -n "$(pidof distccd)" -a -x /etc/init.d/distccd ] && \
+ /etc/init.d/distccd stop
+
+ # moved user creation and permissions to distcc-config script
+ # because of ROOT install requirements
+}
+
+pkg_postinst() {
+ # handle DISTCC_HOSTS upgrade better
+ local ENVFILE
+ ENVFILE="${ROOT}etc/env.d/02distcc"
+ [ ! -f "${ENVFILE}" ] && \
+ ENVFILE="${ROOT}etc/env.d/04distcc"
+ if [ -f "${ENVFILE}" ]
+ then
+ # save hosts to new file
+ ROOT="${ROOT}"
+ HOSTS=$(egrep '^DISTCC_HOSTS' "${ENVFILE}" | sed 's,[^=]*=,,')
+ [ ${HOSTS} ] && ${ROOT}usr/bin/distcc-config --set-hosts ${HOSTS}
+ # now remove from the file
+ grep -v 'DISTCC_HOSTS' "${ENVFILE}" > "${ENVFILE}.new"
+ mv "${ENVFILE}.new" "${ENVFILE}"
+ fi
+
+ if [ "${ROOT}" = "/" ]; then
+ einfo "Installing links to native compilers..."
+ /usr/bin/distcc-config --install
+ else
+ # distcc-config can *almost* handle ROOT installs itself
+ # but for now, but user must finsh things off
+ ewarn "*** Installation is not complete ***"
+ ewarn "You must run the following as root:"
+ ewarn " /usr/bin/distcc-config --install"
+ ewarn "after booting or chrooting into ${ROOT}"
+ fi
+ einfo "Setting permissions on ${ROOT}var/run/distccd"
+ chown -R distcc:daemon ${ROOT}var/run/distccd
+ echo ""
+
+ einfo "Tips on using distcc with Gentoo can be found at"
+ einfo "http://www.gentoo.org/doc/en/distcc.xml"
+ ewarn "As of distcc-2.11, the only thing you have to do to configure distcc"
+ ewarn "is to set your hosts (see the Guide, above) and to add distcc to"
+ ewarn "the FEATURES line in /etc/make.conf"
+ ewarn "This version includes a new distcc-config. If you encounter problems with it,"
+ ewarn "please report them to our Bugzilla at bugs.gentoo.org"
+ echo ""
+ einfo "To use the distccmon programs with Gentoo you should use this command:"
+ einfo " DISTCC_DIR=/var/tmp/portage/.distcc distccmon-text N"
+ use gnome || use gtk && einfo "Or: DISTCC_DIR=/var/tmp/portage/.distcc distccmon-gnome"
+
+ ewarn "***SECURITY NOTICE***"
+ ewarn "If you are upgrading distcc please make sure to run etc-update to"
+ ewarn "update your /etc/conf.d/distccd and /etc/init.d/distccd files with"
+ ewarn "added security precautions (the --listen and --allow directives)"
+ ebeep 5
+}
diff --git a/sys-devel/distcc/distcc-2.18.3-r7.ebuild b/sys-devel/distcc/distcc-2.18.3-r7.ebuild
new file mode 100644
index 000000000000..7f4a782ab325
--- /dev/null
+++ b/sys-devel/distcc/distcc-2.18.3-r7.ebuild
@@ -0,0 +1,162 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/distcc/distcc-2.18.3-r7.ebuild,v 1.1 2005/06/15 12:52:17 lisa Exp $
+
+# If you change this in any way please email lisa@gentoo.org and make an
+# entry in the ChangeLog (this means you spanky :P). (2004-04-11) Lisa Seelye
+
+inherit eutils flag-o-matic gnuconfig toolchain-funcs
+
+PATCHLEVEL="2.18"
+
+DESCRIPTION="a program to distribute compilation of C code across several machines on a network"
+HOMEPAGE="http://distcc.samba.org/"
+SRC_URI="http://distcc.samba.org/ftp/distcc/distcc-${PV}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="x86 ~ppc ~sparc ~mips ~alpha ~arm ~hppa ia64 amd64 ~s390"
+
+IUSE="gnome gtk selinux ipv6"
+
+DEPEND=">=sys-apps/portage-2.0.49-r6
+ >=sys-devel/gcc-config-1.3.1
+ sys-apps/shadow
+ gnome? (
+ dev-util/pkgconfig
+ )
+ gtk? (
+ dev-util/pkgconfig
+ )"
+RDEPEND="
+ gnome? (
+ >=x11-libs/gtk+-2.0.0
+ >=gnome-base/libgnome-2.0.0
+ >=gnome-base/libgnomeui-2.0.0.0
+ >=gnome-base/libglade-2.0.0
+ x11-libs/pango
+ >=gnome-base/gconf-2.0.0
+ )
+ gtk? (
+ >=x11-libs/gtk+-2.0.0
+ x11-libs/pango
+ )
+ selinux? ( sec-policy/selinux-distcc )"
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+
+ # See bug #75420 for more multilib stuff
+ epatch ${FILESDIR}/distcc-gentoo-multilib-r1.patch
+ einfo "Please report to bug #75420 success or failure of this patch."
+ gnuconfig_update
+}
+
+src_compile() {
+ local myconf="--with-included-popt "
+ #Here we use the built in parse-options package. saves a dependancy
+
+ #not taking any chances here, guessing which takes precedence in the
+ #configure script, so we'll just make the distinction here:
+ #gnome takes precedence over gtk if both are specified (gnome pulls
+ #in gtk anyways...)
+ use gtk && ! use gnome && myconf="${myconf} --with-gtk"
+ use gtk && use gnome && myconf="${myconf} --with-gnome"
+
+ #More legacy stuff?
+ [ `gcc-major-version` -eq 2 ] && filter-lfs-flags
+
+ if use ipv6; then
+ ewarn "To use IPV6 you must have IPV6 compiled into your kernel"
+ ewarn "either via a module or compiled code"
+ ewarn "You can recompile without ipv6 with: USE='-ipv6' emerge distcc"
+ myconf=" ${myconf} --enable-rfc2553 "
+ epause 5
+ fi
+ econf ${myconf} || die "econf ${myconf} failed"
+ emake || die "emake failed"
+}
+
+src_install() {
+ make DESTDIR="${D%/}" install
+
+ insinto /usr/share/doc/${PN}
+ doins "${S}/survey.txt"
+
+ exeinto /usr/bin
+ doexe "${FILESDIR}/distcc-config"
+
+ insinto /etc/conf.d
+ newins "${FILESDIR}/${PATCHLEVEL}/conf" distccd
+
+ exeinto /etc/init.d
+ newexe "${FILESDIR}/${PATCHLEVEL}/init" distccd
+
+ # create and keep the symlink dir
+ dodir /usr/lib/distcc/bin
+ keepdir /usr/lib/distcc/bin
+
+ # create the distccd pid directory
+ dodir /var/run/distccd
+ keepdir /var/run/distccd
+
+ if [ `use gnome` -o `use gtk` ]; then
+ einfo "Renaming /usr/bin/distccmon-gnome to /usr/bin/distccmon-gui"
+ einfo "This is to have a little sensability in naming schemes between distccmon programs"
+ mv ${D}/usr/bin/distccmon-gnome ${D}/usr/bin/distccmon-gui
+ dosym /usr/bin/distccmon-gui /usr/bin/distccmon-gnome
+ fi
+
+}
+
+pkg_preinst() {
+ # non-/ installs don't require us to do anything here
+ [ "${ROOT}" != "/" ] && return 0
+
+ # stop daemon since script is being updated
+ [ -n "$(pidof distccd)" -a -x /etc/init.d/distccd ] && \
+ /etc/init.d/distccd stop
+}
+
+pkg_postinst() {
+ #are we doing bootstrap with has no useradd?
+ if [ -x /usr/sbin/useradd ]; then
+ enewuser distcc 240
+ else
+ ewarn "You do not have useradd (bootstrap) from shadow so I didn't"
+ ewarn "install the distcc user. Note that attempting to start the daemon"
+ ewarn "will fail. Please install shadow and re-emerge distcc."
+ ebeep 2
+ fi
+
+ # By now everyone should be using the right envfile
+
+ if [ "${ROOT}" = "/" ]; then
+ einfo "Installing links to native compilers..."
+ /usr/bin/distcc-config --install
+ else
+ # distcc-config can *almost* handle ROOT installs itself
+ # but for now, but user must finsh things off
+ ewarn "*** Installation is not complete ***"
+ ewarn "You must run the following as root:"
+ ewarn " /usr/bin/distcc-config --install"
+ ewarn "after booting or chrooting into ${ROOT}"
+ fi
+ einfo "Setting permissions on ${ROOT}var/run/distccd"
+ chown -R distcc:daemon ${ROOT}var/run/distccd
+ echo ""
+
+ einfo "Tips on using distcc with Gentoo can be found at"
+ einfo "http://www.gentoo.org/doc/en/distcc.xml"
+ echo ""
+ einfo "To use the distccmon programs with Gentoo you should use this command:"
+ einfo " DISTCC_DIR=/var/tmp/portage/.distcc distccmon-text N"
+ use gnome || use gtk && einfo "Or: DISTCC_DIR=/var/tmp/portage/.distcc distccmon-gnome"
+
+ ewarn "***SECURITY NOTICE***"
+ ewarn "If you are upgrading distcc please make sure to run etc-update to"
+ ewarn "update your /etc/conf.d/distccd and /etc/init.d/distccd files with"
+ ewarn "added security precautions (the --listen and --allow directives)"
+ ebeep 5
+}
diff --git a/sys-devel/distcc/files/digest-distcc-2.16-r3 b/sys-devel/distcc/files/digest-distcc-2.16-r3
new file mode 100644
index 000000000000..b46ab9e2afc2
--- /dev/null
+++ b/sys-devel/distcc/files/digest-distcc-2.16-r3
@@ -0,0 +1 @@
+MD5 c28aae996fb4646db27204d9cd6a78dc distcc-2.16.tar.bz2 336681
diff --git a/sys-devel/distcc/files/digest-distcc-2.18.3-r7 b/sys-devel/distcc/files/digest-distcc-2.18.3-r7
new file mode 100644
index 000000000000..7f1ca5e12714
--- /dev/null
+++ b/sys-devel/distcc/files/digest-distcc-2.18.3-r7
@@ -0,0 +1 @@
+MD5 0d6b80a1efc3a3d816c4f4175f63eaa2 distcc-2.18.3.tar.bz2 341601