summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLisa M. Seelye <lisa@gentoo.org>2004-10-12 17:21:43 +0000
committerLisa M. Seelye <lisa@gentoo.org>2004-10-12 17:21:43 +0000
commit3e4f056828b38506b90226a26a4a2efed268db45 (patch)
tree6ea22fd7f3c5b5ed2670bcd9dfb3fc083ef3062c /sys-devel/distcc
parentKeyworded ~sparc (diff)
downloadhistorical-3e4f056828b38506b90226a26a4a2efed268db45.tar.gz
historical-3e4f056828b38506b90226a26a4a2efed268db45.tar.bz2
historical-3e4f056828b38506b90226a26a4a2efed268db45.zip
New version. Hoorraay; --allow flag is now mandatory.
Diffstat (limited to 'sys-devel/distcc')
-rw-r--r--sys-devel/distcc/ChangeLog8
-rw-r--r--sys-devel/distcc/Manifest6
-rw-r--r--sys-devel/distcc/distcc-2.18.ebuild162
-rw-r--r--sys-devel/distcc/files/2.18/conf42
-rw-r--r--sys-devel/distcc/files/2.18/init30
-rw-r--r--sys-devel/distcc/files/digest-distcc-2.181
6 files changed, 247 insertions, 2 deletions
diff --git a/sys-devel/distcc/ChangeLog b/sys-devel/distcc/ChangeLog
index 457d63a1b0ea..af0b8d88d7e3 100644
--- a/sys-devel/distcc/ChangeLog
+++ b/sys-devel/distcc/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sys-devel/distcc
# Copyright 2000-2004 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/distcc/ChangeLog,v 1.124 2004/10/05 16:21:53 lisa Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/distcc/ChangeLog,v 1.125 2004/10/12 17:21:43 lisa Exp $
+
+*distcc-2.18 (12 Oct 2004)
+
+ 12 Oct 2004; Lisa Seelye <lisa@gentoo.org> +files/2.18/conf,
+ +files/2.18/init, +distcc-2.18.ebuild:
+ New version. Hoorraay; --allow flag is now mandatory.
05 Oct 2004; Lisa Seelye <lisa@gentoo.org> distcc-2.16-r2.ebuild:
bump 2.16-r2 on mips
diff --git a/sys-devel/distcc/Manifest b/sys-devel/distcc/Manifest
index 9143fce7d4b7..bbb2650a74b1 100644
--- a/sys-devel/distcc/Manifest
+++ b/sys-devel/distcc/Manifest
@@ -1,10 +1,14 @@
-MD5 df619901019b34183af1167884c23f21 ChangeLog 22654
+MD5 bae63152392738d01451f1d38404328e ChangeLog 22843
+MD5 ef5116f7d387c69aa45c1b437aa55cf2 distcc-2.18.ebuild 5036
MD5 05e11e55fc2c52ffec1f8f44703802f9 distcc-2.16-r2.ebuild 5026
MD5 70619e7eb5fa4fd0aa4f3588579cd50d metadata.xml 443
MD5 b634e8c42c191a882dab36a1e1fddd7b distcc-2.17-r1.ebuild 5169
+MD5 d846f3713232d9c263e6adbfdd521b02 files/digest-distcc-2.18 64
MD5 c462167d99c154e9f8b9f94022ed2a71 files/digest-distcc-2.16-r2 64
MD5 af5f3983a736bd552e83d92ac9955a03 files/digest-distcc-2.17-r1 64
MD5 fec77b3be8d8bd8f2d6e5a708cb35717 files/distcc-config 4874
MD5 2f83451f527f3c2c7739d4535f1fb1b3 files/2.17/conf 1317
MD5 1161999a5d25185f95a8c284bd7307d1 files/2.17/init 733
MD5 a053c2281c30835b1025f307b09b78ae files/2.17/2.17-ipv6-fix.diff.gz 237
+MD5 617b55b46387e2800473b7eb9ca096f0 files/2.18/conf 1384
+MD5 739ebfc62fe125b76021cf7987a158f7 files/2.18/init 733
diff --git a/sys-devel/distcc/distcc-2.18.ebuild b/sys-devel/distcc/distcc-2.18.ebuild
new file mode 100644
index 000000000000..d5b7eb8ec2ac
--- /dev/null
+++ b/sys-devel/distcc/distcc-2.18.ebuild
@@ -0,0 +1,162 @@
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/distcc/distcc-2.18.ebuild,v 1.1 2004/10/12 17:21:43 lisa Exp $
+
+# If you change this in any way please email lisa@gentoo.org and make an
+# entry in the ChangeLog (this means you spanky :P). (2004-04-11) Lisa Seelye
+
+inherit eutils gcc flag-o-matic gnuconfig
+
+PATCHLEVEL="2.18"
+
+DESCRIPTION="a program to distribute compilation of C code across several machines on a network"
+HOMEPAGE="http://distcc.samba.org/"
+SRC_URI="http://distcc.samba.org/ftp/distcc/distcc-${PV}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86 ~ppc ~sparc ~mips ~alpha ~arm ~hppa ~ia64 ~amd64 ~s390"
+
+IUSE="gnome gtk selinux ipv6"
+
+DEPEND=">=sys-apps/portage-2.0.49-r6
+ >=sys-devel/gcc-config-1.3.1
+ sys-apps/shadow
+ dev-util/pkgconfig"
+RDEPEND="
+ !arm? (
+ !mips? (
+ !s390? (
+ gnome? (
+ >=x11-libs/gtk+-2.0.0
+ >=gnome-base/libgnome-2.0.0
+ >=gnome-base/libgnomeui-2.0.0.0
+ >=gnome-base/libglade-2.0.0
+ x11-libs/pango
+ >=gnome-base/gconf-2.0.0
+ )
+ gtk? (
+ >=x11-libs/gtk+-2.0.0
+ x11-libs/pango
+ )
+ )
+ )
+ )
+ selinux? ( sec-policy/selinux-distcc )"
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ gnuconfig_update
+}
+
+src_compile() {
+ local myconf="--with-included-popt "
+ #Here we use the built in parse-options package. saves a dependancy
+
+ #not taking any chances here, guessing which takes precedence in the
+ #configure script, so we'll just make the distinction here:
+ #gnome takes precedence over gtk if both are specified (gnome pulls
+ #in gtk anyways...)
+ use gtk && ! use gnome && ! use mips && myconf="${myconf} --with-gtk"
+ use gtk && use gnome && ! use mips && myconf="${myconf} --with-gnome"
+ use mips && use gtk || use gnome && ewarn "X support for Mips has been disabled."
+ #Above, mips is excluded due to version issues. 2004-02-20
+
+ [ `gcc-major-version` -eq 2 ] && filter-lfs-flags
+
+ if use ipv6; then
+ ewarn "To use IPV6 you must have IPV6 compiled into your kernel"
+ ewarn "either via a module or compiled code"
+ ewarn "You can recompile without ipv6 with: USE='-ipv6' emerge distcc"
+ myconf=" ${myconf} --enable-rfc2553 "
+ epause 5
+ fi
+ einfo "${D}"
+ econf ${myconf} || die "econf ${myconf} failed"
+ emake || die "emake failed"
+}
+
+src_install() {
+ make DESTDIR="${D%/}" install
+
+ insinto /usr/share/doc/${PN}
+ doins "${S}/survey.txt"
+
+ exeinto /usr/bin
+ doexe "${FILESDIR}/distcc-config"
+
+ insinto /etc/conf.d
+ newins "${FILESDIR}/${PATCHLEVEL}/conf" distccd
+
+ exeinto /etc/init.d
+ newexe "${FILESDIR}/${PATCHLEVEL}/init" distccd
+
+ # create and keep the symlink dir
+ dodir /usr/lib/distcc/bin
+ keepdir /usr/lib/distcc/bin
+
+ # create the distccd pid directory
+ dodir /var/run/distccd
+ keepdir /var/run/distccd
+}
+
+pkg_preinst() {
+ # non-/ installs don't require us to do anything here
+ [ "${ROOT}" != "/" ] && return 0
+
+ # stop daemon since script is being updated
+ [ -n "$(pidof distccd)" -a -x /etc/init.d/distccd ] && \
+ /etc/init.d/distccd stop
+}
+
+pkg_postinst() {
+ # handle DISTCC_HOSTS upgrade better
+ local ENVFILE
+ ENVFILE="${ROOT}etc/env.d/02distcc"
+ [ ! -f "${ENVFILE}" ] && \
+ ENVFILE="${ROOT}etc/env.d/04distcc"
+ if [ -f "${ENVFILE}" ]
+ then
+ # save hosts to new file
+ ROOT="${ROOT}"
+ HOSTS=$(egrep '^DISTCC_HOSTS' "${ENVFILE}" | sed 's,[^=]*=,,')
+ [ ${HOSTS} ] && ${ROOT}usr/bin/distcc-config --set-hosts ${HOSTS}
+ # now remove from the file
+ grep -v 'DISTCC_HOSTS' "${ENVFILE}" > "${ENVFILE}.new"
+ mv "${ENVFILE}.new" "${ENVFILE}"
+ fi
+
+ if [ "${ROOT}" = "/" ]; then
+ einfo "Installing links to native compilers..."
+ /usr/bin/distcc-config --install
+ else
+ # distcc-config can *almost* handle ROOT installs itself
+ # but for now, but user must finsh things off
+ ewarn "*** Installation is not complete ***"
+ ewarn "You must run the following as root:"
+ ewarn " /usr/bin/distcc-config --install"
+ ewarn "after booting or chrooting into ${ROOT}"
+ fi
+ einfo "Setting permissions on ${ROOT}var/run/distccd"
+ chown -R distcc:daemon ${ROOT}var/run/distccd
+ echo ""
+
+ einfo "Tips on using distcc with Gentoo can be found at"
+ einfo "http://www.gentoo.org/doc/en/distcc.xml"
+ ewarn "As of distcc-2.11, the only thing you have to do to configure distcc"
+ ewarn "is to set your hosts (see the Guide, above) and to add distcc to"
+ ewarn "the FEATURES line in /etc/make.conf"
+ ewarn "This version includes a new distcc-config. If you encounter problems with it,"
+ ewarn "please report them to our Bugzilla at bugs.gentoo.org"
+ echo ""
+ einfo "To use the distccmon programs with Gentoo you should use this command:"
+ einfo " DISTCC_DIR=/var/tmp/portage/.distcc distccmon-text N"
+ use gnome || use gtk && einfo "Or: DISTCC_DIR=/var/tmp/portage/.distcc distccmon-gnome"
+
+ ewarn "***SECURITY NOTICE***"
+ ewarn "If you are upgrading distcc please make sure to run etc-update to"
+ ewarn "update your /etc/conf.d/distccd and /etc/init.d/distccd files with"
+ ewarn "added security precautions (the --listen and --allow directives)"
+ ebeep 5
+}
diff --git a/sys-devel/distcc/files/2.18/conf b/sys-devel/distcc/files/2.18/conf
new file mode 100644
index 000000000000..700ed42fb6f0
--- /dev/null
+++ b/sys-devel/distcc/files/2.18/conf
@@ -0,0 +1,42 @@
+# Copyright 2003 Gentoo Technologies, Inc
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/distcc/files/2.18/conf,v 1.1 2004/10/12 17:21:43 lisa Exp $
+# distccd configuration file
+
+DISTCCD_OPTS=""
+
+# this is the distccd executable
+DISTCCD_EXEC="/usr/bin/distccd"
+
+# this is where distccd will store its pid file
+DISTCCD_PIDFILE="/var/run/distccd/distccd.pid"
+
+# set this option to run distccd with extra parameters
+# Default port is 3632. For most people the default is okay.
+DISTCCD_OPTS="${DISTCCD_OPTS} --port 3632"
+
+# Logging
+# You can change some logging options here:
+# --log-file FILE
+# --log-level LEVEL [critical,error,warning, notice, info, debug]
+#
+# Leaving --log-file blank will log to syslog
+# example: --log-file /dev/null --log-level warning
+# example: --log-level critical
+
+DISTCCD_OPTS="${DISTCCD_OPTS} --log-level critical"
+
+# SECURITY NOTICE:
+# It is HIGHLY recomended that you use the --listen option
+# for increased security. You can specify an IP to permit connections
+# from or a CIDR mask
+# --listen accepts only a single IP
+# --allow is now mandatory as of distcc-2.18.
+# example: --allow 192.168.0.0/24
+# example: --allow 192.168.0.5 --allow 192.168.0.150
+# example: --listen 192.168.0.2
+DISTCCD_OPTS="${DISTCCD_OPTS} --allow 192.168.0.0/24"
+#DISTCCD_OPTS="${DISTCCD_OPTS} --listen 192.168.0.2"
+
+# set this for niceness
+# Default is 15
+DISTCCD_NICE="15"
diff --git a/sys-devel/distcc/files/2.18/init b/sys-devel/distcc/files/2.18/init
new file mode 100644
index 000000000000..1abe4a9b9001
--- /dev/null
+++ b/sys-devel/distcc/files/2.18/init
@@ -0,0 +1,30 @@
+#!/sbin/runscript
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/distcc/files/2.18/init,v 1.1 2004/10/12 17:21:43 lisa Exp $
+
+depend() {
+ need net
+ use ypbind
+}
+
+start() {
+ [ -e "${DISTCCD_PIDFILE}" ] && rm -f ${DISTCCD_PIDFILE} &>/dev/null
+
+ ebegin "Starting distccd"
+ chown distcc `dirname ${DISTCCD_PIDFILE}` &>/dev/null
+ TMPDIR="${TMPDIR}" \
+ PATH="$(gcc-config --get-bin-path):${PATH}" \
+ /sbin/start-stop-daemon --start --quiet --startas ${DISTCCD_EXEC} \
+ --pidfile ${DISTCCD_PIDFILE} -- \
+ --pid-file ${DISTCCD_PIDFILE} -N ${DISTCCD_NICE} --user distcc \
+ ${DISTCCD_OPTS}
+
+ eend $?
+}
+
+stop() {
+ ebegin "Stopping distccd"
+ start-stop-daemon --stop --quiet --pidfile "${DISTCCD_PIDFILE}"
+ rm -f "${DISTCCD_PIDFILE}"
+ eend $?
+}
+
diff --git a/sys-devel/distcc/files/digest-distcc-2.18 b/sys-devel/distcc/files/digest-distcc-2.18
new file mode 100644
index 000000000000..a3d04bc07f68
--- /dev/null
+++ b/sys-devel/distcc/files/digest-distcc-2.18
@@ -0,0 +1 @@
+MD5 a55b547d4ff62d8500e290b82671db50 distcc-2.18.tar.bz2 339939