summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMark Loeser <halcy0n@gentoo.org>2006-01-14 01:42:17 +0000
committerMark Loeser <halcy0n@gentoo.org>2006-01-14 01:42:17 +0000
commit5e8e2e09bcb92ffb718bf2da58d7f08966f4ab2f (patch)
treebf82f70dd2409f70138940305b786a5799552423 /sys-devel/gcc/gcc-3.4.3.20050110-r2.ebuild
parentsh love (diff)
downloadhistorical-5e8e2e09bcb92ffb718bf2da58d7f08966f4ab2f.tar.gz
historical-5e8e2e09bcb92ffb718bf2da58d7f08966f4ab2f.tar.bz2
historical-5e8e2e09bcb92ffb718bf2da58d7f08966f4ab2f.zip
Adding new gcc-4.1 snapshot, and cleaning up old versions
Package-Manager: paludis-0.1.0 svn 68:104M/
Diffstat (limited to 'sys-devel/gcc/gcc-3.4.3.20050110-r2.ebuild')
-rw-r--r--sys-devel/gcc/gcc-3.4.3.20050110-r2.ebuild146
1 files changed, 0 insertions, 146 deletions
diff --git a/sys-devel/gcc/gcc-3.4.3.20050110-r2.ebuild b/sys-devel/gcc/gcc-3.4.3.20050110-r2.ebuild
deleted file mode 100644
index 426b7761de9d..000000000000
--- a/sys-devel/gcc/gcc-3.4.3.20050110-r2.ebuild
+++ /dev/null
@@ -1,146 +0,0 @@
-# Copyright 1999-2005 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/gcc/gcc-3.4.3.20050110-r2.ebuild,v 1.12 2005/10/16 08:00:37 vapier Exp $
-
-MAN_VER="3.4.3"
-PATCH_VER="2.0"
-UCLIBC_VER="1.1"
-PIE_VER="8.7.7"
-PIE_CORE="gcc-3.4.3-piepatches-v${PIE_VER}.tar.bz2"
-PP_VER="3.4.3.20050110"
-PP_FVER="${PP_VER//_/.}-0"
-HTB_VER="1.00"
-HTB_EXCLUSIVE="true"
-
-GCC_LIBSSP_SUPPORT="true"
-
-ETYPE="gcc-compiler"
-
-# Punt redhat patch #87631
-GENTOO_PATCH_EXCLUDE="08_all_gcc34-chk.patch"
-
-# arch/libc configurations known to be stable with {PIE,SSP}-by-default
-SSP_STABLE="x86 sparc amd64 ppc ppc64"
-SSP_UCLIBC_STABLE="arm mips ppc x86"
-PIE_GLIBC_STABLE="x86 sparc amd64 ppc ppc64"
-PIE_UCLIBC_STABLE="x86 mips ppc"
-
-# arch/libc configurations known to be broken with {PIE,SSP}-by-default
-SSP_UNSUPPORTED="hppa"
-SSP_UCLIBC_UNSUPPORTED="${SSP_UNSUPPORTED}"
-PIE_UCLIBC_UNSUPPORTED="alpha amd64 arm hppa ia64 m68k ppc64 s390 sh sparc"
-PIE_GLIBC_UNSUPPORTED="hppa"
-
-# whether we should split out specs files for multiple {PIE,SSP}-by-default
-# and vanilla configurations.
-SPLIT_SPECS=${SPLIT_SPECS-true}
-
-#GENTOO_PATCH_EXCLUDE=""
-#PIEPATCH_EXCLUDE=""
-
-inherit toolchain eutils
-
-DESCRIPTION="The GNU Compiler Collection. Includes C/C++, java compilers, pie+ssp extensions, Haj Ten Brugge runtime bounds checking"
-
-KEYWORDS="-* ~amd64 -hppa ~ia64 mips ~ppc ~ppc64 ~sparc ~x86"
-
-# we need a proper glibc version for the Scrt1.o provided to the pie-ssp specs
-# NOTE: we SHOULD be using at least binutils 2.15.90.0.1 everywhere for proper
-# .eh_frame ld optimisation and symbol visibility support, but it hasnt been
-# well tested in gentoo on any arch other than amd64!!
-RDEPEND="virtual/libc
- || ( app-admin/eselect-compiler >=sys-devel/gcc-config-1.3.10 )
- >=sys-libs/zlib-1.1.4
- !sys-devel/hardened-gcc
- amd64? ( multilib? ( >=app-emulation/emul-linux-x86-glibc-1.1 ) )
- !build? (
- gcj? (
- gtk? ( >=x11-libs/gtk+-2.2 )
- >=media-libs/libart_lgpl-2.1
- )
- >=sys-libs/ncurses-5.2-r2
- nls? ( sys-devel/gettext )
- )"
-
-if [[ ${CATEGORY/cross-} != ${CATEGORY} ]]; then
- RDEPEND="${RDEPEND} ${CATEGORY}/binutils"
-fi
-
-DEPEND="${RDEPEND}
- >=sys-apps/texinfo-4.2-r4
- >=sys-devel/bison-1.875
- >=sys-devel/binutils-2.14.90.0.8-r1
- amd64? ( >=sys-devel/binutils-2.15.90.0.1.1-r1 )"
-PDEPEND="|| ( app-admin/eselect-compiler sys-devel/gcc-config )
- !nocxx? ( !mips? ( !ia64? ( !elibc_uclibc? ( !build? ( sys-libs/libstdc++-v3 ) ) ) ) )"
-
-src_unpack() {
- gcc_src_unpack
-
- # bah
- sed -e 's/3\.4\.4/3.4.3/' -i ${S}/gcc/version.c
-
- # misc patches that havent made it into a patch tarball yet
- [[ ${CHOST} == ${CTARGET} ]] && epatch "${FILESDIR}"/gcc-spec-env.patch
-
- # nothing in the tree provides libssp.so, so nothing will ever trigger this
- # logic, but having the patch in the tree makes life so much easier for me
- # since I dont have to also have an overlay for this.
- want_libssp && epatch ${FILESDIR}/3.4.3/libssp.patch
-
- # Anything useful and objc will require libffi. Seriously. Lets just force
- # libffi to install with USE="objc", even though it normally only installs
- # if you attempt to build gcj.
- if use !build && use objc && ! use gcj ; then
- epatch ${FILESDIR}/3.4.3/libffi-without-libgcj.patch
- #epatch ${FILESDIR}/3.4.3/libffi-nogcj-lib-path-fix.patch
- fi
-
- # hack around some ugly 32bit sse2 wrong-code bugs
- epatch ${FILESDIR}/3.4.2/gcc34-m32-no-sse2.patch
- epatch ${FILESDIR}/3.4.2/gcc34-fix-sse2_pinsrw.patch
-
- # Fix cross-compiling
- epatch ${FILESDIR}/3.4.3/gcc-3.4.3-cross-compile.patch
-
- # Arch stuff
- case $(tc-arch) in
- mips)
- # If mips, and we DON'T want multilib, then rig gcc to only use n32 OR n64
- if ! is_multilib; then
- use n32 && epatch ${FILESDIR}/3.4.1/gcc-3.4.1-mips-n32only.patch
- use n64 && epatch ${FILESDIR}/3.4.1/gcc-3.4.1-mips-n64only.patch
- fi
-
- # Patch forward-ported from a gcc-3.0.x patch that adds -march=r10000 and
- # -mtune=r10000 support to gcc (Allows the compiler to generate code to
- # take advantage of R10k's second ALU, perform shifts, etc..
- #
- # Needs re-porting to DFA in gcc-4.0 - Any Volunteers? :)
- epatch ${FILESDIR}/3.4.2/gcc-3.4.x-mips-add-march-r10k.patch
-
- # This is a very special patch -- it allows us to build semi-usable kernels
- # on SGI IP28 (Indigo2 Impact R10000) systems. The patch is henceforth
- # regarded as a kludge by upstream, and thus, it will never get accepted upstream,
- # but for our purposes of building a kernel, it works.
- # Unless you're building an IP28 kernel, you really don't need care about what
- # this patch does, because if you are, you are probably already aware of what
- # it does.
- # All that said, the abilities of this patch are disabled by default and need
- # to be enabled by passing -mip28-cache-barrier. Only used to build kernels,
- # There is the possibility it may be used for very specific userland apps too.
- if use ip28; then
- epatch ${FILESDIR}/3.4.2/gcc-3.4.2-mips-ip28_cache_barriers-v2.patch
- fi
- ;;
- amd64)
- if is_multilib; then
- epatch ${FILESDIR}/3.4.1/gcc-3.4.1-glibc-is-native.patch
- cd ${S}/libstdc++-v3
- einfo "running autoreconf..."
- autoreconf 2> /dev/null
- cd ${S}
- fi
- ;;
- esac
-}