summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2004-06-07 16:50:18 +0000
committerMike Frysinger <vapier@gentoo.org>2004-06-07 16:50:18 +0000
commitb368525367aaeb28c6a5420e7f856d3215f8abb7 (patch)
tree0b6c0f0a49c392fb04dbde11e34dea9da2f12b2e /sys-devel/libperl
parentdont detect commented notrust lines (diff)
downloadhistorical-b368525367aaeb28c6a5420e7f856d3215f8abb7.tar.gz
historical-b368525367aaeb28c6a5420e7f856d3215f8abb7.tar.bz2
historical-b368525367aaeb28c6a5420e7f856d3215f8abb7.zip
move to ~ppc
Diffstat (limited to 'sys-devel/libperl')
-rw-r--r--sys-devel/libperl/Manifest22
-rw-r--r--sys-devel/libperl/libperl-5.8.4.ebuild20
2 files changed, 25 insertions, 17 deletions
diff --git a/sys-devel/libperl/Manifest b/sys-devel/libperl/Manifest
index fd712b360a76..09af240af5a5 100644
--- a/sys-devel/libperl/Manifest
+++ b/sys-devel/libperl/Manifest
@@ -1,11 +1,21 @@
+-----BEGIN PGP SIGNED MESSAGE-----
+Hash: SHA1
+
+MD5 1469ca3fca2ba05da23efdbb7101273f ChangeLog 3990
+MD5 6fdd466a33637a39199ec8cd0a4e2302 libperl-5.8.4.ebuild 10821
MD5 c70aa9525be96a22398fbc7a1425cfb3 libperl-5.8.3.ebuild 10868
MD5 f26389d2c42ee51afc479cfd659c5582 libperl-5.8.2.ebuild 10848
-MD5 1469ca3fca2ba05da23efdbb7101273f ChangeLog 3990
MD5 e2d8f1bf77722def1dd432e26455c818 metadata.xml 305
-MD5 c2c7a014396f7f75c33348750d1de2f8 libperl-5.8.4.ebuild 10878
-MD5 0bdca74363c218d91a0db4ad1ea55485 files/libperl-5.8.3-create-libperl-soname.patch 417
-MD5 0bdca74363c218d91a0db4ad1ea55485 files/libperl-5.8.2-create-libperl-soname.patch 417
-MD5 8381e239056a7895edf8f3c6c05c835c files/digest-libperl-5.8.2 64
-MD5 35eb3b7645102bbcc4088d900dc28984 files/digest-libperl-5.8.3 64
MD5 93155b02a7e9d3cdc6d6934ce78d9f11 files/digest-libperl-5.8.4 64
+MD5 35eb3b7645102bbcc4088d900dc28984 files/digest-libperl-5.8.3 64
+MD5 8381e239056a7895edf8f3c6c05c835c files/digest-libperl-5.8.2 64
MD5 0bdca74363c218d91a0db4ad1ea55485 files/libperl-5.8.4-create-libperl-soname.patch 417
+MD5 0bdca74363c218d91a0db4ad1ea55485 files/libperl-5.8.2-create-libperl-soname.patch 417
+MD5 0bdca74363c218d91a0db4ad1ea55485 files/libperl-5.8.3-create-libperl-soname.patch 417
+-----BEGIN PGP SIGNATURE-----
+Version: GnuPG v1.9.8 (GNU/Linux)
+
+iD8DBQFAxJzQHTu7gpaalycRAi1wAJ93oWgHKtfDfET+G0Z9ZzF6B6nJSACg4Kv+
+IOtIV10xJ7bg/4tWE+0KNTU=
+=i4Ba
+-----END PGP SIGNATURE-----
diff --git a/sys-devel/libperl/libperl-5.8.4.ebuild b/sys-devel/libperl/libperl-5.8.4.ebuild
index 237c286c7ea9..c583aa77af53 100644
--- a/sys-devel/libperl/libperl-5.8.4.ebuild
+++ b/sys-devel/libperl/libperl-5.8.4.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/libperl/libperl-5.8.4.ebuild,v 1.5 2004/06/02 05:02:51 lv Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/libperl/libperl-5.8.4.ebuild,v 1.6 2004/06/07 16:50:18 vapier Exp $
# The basic theory based on comments from Daniel Robbins <drobbins@gentoo.org>.
#
@@ -82,7 +82,7 @@ fi
LIBPERL="libperl.so.${PERLSLOT}.${SHORT_PV}"
LICENSE="Artistic GPL-2"
-KEYWORDS="~x86 -ppc ~sparc ~mips ~alpha ~arm ~hppa amd64 ~ia64 ~ppc64 s390"
+KEYWORDS="~x86 ~ppc ~sparc ~mips ~alpha ~arm ~hppa amd64 ~ia64 ~ppc64 s390"
DEPEND="sys-apps/groff
berkdb? ( sys-libs/db )
@@ -98,7 +98,7 @@ PDEPEND=">=dev-lang/perl-${PV}"
pkg_setup() {
# I think this should rather be displayed if you *have* 'threads'
# in USE if it could break things ...
- if [ -n "`use threads`" ]
+ if use threads
then
ewarn ""
ewarn "PLEASE NOTE: You are compiling perl-5.8 with"
@@ -142,7 +142,7 @@ src_compile() {
export LC_ALL="C"
local myconf=""
- if [ "`use threads`" ]
+ if use threads
then
einfo "using threads"
mythreading="-multi"
@@ -152,28 +152,28 @@ src_compile() {
myarch="${CHOST%%-*}-linux"
fi
- if [ "`use gdbm`" ]
+ if use gdbm
then
myconf="${myconf} -Di_gdbm"
fi
- if [ "`use berkdb`" ]
+ if use berkdb
then
myconf="${myconf} -Di_db -Di_ndbm"
else
myconf="${myconf} -Ui_db -Ui_ndbm"
fi
- if [ "`use mips`" ]
+ if use mips
then
# this is needed because gcc 3.3-compiled kernels will hang
# the machine trying to run this test - check with `Kumba
# <rac@gentoo.org> 2003.06.26
myconf="${myconf} -Dd_u32align"
fi
- if [ "`use sparc`" ]
+ if use sparc
then
myconf="${myconf} -Ud_longdbl"
fi
- if [ "`use sparc64`" ]
+ if use sparc64
then
myconf="${myconf} -Ud_longdbl"
fi
@@ -374,5 +374,3 @@ pkg_postinst() {
fi
fi
}
-
-