summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorZack Welch <zwelch@gentoo.org>2003-05-30 09:23:58 +0000
committerZack Welch <zwelch@gentoo.org>2003-05-30 09:23:58 +0000
commit6f0c9b5c83233957e43d7da3183ba0a60495ee3c (patch)
treec2076ac79a024107bc3a8cc1ce2de062e625923e /sys-devel
parentfix to smooth DISTCC_HOSTS upgrades (diff)
downloadhistorical-6f0c9b5c83233957e43d7da3183ba0a60495ee3c.tar.gz
historical-6f0c9b5c83233957e43d7da3183ba0a60495ee3c.tar.bz2
historical-6f0c9b5c83233957e43d7da3183ba0a60495ee3c.zip
fix to smooth DISTCC_HOSTS upgrades
Diffstat (limited to 'sys-devel')
-rw-r--r--sys-devel/distcc/Manifest6
-rw-r--r--sys-devel/distcc/distcc-2.5-r1.ebuild109
-rw-r--r--sys-devel/distcc/files/2.3/distcc-config6
-rw-r--r--sys-devel/distcc/files/digest-distcc-2.5-r11
4 files changed, 116 insertions, 6 deletions
diff --git a/sys-devel/distcc/Manifest b/sys-devel/distcc/Manifest
index ecd049389fd6..56d48f87ca34 100644
--- a/sys-devel/distcc/Manifest
+++ b/sys-devel/distcc/Manifest
@@ -1,11 +1,11 @@
-MD5 39c61763d090239991c94e6f5a3a6b7c ChangeLog 396
+MD5 c2f5ed87e0774f9510e75b25675a07c8 ChangeLog 602
MD5 960b9f9b17b8f9dd99094d162362dd1b distcc-2.0.1-r1.ebuild 2892
MD5 da890f4d3d7a6c3cb65ad47f80feff6a distcc-2.0.1.ebuild 2895
MD5 8df905f30d3f4bce8c31534396b66ec8 distcc-2.3.ebuild 2691
MD5 c242a8c0ff4035a2c6a3ee0545691aed distcc-2.4.ebuild 2702
MD5 3bc5a82158ff39298b4b80134999ddde distcc-2.4.2.ebuild 2703
MD5 c958bfeb956960d4b15ebab2df7a6d86 distcc-2.5.ebuild 2702
-MD5 a91eabd2d6fb1ab70cdce1d5a7ab5819 distcc-2.5-r1.ebuild 3163
+MD5 fab89eae22993f7c8a9db2e174684bc2 distcc-2.5-r1.ebuild 3166
MD5 372827ac4fc6b9dae1d585934369ce8e distcc-1.2.3-r3.ebuild 2882
MD5 9a3a39b4f229559e6a855d777c6fe807 files/digest-distcc-2.0.1-r1 65
MD5 8aa55227d128b8ff22a8caf5d47db89c files/digest-distcc-2.3 63
@@ -18,6 +18,6 @@ MD5 9a3a39b4f229559e6a855d777c6fe807 files/digest-distcc-2.0.1 65
MD5 6bc82bf32667e5398497b2dae88f1033 files/1.2.3/wrapper.patch 5242
MD5 22c6ce6c5fde53bc04590015d9d82e50 files/1.2.3/distcc-config 6858
MD5 d4fd07d7d3d3e3952baef8c654d2715f files/1.2.3/info.patch 545
-MD5 41a5480f90d910ab92196580d849e437 files/2.3/distcc-config 7389
+MD5 785e2966bd49522fd593e9f92e926c46 files/2.3/distcc-config 7389
MD5 3783a1abcbd33bc1d24e14012edeb696 files/1.2/init 484
MD5 34d20e7bf223ac2f2ec61c5a7a9b2e3c files/1.2/conf 314
diff --git a/sys-devel/distcc/distcc-2.5-r1.ebuild b/sys-devel/distcc/distcc-2.5-r1.ebuild
new file mode 100644
index 000000000000..15d77fb6e771
--- /dev/null
+++ b/sys-devel/distcc/distcc-2.5-r1.ebuild
@@ -0,0 +1,109 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/distcc/distcc-2.5-r1.ebuild,v 1.1 2003/05/30 09:23:56 zwelch Exp $
+
+inherit eutils
+
+IUSE=""
+
+HOMEPAGE="http://distcc.samba.org/"
+SRC_URI="http://distcc.samba.org/ftp/distcc/distcc-${PV}.tar.bz2"
+DESCRIPTION="a program to distribute compilation of C code across several machines on a network"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86 ~ppc ~sparc ~alpha ~hppa ~mips ~arm"
+
+OPV="1.2"
+LPV="2.3"
+
+DEPEND=">=sys-apps/portage-2.0.46-r11
+ >=sys-devel/gcc-config-1.3.1
+ sys-apps/shadow
+ dev-libs/popt"
+
+src_compile() {
+ econf || die "econf failed"
+ emake || die "emake failed"
+}
+
+src_install() {
+ make DESTDIR="${D%/}" install
+
+ insinto /usr/share/doc/${PN}
+ doins "${S}/survey.txt"
+
+ exeinto /usr/bin
+ doexe "${FILESDIR}/${LPV}/distcc-config"
+
+ insinto /etc/conf.d
+ newins "${FILESDIR}/${OPV}/conf" distccd
+
+ exeinto /etc/init.d
+ newexe "${FILESDIR}/${OPV}/init" distccd
+
+ # create and keep the symlink dir
+ dodir /usr/lib/distcc/bin
+ keepdir /usr/lib/distcc/bin
+
+ # create the distccd pid directory
+ dodir /var/run/distccd
+ keepdir /var/run/distccd
+}
+
+pkg_preinst() {
+ # non-/ installs don't require us to do anything here
+ [ "${ROOT}" != "/" ] && return 0
+
+ # stop daemon since script is being updated
+ [ -n "$(pidof distccd)" -a -x /etc/init.d/distccd ] && \
+ /etc/init.d/distccd stop
+
+ # moved user creation and permissions to distcc-config script
+ # because of ROOT install requirements
+}
+
+pkg_postinst() {
+ # handle DISTCC_HOSTS upgrade better
+ local ENVFILE
+ ENVFILE="${ROOT}etc/env.d/02distcc"
+ [ ! -f "${ENVFILE}" ] && \
+ ENVFILE="${ROOT}etc/env.d/04distcc"
+ if [ -f "${ENVFILE}" ]
+ then
+ # save hosts to new file
+ ROOT="${ROOT}" ${ROOT}usr/bin/distcc-config --set-hosts \
+ $(egrep '^DISTCC_HOSTS' "${ENVFILE}" | sed 's,[^=]*=,,')
+ # now remove from the file
+ grep -v 'DISTCC_HOSTS' "${ENVFILE}" > "${ENVFILE}.new"
+ mv "${ENVFILE}.new" "${ENVFILE}"
+ fi
+
+ if [ "${ROOT}" = "/" ]; then
+ einfo "Installing links to native compilers..."
+ /usr/bin/distcc-config --install-user
+ /usr/bin/distcc-config --install-links
+ /usr/bin/distcc-config --install-links "${CHOST}"
+ else
+ # distcc-config can *almost* handle ROOT installs itself
+ # but for now, but user must finsh things off
+ ewarn "*** Installation is not complete ***"
+ ewarn "You must run the following as root:"
+ ewarn " /usr/bin/distcc-config --install"
+ ewarn "after booting or chrooting into ${ROOT}"
+ fi
+ einfo "To use distcc with **non-Portage** C compiling, add"
+ einfo "/usr/lib/distcc/bin to your path before /usr/bin. If you're"
+ einfo "combining this with ccache, put the ccache path BEFORE distcc."
+ einfo "Portage 2.0.46-r11+ will take advantage of distcc if you put"
+ einfo "distcc into the FEATURES setting in make.conf and use"
+ einfo "distcc-config --set-hosts. Do NOT set CC=distcc or similar."
+ ewarn "See http://cvs.gentoo.org/~zwelch/distcc.html for information."
+}
+
+#pkg_prerm() {
+# # ztw - not sure if this is the right place
+# distcc-config --remove-links "${CHOST}"
+# distcc-config --remove-links
+#}
+
diff --git a/sys-devel/distcc/files/2.3/distcc-config b/sys-devel/distcc/files/2.3/distcc-config
index 4ca40100953d..61230714b366 100644
--- a/sys-devel/distcc/files/2.3/distcc-config
+++ b/sys-devel/distcc/files/2.3/distcc-config
@@ -8,7 +8,7 @@
# This script developed by Zachary T Welch at Superlucidity Services, LLC
# based on ideas from irc discussion and the clear need for this support
#
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/distcc/files/2.3/distcc-config,v 1.1 2003/05/21 10:15:09 zwelch Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/distcc/files/2.3/distcc-config,v 1.2 2003/05/30 09:23:56 zwelch Exp $
[ -z "${ROOT}" ] && ROOT=/
@@ -36,8 +36,8 @@ dccc_exit() {
# create the appropriate configuration directory
is_super_user && \
- DCCC_HOSTS_FILE="/etc/distcc/hosts" || \
- DCCC_HOSTS_FILE="${HOME}/.distcc/hosts"
+ DCCC_HOSTS_FILE="${ROOT}etc/distcc/hosts" || \
+ DCCC_HOSTS_FILE="${ROOT}${HOME#/}/.distcc/hosts"
mkdir -p $(dirname ${DCCC_HOSTS_FILE}) || \
dccc_exit "unable to create configuration directory"
diff --git a/sys-devel/distcc/files/digest-distcc-2.5-r1 b/sys-devel/distcc/files/digest-distcc-2.5-r1
new file mode 100644
index 000000000000..b14915b69443
--- /dev/null
+++ b/sys-devel/distcc/files/digest-distcc-2.5-r1
@@ -0,0 +1 @@
+MD5 b0b6a34fa5a30bfa7f6853f477f7772f distcc-2.5.tar.bz2 220088