summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2010-07-25 14:36:05 +0000
committerMike Frysinger <vapier@gentoo.org>2010-07-25 14:36:05 +0000
commit97e943ab58828143364deaa28cc257a85a5f2e90 (patch)
treed2e56912eb13edae3250f7b9d30c13df8c6bebc2 /sys-devel
parentmove documentation to the patch (diff)
downloadhistorical-97e943ab58828143364deaa28cc257a85a5f2e90.tar.gz
historical-97e943ab58828143364deaa28cc257a85a5f2e90.tar.bz2
historical-97e943ab58828143364deaa28cc257a85a5f2e90.zip
Add change from upstream for recursion test #329153 by Kent Fredric.
Package-Manager: portage-2.2_rc67/cvs/Linux x86_64
Diffstat (limited to 'sys-devel')
-rw-r--r--sys-devel/make/ChangeLog6
-rw-r--r--sys-devel/make/files/make-3.81-tests-recursion.patch14
-rw-r--r--sys-devel/make/make-3.81-r2.ebuild6
3 files changed, 22 insertions, 4 deletions
diff --git a/sys-devel/make/ChangeLog b/sys-devel/make/ChangeLog
index 578fd70ed9a1..21ff67ce1388 100644
--- a/sys-devel/make/ChangeLog
+++ b/sys-devel/make/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for sys-devel/make
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/make/ChangeLog,v 1.63 2010/03/31 22:42:05 robbat2 Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/make/ChangeLog,v 1.64 2010/07/25 14:36:05 vapier Exp $
+
+ 25 Jul 2010; Mike Frysinger <vapier@gentoo.org> make-3.81-r2.ebuild,
+ +files/make-3.81-tests-recursion.patch:
+ Add change from upstream for recursion test #329153 by Kent Fredric.
*make-3.81-r2 (31 Mar 2010)
diff --git a/sys-devel/make/files/make-3.81-tests-recursion.patch b/sys-devel/make/files/make-3.81-tests-recursion.patch
new file mode 100644
index 000000000000..490e2a912cd8
--- /dev/null
+++ b/sys-devel/make/files/make-3.81-tests-recursion.patch
@@ -0,0 +1,14 @@
+http://bugs.gentoo.org/329153
+https://savannah.gnu.org/bugs/index.php?29968
+
+--- tests/scripts/features/recursion 2005/02/10 00:10:58 1.2
++++ tests/scripts/features/recursion 2010/07/01 07:16:00 1.3
+@@ -16,7 +16,7 @@
+ @echo MAKELEVEL = $(MAKELEVEL)
+ @echo THE END
+ ',
+- ('CFLAGS=-O -w' . ($parallel_jobs ? '-j 2' : '')),
++ ('CFLAGS=-O -w' . ($parallel_jobs ? ' -j 2' : '')),
+ ($vos
+ ? "#MAKE#: Entering directory `#PWD#'
+ make 'CFLAGS=-O' -f #MAKEFILE# foo
diff --git a/sys-devel/make/make-3.81-r2.ebuild b/sys-devel/make/make-3.81-r2.ebuild
index 54490775ebf3..737d030ea446 100644
--- a/sys-devel/make/make-3.81-r2.ebuild
+++ b/sys-devel/make/make-3.81-r2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/make/make-3.81-r2.ebuild,v 1.2 2010/04/01 01:28:31 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/make/make-3.81-r2.ebuild,v 1.3 2010/07/25 14:36:05 vapier Exp $
inherit flag-o-matic
@@ -21,8 +21,8 @@ src_unpack() {
cd "${S}"
epatch "${FILESDIR}"/${P}-tests-lang.patch
epatch "${FILESDIR}"/${P}-long-cmdline.patch #301116
- # related to bug #193258, but this is the final patch that Fedora went with.
- epatch "${FILESDIR}"/${P}-jobserver.patch
+ epatch "${FILESDIR}"/${P}-tests-recursion.patch #329153
+ epatch "${FILESDIR}"/${P}-jobserver.patch #193258
}
src_compile() {