summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2004-10-28 15:57:16 +0000
committerMike Frysinger <vapier@gentoo.org>2004-10-28 15:57:16 +0000
commitb01b7b522574319faa5c5085e8f9bf2b7274a94c (patch)
treea0363260c45d3c5ba5822a7c6d85ba6b5da47058 /sys-devel
parentMake sure all of kde_src_compile is called - see bug #68303 (diff)
downloadhistorical-b01b7b522574319faa5c5085e8f9bf2b7274a94c.tar.gz
historical-b01b7b522574319faa5c5085e8f9bf2b7274a94c.tar.bz2
historical-b01b7b522574319faa5c5085e8f9bf2b7274a94c.zip
use tc-getCC
Diffstat (limited to 'sys-devel')
-rw-r--r--sys-devel/gcc-config/gcc-config-1.3.6-r3.ebuild6
-rw-r--r--sys-devel/gcc-config/gcc-config-1.3.7-r1.ebuild6
-rw-r--r--sys-devel/gettext/gettext-0.12.1-r2.ebuild7
-rw-r--r--sys-devel/gettext/gettext-0.14.1.ebuild6
4 files changed, 15 insertions, 10 deletions
diff --git a/sys-devel/gcc-config/gcc-config-1.3.6-r3.ebuild b/sys-devel/gcc-config/gcc-config-1.3.6-r3.ebuild
index d4d3890c40e9..b22562887ce4 100644
--- a/sys-devel/gcc-config/gcc-config-1.3.6-r3.ebuild
+++ b/sys-devel/gcc-config/gcc-config-1.3.6-r3.ebuild
@@ -1,6 +1,8 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/gcc-config/gcc-config-1.3.6-r3.ebuild,v 1.3 2004/10/13 13:34:25 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/gcc-config/gcc-config-1.3.6-r3.ebuild,v 1.4 2004/10/28 15:53:08 vapier Exp $
+
+inherit toolchain-funcs
# Version of .c wrapper to use
W_VER="1.4.2"
@@ -43,7 +45,7 @@ src_install() {
fi
einfo "Compiling wrapper..."
- ${CC:-gcc} -O2 -Wall -o ${WORKDIR}/wrapper \
+ $(tc-getCC) -O2 -Wall -o ${WORKDIR}/wrapper \
${FILESDIR}/wrapper-${W_VER}.c || die
exeinto /usr/lib/gcc-config
diff --git a/sys-devel/gcc-config/gcc-config-1.3.7-r1.ebuild b/sys-devel/gcc-config/gcc-config-1.3.7-r1.ebuild
index a58d1dafd74c..c1d3e25e21d8 100644
--- a/sys-devel/gcc-config/gcc-config-1.3.7-r1.ebuild
+++ b/sys-devel/gcc-config/gcc-config-1.3.7-r1.ebuild
@@ -1,6 +1,8 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/gcc-config/gcc-config-1.3.7-r1.ebuild,v 1.1 2004/10/26 03:14:01 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/gcc-config/gcc-config-1.3.7-r1.ebuild,v 1.2 2004/10/28 15:53:08 vapier Exp $
+
+inherit toolchain-funcs
# Version of .c wrapper to use
W_VER="1.4.2"
@@ -28,7 +30,7 @@ src_install() {
export PATH="${D}/usr/bin:${PATH}"
einfo "Compiling wrapper..."
- ${CC:-gcc} -O2 -Wall -o ${WORKDIR}/wrapper \
+ $(tc-getCC) -O2 -Wall -o ${WORKDIR}/wrapper \
${FILESDIR}/wrapper-${W_VER}.c || die
exeinto /usr/lib/gcc-config
diff --git a/sys-devel/gettext/gettext-0.12.1-r2.ebuild b/sys-devel/gettext/gettext-0.12.1-r2.ebuild
index d86496cf23e7..33b0b53df499 100644
--- a/sys-devel/gettext/gettext-0.12.1-r2.ebuild
+++ b/sys-devel/gettext/gettext-0.12.1-r2.ebuild
@@ -1,8 +1,8 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/gettext/gettext-0.12.1-r2.ebuild,v 1.10 2004/10/28 15:55:13 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/gettext/gettext-0.12.1-r2.ebuild,v 1.11 2004/10/28 15:57:16 vapier Exp $
-inherit eutils gnuconfig
+inherit eutils gnuconfig toolchain-funcs
DESCRIPTION="GNU locale utilities"
HOMEPAGE="http://www.gnu.org/software/gettext/gettext.html"
@@ -45,7 +45,8 @@ src_compile() {
# need preloadable_libintl.so for new help2man, bug #40162.
# Also note that it only gets build with USE=nls ...
# Lastly, we need to build without --disable-shared ...
- CXX=${CC} econf \
+ CXX=$(tc-getCC) \
+ econf \
--without-included-gettext \
${myconf} || die
diff --git a/sys-devel/gettext/gettext-0.14.1.ebuild b/sys-devel/gettext/gettext-0.14.1.ebuild
index 8c8dbdee5b5c..9eba89d6e532 100644
--- a/sys-devel/gettext/gettext-0.14.1.ebuild
+++ b/sys-devel/gettext/gettext-0.14.1.ebuild
@@ -1,8 +1,8 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/gettext/gettext-0.14.1.ebuild,v 1.10 2004/10/07 23:51:46 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/gettext/gettext-0.14.1.ebuild,v 1.11 2004/10/28 15:57:16 vapier Exp $
-inherit eutils gnuconfig gcc mono
+inherit eutils gnuconfig toolchain-funcs mono
DESCRIPTION="GNU locale utilities"
HOMEPAGE="http://www.gnu.org/software/gettext/gettext.html"
@@ -44,7 +44,7 @@ src_compile() {
# need preloadable_libintl.so for new help2man, bug #40162.
# Also note that it only gets build with USE=nls ...
# Lastly, we need to build without --disable-shared ...
- CXX=$(gcc-getCC) \
+ CXX=$(tc-getCC) \
econf \
--without-included-gettext \
$(use_enable nls) \