summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2013-06-18 23:14:42 +0000
committerAlexis Ballier <aballier@gentoo.org>2013-06-18 23:14:42 +0000
commit7131ae3f274bc1cdf1a67435c9c9a9fe57a8ee3b (patch)
tree3d123882b268f22139a543031952374be79af188 /sys-freebsd/boot0/boot0-9.1.ebuild
parentremove freebsd-8.0 profiles (diff)
downloadhistorical-7131ae3f274bc1cdf1a67435c9c9a9fe57a8ee3b.tar.gz
historical-7131ae3f274bc1cdf1a67435c9c9a9fe57a8ee3b.tar.bz2
historical-7131ae3f274bc1cdf1a67435c9c9a9fe57a8ee3b.zip
Build libstand here so that we can drop it from freebsd-lib.
Package-Manager: portage-2.2.0_alpha180/cvs/Linux x86_64 Manifest-Sign-Key: 0x160F534A
Diffstat (limited to 'sys-freebsd/boot0/boot0-9.1.ebuild')
-rw-r--r--sys-freebsd/boot0/boot0-9.1.ebuild10
1 files changed, 9 insertions, 1 deletions
diff --git a/sys-freebsd/boot0/boot0-9.1.ebuild b/sys-freebsd/boot0/boot0-9.1.ebuild
index 26caeb75626e..dcfb6d9d5a5d 100644
--- a/sys-freebsd/boot0/boot0-9.1.ebuild
+++ b/sys-freebsd/boot0/boot0-9.1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-freebsd/boot0/boot0-9.1.ebuild,v 1.1 2013/01/27 21:23:47 aballier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-freebsd/boot0/boot0-9.1.ebuild,v 1.2 2013/06/18 23:14:29 aballier Exp $
EAPI=2
@@ -44,6 +44,14 @@ src_prepare() {
src_compile() {
strip-flags
append-flags "-fno-strict-aliasing"
+
+ cd "${WORKDIR}/lib/libstand" || die
+ freebsd_src_compile
+
+ cd "${S}"
+ CFLAGS="${CFLAGS} -I${WORKDIR}/lib/libstand"
+ LDFLAGS="${LDFLAGS} -L${WORKDIR}/lib/libstand"
+ export LIBSTAND="${WORKDIR}/lib/libstand/libstand.a"
NOFLAGSTRIP="yes" freebsd_src_compile
}