summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2004-10-03 10:29:12 +0000
committerMike Frysinger <vapier@gentoo.org>2004-10-03 10:29:12 +0000
commite7b409c1bbeb301e205918dc0e41c34178772ceb (patch)
treea0454009671360b42ea8f5d6c0f79a28ee9cdd37 /sys-fs/quota/quota-3.12.ebuild
parentmove quota stuff from sys-apps to sys-fs (diff)
downloadhistorical-e7b409c1bbeb301e205918dc0e41c34178772ceb.tar.gz
historical-e7b409c1bbeb301e205918dc0e41c34178772ceb.tar.bz2
historical-e7b409c1bbeb301e205918dc0e41c34178772ceb.zip
move from sys-apps
Diffstat (limited to 'sys-fs/quota/quota-3.12.ebuild')
-rw-r--r--sys-fs/quota/quota-3.12.ebuild55
1 files changed, 55 insertions, 0 deletions
diff --git a/sys-fs/quota/quota-3.12.ebuild b/sys-fs/quota/quota-3.12.ebuild
new file mode 100644
index 000000000000..c6be2604072f
--- /dev/null
+++ b/sys-fs/quota/quota-3.12.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/quota/quota-3.12.ebuild,v 1.1 2004/10/03 10:28:05 vapier Exp $
+
+inherit eutils
+
+DESCRIPTION="Linux quota tools"
+HOMEPAGE="http://sourceforge.net/projects/linuxquota/"
+SRC_URI="mirror://sourceforge/linuxquota/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~mips ~ppc ~sparc ~x86"
+IUSE="nls tcpd"
+
+DEPEND="virtual/libc
+ tcpd? ( sys-apps/tcp-wrappers )"
+
+S=${WORKDIR}/quota-tools
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+
+ # patch to prevent quotactl.2 manpage from being installed
+ # that page is provided by man-pages instead
+ epatch ${FILESDIR}/${PN}-no-quotactl-manpage.patch
+
+ sed -i -e "s:,LIBS=\"\$saved_LIBS=\":;LIBS=\"\$saved_LIBS\":" configure
+}
+
+src_install() {
+ dodir {sbin,etc,usr/sbin,usr/bin,usr/share/man/man{1,3,8}}
+ make ROOTDIR=${D} install || die
+# install -m 644 warnquota.conf ${D}/etc
+ insinto /etc
+ insopts -m0644
+ doins warnquota.conf quotatab
+ dodoc doc/*
+
+ exeinto /etc/init.d
+ newexe ${FILESDIR}/quota.rc6 quota
+
+ # NLS bloat reduction
+ use nls || rm -rf ${D}/usr/share/locale
+}
+
+pkg_postinst() {
+ einfo "with this release, you can configure the used"
+ einfo "ports through /etc/services"
+ einfo
+ einfo "eg. use the default"
+ einfo "rquotad 4003/tcp # quota"
+ einfo "rquotad 4003/udp # quota"
+}