summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2004-01-29 22:59:04 +0000
committerMike Frysinger <vapier@gentoo.org>2004-01-29 22:59:04 +0000
commitfb1498bda64b05e51499e72d1cb2e132772af044 (patch)
tree70969a7e677156b33ef9e64a5c05722635b83a05 /sys-fs/reiserfsprogs
parentmore pixel shaders #39767 (diff)
downloadhistorical-fb1498bda64b05e51499e72d1cb2e132772af044.tar.gz
historical-fb1498bda64b05e51499e72d1cb2e132772af044.tar.bz2
historical-fb1498bda64b05e51499e72d1cb2e132772af044.zip
touchups
Diffstat (limited to 'sys-fs/reiserfsprogs')
-rw-r--r--sys-fs/reiserfsprogs/reiserfsprogs-3.6.10.ebuild17
-rw-r--r--sys-fs/reiserfsprogs/reiserfsprogs-3.6.11-r1.ebuild15
-rw-r--r--sys-fs/reiserfsprogs/reiserfsprogs-3.6.11.ebuild14
-rw-r--r--sys-fs/reiserfsprogs/reiserfsprogs-3.6.3.ebuild13
-rw-r--r--sys-fs/reiserfsprogs/reiserfsprogs-3.6.4-r1.ebuild17
-rw-r--r--sys-fs/reiserfsprogs/reiserfsprogs-3.6.8.ebuild17
-rw-r--r--sys-fs/reiserfsprogs/reiserfsprogs-3.6.9.ebuild15
7 files changed, 43 insertions, 65 deletions
diff --git a/sys-fs/reiserfsprogs/reiserfsprogs-3.6.10.ebuild b/sys-fs/reiserfsprogs/reiserfsprogs-3.6.10.ebuild
index 06f6940d34b5..86de3b6c76d5 100644
--- a/sys-fs/reiserfsprogs/reiserfsprogs-3.6.10.ebuild
+++ b/sys-fs/reiserfsprogs/reiserfsprogs-3.6.10.ebuild
@@ -1,21 +1,19 @@
-# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-fs/reiserfsprogs/reiserfsprogs-3.6.10.ebuild,v 1.2 2003/12/04 23:31:13 plasmaroo Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/reiserfsprogs/reiserfsprogs-3.6.10.ebuild,v 1.3 2004/01/29 22:59:04 vapier Exp $
-inherit flag-o-matic eutils
+inherit flag-o-matic
-filter-flags -fPIC
-
-S=${WORKDIR}/${P}
DESCRIPTION="Reiserfs Utilities"
+HOMEPAGE="http://www.namesys.com/"
SRC_URI="http://www.namesys.com/pub/${PN}/${P}.tar.gz"
-HOMEPAGE="http://www.namesys.com"
-SLOT="0"
LICENSE="GPL-2"
-KEYWORDS="x86 ~amd64 ~ppc ~sparc ~alpha"
+SLOT="0"
+KEYWORDS="x86 ~ppc ~sparc ~alpha ~amd64"
src_compile() {
+ filter-flags -fPIC
./configure --prefix=/ || die "Failed to configure"
emake || die "Failed to compile"
}
@@ -29,4 +27,3 @@ src_install() {
mv man usr/share
dosym /sbin/reiserfsck /sbin/fsck.reiserfs
}
-
diff --git a/sys-fs/reiserfsprogs/reiserfsprogs-3.6.11-r1.ebuild b/sys-fs/reiserfsprogs/reiserfsprogs-3.6.11-r1.ebuild
index ab94cb3f1ed1..1fb9444aa7c6 100644
--- a/sys-fs/reiserfsprogs/reiserfsprogs-3.6.11-r1.ebuild
+++ b/sys-fs/reiserfsprogs/reiserfsprogs-3.6.11-r1.ebuild
@@ -1,18 +1,15 @@
-# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-fs/reiserfsprogs/reiserfsprogs-3.6.11-r1.ebuild,v 1.3 2003/12/28 02:23:04 gmsoft Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/reiserfsprogs/reiserfsprogs-3.6.11-r1.ebuild,v 1.4 2004/01/29 22:59:04 vapier Exp $
inherit flag-o-matic eutils
-filter-flags -fPIC
-
-S=${WORKDIR}/${P}
DESCRIPTION="Reiserfs Utilities"
+HOMEPAGE="http://www.namesys.com/"
SRC_URI="http://www.namesys.com/pub/${PN}/${P}.tar.gz"
-HOMEPAGE="http://www.namesys.com"
-SLOT="0"
LICENSE="GPL-2"
+SLOT="0"
KEYWORDS="ia64 hppa"
src_unpack() {
@@ -22,11 +19,12 @@ src_unpack() {
# to Vitaly Fertman from the Namesys/ReiserFS team for
# this fix. Makes reiserfsck work. (drobbins, 23 Sep 03)
cd ${S}
- patch -p2 < ${FILESDIR}/blk_size.patch || die "blk_size.patch failure"
+ epatch ${FILESDIR}/blk_size.patch
fi
}
src_compile() {
+ filter-flags -fPIC
./configure --prefix=/ || die "Failed to configure"
emake || die "Failed to compile"
}
@@ -40,4 +38,3 @@ src_install() {
mv man usr/share
dosym /sbin/reiserfsck /sbin/fsck.reiserfs
}
-
diff --git a/sys-fs/reiserfsprogs/reiserfsprogs-3.6.11.ebuild b/sys-fs/reiserfsprogs/reiserfsprogs-3.6.11.ebuild
index daeeabd5d969..16bbdf65a1f3 100644
--- a/sys-fs/reiserfsprogs/reiserfsprogs-3.6.11.ebuild
+++ b/sys-fs/reiserfsprogs/reiserfsprogs-3.6.11.ebuild
@@ -1,23 +1,20 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-fs/reiserfsprogs/reiserfsprogs-3.6.11.ebuild,v 1.6 2004/01/09 22:03:31 weeve Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/reiserfsprogs/reiserfsprogs-3.6.11.ebuild,v 1.7 2004/01/29 22:59:04 vapier Exp $
inherit flag-o-matic eutils
-filter-flags -fPIC
-
-S=${WORKDIR}/${P}
DESCRIPTION="Reiserfs Utilities"
+HOMEPAGE="http://www.namesys.com/"
SRC_URI="http://www.namesys.com/pub/${PN}/${P}.tar.gz"
-HOMEPAGE="http://www.namesys.com"
-SLOT="0"
LICENSE="GPL-2"
-KEYWORDS="ia64 x86 ~amd64 ~ppc sparc ~alpha ppc64"
+SLOT="0"
+KEYWORDS="x86 ~ppc sparc ~alpha ~amd64 ia64 ppc64"
src_compile() {
epatch ${FILESDIR}/${P}-2.6.patch
-
+ filter-flags -fPIC
./configure --prefix=/ || die "Failed to configure"
emake || die "Failed to compile"
}
@@ -31,4 +28,3 @@ src_install() {
mv man usr/share
dosym /sbin/reiserfsck /sbin/fsck.reiserfs
}
-
diff --git a/sys-fs/reiserfsprogs/reiserfsprogs-3.6.3.ebuild b/sys-fs/reiserfsprogs/reiserfsprogs-3.6.3.ebuild
index a1d718f6e954..55b60cecd9da 100644
--- a/sys-fs/reiserfsprogs/reiserfsprogs-3.6.3.ebuild
+++ b/sys-fs/reiserfsprogs/reiserfsprogs-3.6.3.ebuild
@@ -1,19 +1,18 @@
-# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-fs/reiserfsprogs/reiserfsprogs-3.6.3.ebuild,v 1.1 2003/09/15 17:46:25 seemant Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/reiserfsprogs/reiserfsprogs-3.6.3.ebuild,v 1.2 2004/01/29 22:59:04 vapier Exp $
-S=${WORKDIR}/${P}
DESCRIPTION="Reiserfs Utilities"
+HOMEPAGE="http://www.namesys.com/"
SRC_URI="http://www.namesys.com/pub/${PN}/${P}.tar.gz"
-HOMEPAGE="http://www.namesys.com"
-KEYWORDS="x86 amd64 ppc sparc alpha"
-SLOT="0"
+
LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="x86 amd64 ppc sparc alpha"
DEPEND="virtual/glibc"
src_compile() {
- cd ${S}
./configure --prefix=/ || die
emake || die
}
diff --git a/sys-fs/reiserfsprogs/reiserfsprogs-3.6.4-r1.ebuild b/sys-fs/reiserfsprogs/reiserfsprogs-3.6.4-r1.ebuild
index a4e203b5e861..5c4cab0bef26 100644
--- a/sys-fs/reiserfsprogs/reiserfsprogs-3.6.4-r1.ebuild
+++ b/sys-fs/reiserfsprogs/reiserfsprogs-3.6.4-r1.ebuild
@@ -1,25 +1,21 @@
-# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-fs/reiserfsprogs/reiserfsprogs-3.6.4-r1.ebuild,v 1.1 2003/09/15 17:46:25 seemant Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/reiserfsprogs/reiserfsprogs-3.6.4-r1.ebuild,v 1.2 2004/01/29 22:59:04 vapier Exp $
inherit flag-o-matic eutils
-filter-flags -fPIC
-
-S=${WORKDIR}/${P}
DESCRIPTION="Reiserfs Utilities"
+HOMEPAGE="http://www.namesys.com/"
SRC_URI="http://www.namesys.com/pub/${PN}/${P}.tar.gz"
-HOMEPAGE="http://www.namesys.com"
-SLOT="0"
LICENSE="GPL-2"
-KEYWORDS="x86 amd64 ppc ~sparc ~alpha"
+SLOT="0"
+KEYWORDS="x86 ppc ~sparc ~alpha amd64"
DEPEND="virtual/glibc"
src_unpack() {
unpack ${A}
-
# NOTE: this patch needs to be applied to any architecture that has
# /usr/include/asm/bitops.h entirely wrapped with #ifdef __KERNEL__.
# This is needed because asm-i386/bitops.h is broken and reiserfsprogs
@@ -34,7 +30,7 @@ src_unpack() {
}
src_compile() {
- cd ${S}
+ filter-flags -fPIC
./configure --prefix=/ || die
emake || die
}
@@ -48,4 +44,3 @@ src_install() {
mv man usr/share
dosym /sbin/reiserfsck /sbin/fsck.reiserfs
}
-
diff --git a/sys-fs/reiserfsprogs/reiserfsprogs-3.6.8.ebuild b/sys-fs/reiserfsprogs/reiserfsprogs-3.6.8.ebuild
index cbfb1b312d9c..8e34edd121f8 100644
--- a/sys-fs/reiserfsprogs/reiserfsprogs-3.6.8.ebuild
+++ b/sys-fs/reiserfsprogs/reiserfsprogs-3.6.8.ebuild
@@ -1,21 +1,19 @@
-# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-fs/reiserfsprogs/reiserfsprogs-3.6.8.ebuild,v 1.2 2003/09/17 01:48:28 weeve Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/reiserfsprogs/reiserfsprogs-3.6.8.ebuild,v 1.3 2004/01/29 22:59:04 vapier Exp $
-inherit flag-o-matic eutils
+inherit flag-o-matic
-filter-flags -fPIC
-
-S=${WORKDIR}/${P}
DESCRIPTION="Reiserfs Utilities"
+HOMEPAGE="http://www.namesys.com/"
SRC_URI="http://www.namesys.com/pub/${PN}/${P}.tar.gz"
-HOMEPAGE="http://www.namesys.com"
-SLOT="0"
LICENSE="GPL-2"
-KEYWORDS="x86 amd64 ppc sparc alpha"
+SLOT="0"
+KEYWORDS="x86 ppc sparc alpha amd64"
src_compile() {
+ filter-flags -fPIC
./configure --prefix=/ || die "Failed to configure"
emake || die "Failed to compile"
}
@@ -29,4 +27,3 @@ src_install() {
mv man usr/share
dosym /sbin/reiserfsck /sbin/fsck.reiserfs
}
-
diff --git a/sys-fs/reiserfsprogs/reiserfsprogs-3.6.9.ebuild b/sys-fs/reiserfsprogs/reiserfsprogs-3.6.9.ebuild
index 234da029e160..450d6a8c4e57 100644
--- a/sys-fs/reiserfsprogs/reiserfsprogs-3.6.9.ebuild
+++ b/sys-fs/reiserfsprogs/reiserfsprogs-3.6.9.ebuild
@@ -1,21 +1,19 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-fs/reiserfsprogs/reiserfsprogs-3.6.9.ebuild,v 1.4 2004/01/18 22:55:43 tuxus Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/reiserfsprogs/reiserfsprogs-3.6.9.ebuild,v 1.5 2004/01/29 22:59:04 vapier Exp $
-inherit flag-o-matic eutils
+inherit flag-o-matic
-filter-flags -fPIC
-
-S=${WORKDIR}/${P}
DESCRIPTION="Reiserfs Utilities"
+HOMEPAGE="http://www.namesys.com/"
SRC_URI="http://www.namesys.com/pub/${PN}/${P}.tar.gz"
-HOMEPAGE="http://www.namesys.com"
-SLOT="0"
LICENSE="GPL-2"
-KEYWORDS="x86 ~amd64 ~ppc ~sparc ~alpha ia64 ~mips"
+SLOT="0"
+KEYWORDS="x86 ~ppc ~sparc ~alpha ~amd64 ia64 ~mips"
src_compile() {
+ filter-flags -fPIC
./configure --prefix=/ || die "Failed to configure"
emake || die "Failed to compile"
}
@@ -29,4 +27,3 @@ src_install() {
mv man usr/share
dosym /sbin/reiserfsck /sbin/fsck.reiserfs
}
-