summaryrefslogtreecommitdiff
path: root/sys-fs
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2011-04-06 19:58:44 +0000
committerMike Frysinger <vapier@gentoo.org>2011-04-06 19:58:44 +0000
commit3cf5276f80d203b6544e6453c1048798106367a6 (patch)
treec9597bac61920395655a241792d0fa7713f1bfd5 /sys-fs
parentadd support for upstream tagged releases (diff)
downloadhistorical-3cf5276f80d203b6544e6453c1048798106367a6.tar.gz
historical-3cf5276f80d203b6544e6453c1048798106367a6.tar.bz2
historical-3cf5276f80d203b6544e6453c1048798106367a6.zip
old
Diffstat (limited to 'sys-fs')
-rw-r--r--sys-fs/mtd-utils/files/mtd-utils-fixup.patch32
-rw-r--r--sys-fs/mtd-utils/mtd-utils-20080907.ebuild57
-rw-r--r--sys-fs/mtd-utils/mtd-utils-20090630.ebuild58
3 files changed, 0 insertions, 147 deletions
diff --git a/sys-fs/mtd-utils/files/mtd-utils-fixup.patch b/sys-fs/mtd-utils/files/mtd-utils-fixup.patch
deleted file mode 100644
index 08991500a462..000000000000
--- a/sys-fs/mtd-utils/files/mtd-utils-fixup.patch
+++ /dev/null
@@ -1,32 +0,0 @@
-Fix up the parallel building. Without this fix, each instance of the NTARGETS
-will try to build the libraries seperately, and on a suitably fast machine this
-can lead to overwriting. Add a specific instance to build the libraries first.
-
-Signed-off-by: Robin H. Johnson <robbat2@gentoo.org>
-
-diff -Nuar mtd-utils.orig/ubi-utils/Makefile mtd-utils/ubi-utils/Makefile
---- mtd-utils.orig/ubi-utils/Makefile 2008-09-23 18:51:00.129193374 -0700
-+++ mtd-utils/ubi-utils/Makefile 2008-09-23 18:54:04.097290355 -0700
-@@ -34,7 +34,10 @@
- IGNORE=${wildcard .*.c.dep}
- -include ${IGNORE}
-
--$(NTARGETS):
-+nlibs:
-+ $(MAKE) -C new-utils libs
-+
-+$(NTARGETS): nlibs
- $(MAKE) -C new-utils $@
- mv new-utils/$@ $@
-
-diff -Nuar mtd-utils.orig/ubi-utils/new-utils/Makefile mtd-utils/ubi-utils/new-utils/Makefile
---- mtd-utils.orig/ubi-utils/new-utils/Makefile 2008-09-23 18:51:00.179204851 -0700
-+++ mtd-utils/ubi-utils/new-utils/Makefile 2008-09-23 18:53:32.513881545 -0700
-@@ -19,6 +19,7 @@
- vpath %.c src
-
- all: $(UTILS)
-+libs: $(addsuffix .a,$(LIBS))
-
- # The below cancels existing implicite rule to make programs from .c files,
- # in order to force make using our rule defined below
diff --git a/sys-fs/mtd-utils/mtd-utils-20080907.ebuild b/sys-fs/mtd-utils/mtd-utils-20080907.ebuild
deleted file mode 100644
index a5be1bd75224..000000000000
--- a/sys-fs/mtd-utils/mtd-utils-20080907.ebuild
+++ /dev/null
@@ -1,57 +0,0 @@
-# Copyright 1999-2010 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-fs/mtd-utils/mtd-utils-20080907.ebuild,v 1.10 2010/09/12 08:39:50 robbat2 Exp $
-
-inherit toolchain-funcs eutils
-
-# Git ID for the snapshot
-MY_PV="${PV}-41c53b6f2d756ae995c3ffa4455576515427c5e0"
-DESCRIPTION="MTD userspace tools, based on GIT snapshot from upstream (NFTL, JFFS2, NAND, FTL, UBI)"
-HOMEPAGE="http://git.infradead.org/?p=mtd-utils.git;a=summary"
-SRC_URI="mirror://gentoo/${PN}-snapshot-${MY_PV}.tar.gz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="amd64 arm ~mips ppc x86"
-IUSE="xattr"
-
-# We need libuuid
-RDEPEND="!sys-fs/mtd
- dev-libs/lzo
- sys-libs/zlib
- >=sys-apps/util-linux-2.16"
-# ACL is only required for the <sys/acl.h> header file to build mkfs.jffs2
-# And ACL brings in Attr as well.
-DEPEND="${RDEPEND}
- xattr? ( sys-apps/acl )"
-
-S=${WORKDIR}/${PN}
-
-src_unpack() {
- unpack ${A}
- cd "${S}"
- sed -i 's:-Werror::' $(find . -name Makefile)
- epatch "${FILESDIR}"/mtd-utils-fixup.patch
- sed -i -e 's:\<ar\>:$(AR):' tests/ubi-tests/Makefile || die
- sed -i -e 's:\<ranlib\>:$(RANLIB):' ubi-utils/new-utils/Makefile || die
-}
-
-src_compile() {
- tc-export AR RANLIB
- # -j1 for #276374
- emake -j1 \
- CC="$(tc-getCC)" \
- OPTFLAGS="${CFLAGS}" \
- $(use xattr || echo WITHOUT_XATTR=1) \
- || die
-}
-
-src_install() {
- emake install DESTDIR="${D}" || die
- newman ubi-utils/doc/unubi.roff unubi.1
- dodoc *.txt */*.TXT
- newdoc mkfs.ubifs/README README.mkfs.ubifs
- newdoc ubi-utils/README README.ubi-utils
- newdoc ubi-utils/new-utils/README README.new-utils
- # TODO: check ubi-utils for docs+scripts
-}
diff --git a/sys-fs/mtd-utils/mtd-utils-20090630.ebuild b/sys-fs/mtd-utils/mtd-utils-20090630.ebuild
deleted file mode 100644
index 72c3d265df58..000000000000
--- a/sys-fs/mtd-utils/mtd-utils-20090630.ebuild
+++ /dev/null
@@ -1,58 +0,0 @@
-# Copyright 1999-2010 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-fs/mtd-utils/mtd-utils-20090630.ebuild,v 1.8 2010/09/12 08:39:50 robbat2 Exp $
-
-inherit eutils toolchain-funcs
-
-# Git ID for the snapshot
-MY_PV="${PV}-22494a8d105936785af53235b088fa38112128fc"
-DESCRIPTION="MTD userspace tools, based on GIT snapshot from upstream (NFTL, JFFS2, NAND, FTL, UBI)"
-HOMEPAGE="http://git.infradead.org/?p=mtd-utils.git;a=summary"
-SRC_URI="mirror://gentoo/${PN}-snapshot-${MY_PV}.tar.bz2"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~amd64 ~arm ~mips ~ppc ~x86"
-IUSE="xattr"
-
-# We need libuuid
-RDEPEND="!sys-fs/mtd
- dev-libs/lzo
- sys-libs/zlib
- >=sys-apps/util-linux-2.16"
-# ACL is only required for the <sys/acl.h> header file to build mkfs.jffs2
-# And ACL brings in Attr as well.
-DEPEND="${RDEPEND}
- xattr? ( sys-apps/acl )"
-
-S=${WORKDIR}/${PN}
-
-src_unpack() {
- unpack ${A}
- cd "${S}"
- sed -i 's:-Werror::' $(find . -name Makefile)
-}
-
-makeopts() {
- tc-export CC
- # bug 276374 has an interaction that makes the directories not work quite
- # right sometimes. This needs more work.
- tc-is-cross-compiler && echo CROSS=${CHOST}-
- use xattr || echo WITHOUT_XATTR=1
-}
-
-src_compile() {
- # bug 276374 requires that the contents of ubi-utils gets built BEFORE the
- # rest of the codebase. There is a parallel interference in the Makefile.
- pushd ubi-utils
- emake $(makeopts) || die
- popd
- emake $(makeopts) || die
-}
-
-src_install() {
- emake $(makeopts) install DESTDIR="${D}" || die
- dodoc *.txt
- newdoc mkfs.ubifs/README README.mkfs.ubifs
- # TODO: check ubi-utils for docs+scripts
-}