summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Marineau <marineam@gentoo.org>2005-08-31 16:52:34 +0000
committerMichael Marineau <marineam@gentoo.org>2005-08-31 16:52:34 +0000
commit7ec40dcccab3109f708a2db940899acd177a5bed (patch)
tree6963ffd76bebfd60c8b4e9cb6ad40b11df57c280 /sys-kernel/ck-sources
parentAdded missing dependencies wrt bug #104312. (diff)
downloadhistorical-7ec40dcccab3109f708a2db940899acd177a5bed.tar.gz
historical-7ec40dcccab3109f708a2db940899acd177a5bed.tar.bz2
historical-7ec40dcccab3109f708a2db940899acd177a5bed.zip
Version bump, new ck-plus use flag
Package-Manager: portage-2.0.51.22-r2
Diffstat (limited to 'sys-kernel/ck-sources')
-rw-r--r--sys-kernel/ck-sources/ChangeLog11
-rw-r--r--sys-kernel/ck-sources/Manifest10
-rw-r--r--sys-kernel/ck-sources/ck-sources-2.6.13_p1.ebuild59
-rw-r--r--sys-kernel/ck-sources/files/digest-ck-sources-2.6.13_p16
4 files changed, 81 insertions, 5 deletions
diff --git a/sys-kernel/ck-sources/ChangeLog b/sys-kernel/ck-sources/ChangeLog
index 6c36b511d1b3..b40c9e6d6d83 100644
--- a/sys-kernel/ck-sources/ChangeLog
+++ b/sys-kernel/ck-sources/ChangeLog
@@ -1,6 +1,15 @@
# ChangeLog for sys-kernel/ck-sources
# Copyright 2002-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-kernel/ck-sources/ChangeLog,v 1.113 2005/08/20 19:07:48 marineam Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-kernel/ck-sources/ChangeLog,v 1.114 2005/08/31 16:52:34 marineam Exp $
+
+*ck-sources-2.6.13_p1 (31 Aug 2005)
+
+ 31 Aug 2005; Michael Marineau <marineam@gentoo.org>
+ +ck-sources-2.6.13_p1.ebuild:
+ New kernel/ck version. Closes bug #104213
+ Added ck-plus use flag which will apply the experimental patches in the
+ ck+ patch. Currently these are sched-staircase12_tweak and
+ vm-swap-prefetch.patch.
*ck-sources-2.6.12_p6 (20 Aug 2005)
diff --git a/sys-kernel/ck-sources/Manifest b/sys-kernel/ck-sources/Manifest
index 01209a8b0a18..3ab6d16ee73b 100644
--- a/sys-kernel/ck-sources/Manifest
+++ b/sys-kernel/ck-sources/Manifest
@@ -1,14 +1,16 @@
-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1
+MD5 83041bdb45d5c43280088444defdcf3f ck-sources-2.6.13_p1.ebuild 1866
MD5 02d0e0b30a6dd845213638e80d436dcd ck-sources-2.6.12_p6.ebuild 1553
-MD5 5713619a7b18f4a28fae9e4fe1c53dd4 ChangeLog 25524
+MD5 2f902f7c71cfea80439614976da3d8e2 ChangeLog 25854
MD5 7187b8c28501f454a2412c9e4a7fcf53 metadata.xml 421
MD5 07ddcfdd8965da5814e2c964973baf58 files/digest-ck-sources-2.6.12_p6 279
+MD5 34c34364ad71a43bdabb94b187652ae7 files/digest-ck-sources-2.6.13_p1 415
-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.4.1 (GNU/Linux)
-iD8DBQFDB3+miP+LossGzjARAhl4AKCyGlriWeFVqOLFs86Gd/NXu2D/QwCfRcC5
-On/Lg9lyygpX0/d+T/MCtoI=
-=3K0r
+iD8DBQFDFeBuiP+LossGzjARAnVzAJ4wGQn53OfQSyCdhpcI9YTDpmdofgCgqK/A
+q284N30gZTZXvYVqqTBEa10=
+=QZ7i
-----END PGP SIGNATURE-----
diff --git a/sys-kernel/ck-sources/ck-sources-2.6.13_p1.ebuild b/sys-kernel/ck-sources/ck-sources-2.6.13_p1.ebuild
new file mode 100644
index 000000000000..355a37d21aa2
--- /dev/null
+++ b/sys-kernel/ck-sources/ck-sources-2.6.13_p1.ebuild
@@ -0,0 +1,59 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-kernel/ck-sources/ck-sources-2.6.13_p1.ebuild,v 1.1 2005/08/31 16:52:34 marineam Exp $
+
+K_PREPATCHED="yes"
+UNIPATCH_STRICTORDER="yes"
+K_NOUSENAME="yes"
+K_WANT_GENPATCHES="base"
+K_GENPATCHES_VER="1"
+ETYPE="sources"
+inherit kernel-2
+detect_version
+
+# A few hacks to set ck version via _p instead of -r
+MY_P=${P/_p*/}
+MY_PR=${PR/r/-r}
+MY_PR=${MY_PR/-r0/}
+EXTRAVERSION=-ck${PV/*_p/}${MY_PR}
+KV_FULL=${OKV}${EXTRAVERSION}
+KV_CK=${KV_FULL/-r*/}
+detect_version
+
+IUSE="ck-server ck-plus"
+if use ck-server; then
+ CK_PATCH="patch-${KV_CK}-server.bz2"
+else
+ CK_PATCH="patch-${KV_CK}.bz2"
+fi
+
+if use ck-plus; then
+ UNIPATCH_LIST="${DISTDIR}/${CK_PATCH}
+ ${DISTDIR}/sched-staircase12_tweak.patch
+ ${DISTDIR}/vm-swap-prefetch.patch"
+else
+ UNIPATCH_LIST="${DISTDIR}/${CK_PATCH}"
+fi
+# Note: 2.6.x.y updates in genpatches begin with 10 but are included in -ck
+#UNIPATCH_EXCLUDE="${UNIPATCH_EXCLUDE}"
+
+DESCRIPTION="Full sources for the Linux kernel with Con Kolivas' high performance patchset and Gentoo's basic patchset."
+HOMEPAGE="http://members.optusnet.com.au/ckolivas/kernel/"
+SRC_URI="${KERNEL_URI} ${GENPATCHES_URI}
+ ck-server? ( http://ck.kolivas.org/patches/2.6/${OKV}/${KV_CK}/patch-${KV_CK}-server.bz2 )
+ !ck-server? ( http://ck.kolivas.org/patches/2.6/${OKV}/${KV_CK}/patch-${KV_CK}.bz2 )
+ ck-plus? (
+ http://ck.kolivas.org/patches/2.6/${OKV}/${KV_CK}/patches/sched-staircase12_tweak.patch
+ http://ck.kolivas.org/patches/2.6/${OKV}/${KV_CK}/patches/vm-swap-prefetch.patch
+ )"
+
+KEYWORDS="~amd64 ~ppc64 ~x86"
+
+pkg_postinst() {
+ postinst_sources
+
+ einfo "The ck patchset is tuned for desktop usage."
+ einfo "To better tune the kernel for server applications add"
+ einfo "ck-server to your use flags and reemerge ck-sources"
+}
+
diff --git a/sys-kernel/ck-sources/files/digest-ck-sources-2.6.13_p1 b/sys-kernel/ck-sources/files/digest-ck-sources-2.6.13_p1
new file mode 100644
index 000000000000..a5ab72da8ead
--- /dev/null
+++ b/sys-kernel/ck-sources/files/digest-ck-sources-2.6.13_p1
@@ -0,0 +1,6 @@
+MD5 560f5fadf59f172973e67939868a4cae linux-2.6.13.tar.bz2 38372729
+MD5 ac43582ec7a1280eee78eabb9c416662 genpatches-2.6.13-1.base.tar.bz2 16013
+MD5 3ba7062e23a5c7b7317bd50e0f001f35 patch-2.6.13-ck1-server.bz2 21357
+MD5 ad98bab28acb512bc7cfdd92dbdc7027 patch-2.6.13-ck1.bz2 21376
+MD5 0f8c2699384e84a972c366aa4b93b9d1 sched-staircase12_tweak.patch 1003
+MD5 cea9536392a0bc5bdc164a1c622a9d29 vm-swap-prefetch.patch 9677