summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Marineau <marineam@gentoo.org>2006-06-22 17:00:11 +0000
committerMichael Marineau <marineam@gentoo.org>2006-06-22 17:00:11 +0000
commitf3c853ad95284b8b3d6bb5d0d14286138c3e174e (patch)
tree55aec6bc116f33be53160ab62194d0b6d2f17b31 /sys-kernel/ck-sources
parentStable on x86 wrt bug #135886. (diff)
downloadhistorical-f3c853ad95284b8b3d6bb5d0d14286138c3e174e.tar.gz
historical-f3c853ad95284b8b3d6bb5d0d14286138c3e174e.tar.bz2
historical-f3c853ad95284b8b3d6bb5d0d14286138c3e174e.zip
Version bump
Package-Manager: portage-2.1
Diffstat (limited to 'sys-kernel/ck-sources')
-rw-r--r--sys-kernel/ck-sources/ChangeLog11
-rw-r--r--sys-kernel/ck-sources/ck-sources-2.6.16_p12.ebuild48
-rw-r--r--sys-kernel/ck-sources/ck-sources-2.6.17_p1.ebuild48
-rw-r--r--sys-kernel/ck-sources/files/digest-ck-sources-2.6.16_p1212
-rw-r--r--sys-kernel/ck-sources/files/digest-ck-sources-2.6.17_p112
5 files changed, 130 insertions, 1 deletions
diff --git a/sys-kernel/ck-sources/ChangeLog b/sys-kernel/ck-sources/ChangeLog
index 03f6669de64b..b6cff77ff94e 100644
--- a/sys-kernel/ck-sources/ChangeLog
+++ b/sys-kernel/ck-sources/ChangeLog
@@ -1,6 +1,15 @@
# ChangeLog for sys-kernel/ck-sources
# Copyright 2002-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-kernel/ck-sources/ChangeLog,v 1.143 2006/05/22 19:28:12 marineam Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-kernel/ck-sources/ChangeLog,v 1.144 2006/06/22 17:00:11 marineam Exp $
+
+*ck-sources-2.6.17_p1 (22 Jun 2006)
+*ck-sources-2.6.16_p12 (22 Jun 2006)
+
+ 22 Jun 2006; Michael Marineau <marineam@gentoo.org>
+ -ck-sources-2.6.16_p11.ebuild, +ck-sources-2.6.16_p12.ebuild,
+ +ck-sources-2.6.17_p1.ebuild:
+ Bump to 2.6.16-ck12 (includes 2.6.16.20) and 2.6.17-ck1.
+ Thanks go to Peter Hyman in bug #136109 for cleaning up the ebuild.
*ck-sources-2.6.16_p11 (22 May 2006)
diff --git a/sys-kernel/ck-sources/ck-sources-2.6.16_p12.ebuild b/sys-kernel/ck-sources/ck-sources-2.6.16_p12.ebuild
new file mode 100644
index 000000000000..06b82c25245b
--- /dev/null
+++ b/sys-kernel/ck-sources/ck-sources-2.6.16_p12.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-kernel/ck-sources/ck-sources-2.6.16_p12.ebuild,v 1.1 2006/06/22 17:00:11 marineam Exp $
+
+DESCRIPTION="Full sources for the Linux kernel with Con Kolivas' high performance patchset and Gentoo's basic patchset."
+HOMEPAGE="http://members.optusnet.com.au/ckolivas/kernel/"
+IUSE="ck-server"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
+
+K_NOUSENAME="yes"
+K_WANT_GENPATCHES="base"
+K_GENPATCHES_VER="12"
+ETYPE="sources"
+inherit kernel-2
+
+detect_version
+# A few hacks to set ck version via _p instead of -r
+MY_PR=${PR/r/-r}
+MY_PR=${MY_PR/-r0/}
+EXTRAVERSION=-ck${PV/*_p/}${MY_PR}
+KV_FULL=${OKV}${EXTRAVERSION}
+KV_CK=${KV_FULL/-r*/}
+
+if use ck-server; then
+ UNIPATCH_LIST="${DISTDIR}/patch-${KV_CK/ck/cks}.bz2"
+else
+ UNIPATCH_LIST="${DISTDIR}/patch-${KV_CK}.bz2"
+fi
+
+# Note: 2.6.x.y updates in genpatches begin with 10 but are included in -ck
+# new order of patches means some additional excludes.
+UNIPATCH_EXCLUDE="${UNIPATCH_EXCLUDE} 10"
+
+SRC_URI="${KERNEL_URI} ${GENPATCHES_URI}
+ ck-server? (
+ mirror://kernel/linux/kernel/people/ck/patches/cks/patch-${KV_CK/ck/cks}.bz2
+ )
+ !ck-server? (
+ mirror://kernel/linux/kernel/people/ck/patches/2.6/${OKV}/${KV_CK}/patch-${KV_CK}.bz2 )"
+
+
+pkg_postinst() {
+ postinst_sources
+
+ einfo "The ck patchset is tuned for desktop usage."
+ einfo "To better tune the kernel for server applications add"
+ einfo "ck-server to your use flags and reemerge ck-sources"
+}
diff --git a/sys-kernel/ck-sources/ck-sources-2.6.17_p1.ebuild b/sys-kernel/ck-sources/ck-sources-2.6.17_p1.ebuild
new file mode 100644
index 000000000000..034734899762
--- /dev/null
+++ b/sys-kernel/ck-sources/ck-sources-2.6.17_p1.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-kernel/ck-sources/ck-sources-2.6.17_p1.ebuild,v 1.1 2006/06/22 17:00:11 marineam Exp $
+
+DESCRIPTION="Full sources for the Linux kernel with Con Kolivas' high performance patchset and Gentoo's basic patchset."
+HOMEPAGE="http://members.optusnet.com.au/ckolivas/kernel/"
+IUSE="ck-server"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
+
+K_NOUSENAME="yes"
+K_WANT_GENPATCHES="base"
+K_GENPATCHES_VER="1"
+ETYPE="sources"
+inherit kernel-2
+
+detect_version
+# A few hacks to set ck version via _p instead of -r
+MY_PR=${PR/r/-r}
+MY_PR=${MY_PR/-r0/}
+EXTRAVERSION=-ck${PV/*_p/}${MY_PR}
+KV_FULL=${OKV}${EXTRAVERSION}
+KV_CK=${KV_FULL/-r*/}
+
+if use ck-server; then
+ UNIPATCH_LIST="${DISTDIR}/patch-${KV_CK/ck/cks}.bz2"
+else
+ UNIPATCH_LIST="${DISTDIR}/patch-${KV_CK}.bz2"
+fi
+
+# Note: 2.6.x.y updates in genpatches begin with 10 but are included in -ck
+# new order of patches means some additional excludes.
+UNIPATCH_EXCLUDE="${UNIPATCH_EXCLUDE} 10"
+
+SRC_URI="${KERNEL_URI} ${GENPATCHES_URI}
+ ck-server? (
+ mirror://kernel/linux/kernel/people/ck/patches/cks/patch-${KV_CK/ck/cks}.bz2
+ )
+ !ck-server? (
+ mirror://kernel/linux/kernel/people/ck/patches/2.6/${OKV}/${KV_CK}/patch-${KV_CK}.bz2 )"
+
+
+pkg_postinst() {
+ postinst_sources
+
+ einfo "The ck patchset is tuned for desktop usage."
+ einfo "To better tune the kernel for server applications add"
+ einfo "ck-server to your use flags and reemerge ck-sources"
+}
diff --git a/sys-kernel/ck-sources/files/digest-ck-sources-2.6.16_p12 b/sys-kernel/ck-sources/files/digest-ck-sources-2.6.16_p12
new file mode 100644
index 000000000000..7fb66376ec11
--- /dev/null
+++ b/sys-kernel/ck-sources/files/digest-ck-sources-2.6.16_p12
@@ -0,0 +1,12 @@
+MD5 01dc7a702556fc2ded6ed6d24e21374b genpatches-2.6.16-12.base.tar.bz2 93996
+RMD160 89e63a245e8d59d00bd740e96db57c03770d56d6 genpatches-2.6.16-12.base.tar.bz2 93996
+SHA256 182dae8504ba907feadc9b5b9c2aba862171b3abb5d389237583973fa8b19367 genpatches-2.6.16-12.base.tar.bz2 93996
+MD5 9a91b2719949ff0856b40bc467fd47be linux-2.6.16.tar.bz2 40845005
+RMD160 af5c2f55733fadd2fdf8b00da55e7b31d516d4e8 linux-2.6.16.tar.bz2 40845005
+SHA256 1200dcc7e60fcdaf68618dba991917a47e41e67099e8b22143976ec972e2cad7 linux-2.6.16.tar.bz2 40845005
+MD5 69e0f62d1b83d37529a487709b92eb64 patch-2.6.16-ck12.bz2 105490
+RMD160 79f84083f71bd575c115036e09201d03fb7b8248 patch-2.6.16-ck12.bz2 105490
+SHA256 357147717d0f3eaa0f6adf346e3d0ad8227fa4dbefe2b2ffe5659c0465863b33 patch-2.6.16-ck12.bz2 105490
+MD5 7995bce37441904fe9c750eefbe9c16d patch-2.6.16-cks12.bz2 105255
+RMD160 3362273f89cb0be0c187aa943abf2ec970f9c1ff patch-2.6.16-cks12.bz2 105255
+SHA256 ad29252917f9427f0b408d06983eeb521f02d56120b1ae7b82176c30403815ba patch-2.6.16-cks12.bz2 105255
diff --git a/sys-kernel/ck-sources/files/digest-ck-sources-2.6.17_p1 b/sys-kernel/ck-sources/files/digest-ck-sources-2.6.17_p1
new file mode 100644
index 000000000000..fd2f872890c6
--- /dev/null
+++ b/sys-kernel/ck-sources/files/digest-ck-sources-2.6.17_p1
@@ -0,0 +1,12 @@
+MD5 cd5d67dc1d3514ec240497efff0f8726 genpatches-2.6.17-1.base.tar.bz2 3337
+RMD160 f9b5621fed8fcfee7da697d89097842287b41b24 genpatches-2.6.17-1.base.tar.bz2 3337
+SHA256 2208b72729dce6daef7dc5700192aec0ae17327c794681621d2123f0c483ae21 genpatches-2.6.17-1.base.tar.bz2 3337
+MD5 37ddefe96625502161f075b9d907f21e linux-2.6.17.tar.bz2 41272919
+RMD160 26aad30c9a6610665c6c7d62401d79bf56a6a699 linux-2.6.17.tar.bz2 41272919
+SHA256 ab0f647d52f124958439517df9e1ae0efda90cdb851f59f522fa1749f1d87d58 linux-2.6.17.tar.bz2 41272919
+MD5 5ea691e8d3cd6a853bf62ecb2f857da6 patch-2.6.17-ck1.bz2 48433
+RMD160 1331c677f8e70237dd81d978ece3682a73bcfeb7 patch-2.6.17-ck1.bz2 48433
+SHA256 eb8ae45cb8d8adbbed5d55f3e5a8ad08483edbefe16571a05c5ab784fe2f0ab6 patch-2.6.17-ck1.bz2 48433
+MD5 7395598437c063f6365ed33a64c3d1de patch-2.6.17-cks1.bz2 38206
+RMD160 f1c3a6ed5998d57d6bdbfab20ff53a1c9e09328c patch-2.6.17-cks1.bz2 38206
+SHA256 f9d3a45589d315ba3b33749f633b55dc9a071c8ca43d0ec2255038eb1069344c patch-2.6.17-cks1.bz2 38206