summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Yamin <plasmaroo@gentoo.org>2004-08-25 17:57:06 +0000
committerTim Yamin <plasmaroo@gentoo.org>2004-08-25 17:57:06 +0000
commit0808d20f66600c560633b6dd72e51b65b252f81f (patch)
tree3717eff8fd485f62894297bc067852269694d0cb /sys-kernel/linux26-headers
parentnew gtk2 version (diff)
downloadhistorical-0808d20f66600c560633b6dd72e51b65b252f81f.tar.gz
historical-0808d20f66600c560633b6dd72e51b65b252f81f.tar.bz2
historical-0808d20f66600c560633b6dd72e51b65b252f81f.zip
Fix for xfce4-netload.
Diffstat (limited to 'sys-kernel/linux26-headers')
-rw-r--r--sys-kernel/linux26-headers/ChangeLog6
-rw-r--r--sys-kernel/linux26-headers/Manifest4
-rw-r--r--sys-kernel/linux26-headers/files/linux26-headers-2.6.8.1-appCompat.patch18
3 files changed, 25 insertions, 3 deletions
diff --git a/sys-kernel/linux26-headers/ChangeLog b/sys-kernel/linux26-headers/ChangeLog
index 3e7063aa6d65..8ce28af2963b 100644
--- a/sys-kernel/linux26-headers/ChangeLog
+++ b/sys-kernel/linux26-headers/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for sys-kernel/linux26-headers
# Copyright 1999-2004 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-kernel/linux26-headers/ChangeLog,v 1.23 2004/08/24 23:42:15 plasmaroo Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-kernel/linux26-headers/ChangeLog,v 1.24 2004/08/25 17:57:06 plasmaroo Exp $
+
+ 25 Aug 2004; <plasmaroo@gentoo.org>
+ files/linux26-headers-2.6.8.1-appCompat.patch:
+ Fix for xfce4-netload.
*linux26-headers-2.6.8.1 (25 Aug 2004)
diff --git a/sys-kernel/linux26-headers/Manifest b/sys-kernel/linux26-headers/Manifest
index 12a863105dda..820dce2a23d2 100644
--- a/sys-kernel/linux26-headers/Manifest
+++ b/sys-kernel/linux26-headers/Manifest
@@ -1,4 +1,4 @@
-MD5 5b40c7871a294cc2a5b496d70d41c5dc ChangeLog 5878
+MD5 4366345ab3c37f08649686cd1f7f24db ChangeLog 5991
MD5 2492e34d9b129b18f0ba2460299741a5 linux26-headers-2.6.7-r4.ebuild 4035
MD5 21dcb669b4e8535f0a04f40ad2c4c9ff metadata.xml 224
MD5 e545ff6a66853894c5fcbc60f199f262 linux26-headers-2.6.6.ebuild 4062
@@ -18,7 +18,7 @@ MD5 b737234adedfb6dc585af6bbb40bf2d3 files/digest-linux26-headers-2.6.6 66
MD5 8a065c0dc3b8fac8747de35f1af75a2c files/linux26-headers-2.6.0-fb.patch 386
MD5 b405a908c2cc1e6ed3e25f030c41f4c4 files/digest-linux26-headers-2.6.7-r3 66
MD5 8fbc202526e4c1b1672c5274bbff4e5f files/linux26-headers-2.6.6-appCompat.patch 26689
-MD5 40d89671cb8057d4b51034645ed47678 files/linux26-headers-2.6.8.1-appCompat.patch 47400
+MD5 08805e52510998e228b623b5cbd07939 files/linux26-headers-2.6.8.1-appCompat.patch 48106
MD5 b405a908c2cc1e6ed3e25f030c41f4c4 files/digest-linux26-headers-2.6.7-r4 66
MD5 830c6d1dcb1b22b9095e6f16f3ebdf85 files/linux26-headers-2.6.6-tcp_info-DRS-backport.patch 288
MD5 7c487aa645f5d88e86c3252ab44ef5ae files/linux26-headers-2.6.7-appCompat.patch 42608
diff --git a/sys-kernel/linux26-headers/files/linux26-headers-2.6.8.1-appCompat.patch b/sys-kernel/linux26-headers/files/linux26-headers-2.6.8.1-appCompat.patch
index 458adf8fa8f5..739e2993bbd6 100644
--- a/sys-kernel/linux26-headers/files/linux26-headers-2.6.8.1-appCompat.patch
+++ b/sys-kernel/linux26-headers/files/linux26-headers-2.6.8.1-appCompat.patch
@@ -1529,3 +1529,21 @@ diff -ur linux-2.6.8.1/include/linux/videodev2.h linux-2.6.8.1-gentoo/include/li
#ifdef __KERNEL__
#include <linux/time.h> /* need struct timeval */
#endif
+diff -ur linux-2.6.8.1/include/linux/crc-ccitt.h linux-2.6.8.1-gentoo/include/linux/crc-ccitt.h
+--- linux-2.6.8.1/include/linux/crc-ccitt.h 2004-08-20 19:54:37.000000000 +0100
++++ linux-2.6.8.1-gentoo/include/linux/crc-ccitt.h 2004-08-25 18:49:57.048297800 +0100
+@@ -3,11 +3,11 @@
+
+ #include <linux/types.h>
+
+-extern u16 const crc_ccitt_table[256];
++extern __u16 const crc_ccitt_table[256];
+
+-extern u16 crc_ccitt(u16 crc, const u8 *buffer, size_t len);
++extern __u16 crc_ccitt(__u16 crc, const __u8 *buffer, size_t len);
+
+-static inline u16 crc_ccitt_byte(u16 crc, const u8 c)
++static inline __u16 crc_ccitt_byte(__u16 crc, const __u8 c)
+ {
+ return (crc >> 8) ^ crc_ccitt_table[(crc ^ c) & 0xff];
+ }