summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick Lauer <patrick@gentoo.org>2009-10-09 17:18:57 +0000
committerPatrick Lauer <patrick@gentoo.org>2009-10-09 17:18:57 +0000
commit3e92c7a134f6b37b36a15e22e7eb655c14ab4647 (patch)
treed0322a04134b3b152b01d305f0f8a9d0c58da0c4 /sys-libs/talloc
parentAutomated update of use.local.desc (diff)
downloadhistorical-3e92c7a134f6b37b36a15e22e7eb655c14ab4647.tar.gz
historical-3e92c7a134f6b37b36a15e22e7eb655c14ab4647.tar.bz2
historical-3e92c7a134f6b37b36a15e22e7eb655c14ab4647.zip
Initial commit. Ebuilds based on those provided by Marcel Greter in #231273
Package-Manager: portage-2.2_rc44/cvs/Linux x86_64
Diffstat (limited to 'sys-libs/talloc')
-rw-r--r--sys-libs/talloc/ChangeLog13
-rw-r--r--sys-libs/talloc/metadata.xml12
-rw-r--r--sys-libs/talloc/talloc-1.3.0.ebuild55
-rw-r--r--sys-libs/talloc/talloc-1.3.1.ebuild55
-rw-r--r--sys-libs/talloc/talloc-2.0.0.ebuild56
5 files changed, 191 insertions, 0 deletions
diff --git a/sys-libs/talloc/ChangeLog b/sys-libs/talloc/ChangeLog
new file mode 100644
index 000000000000..938eb715ff31
--- /dev/null
+++ b/sys-libs/talloc/ChangeLog
@@ -0,0 +1,13 @@
+# ChangeLog for sys-libs/talloc
+# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/talloc/ChangeLog,v 1.1 2009/10/09 17:18:07 patrick Exp $
+
+*talloc-2.0.0 (09 Oct 2009)
+*talloc-1.3.1 (09 Oct 2009)
+*talloc-1.3.0 (09 Oct 2009)
+
+ 09 Oct 2009; Patrick Lauer <patrick@gentoo.org> +talloc-1.3.0.ebuild,
+ +talloc-1.3.1.ebuild, +talloc-2.0.0.ebuild, +metadata.xml:
+ Initial commit. Ebuilds based on those provided by Marcel Greter in
+ #231273
+
diff --git a/sys-libs/talloc/metadata.xml b/sys-libs/talloc/metadata.xml
new file mode 100644
index 000000000000..89867903e8d8
--- /dev/null
+++ b/sys-libs/talloc/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>samba</herd>
+ <maintainer>
+ <email>patrick@gentoo.org</email>
+ <name>Patrick Lauer</name>
+ </maintainer>
+<use>
+ <flag name="compat">Enable extra compatibility stuff</flag>
+</use>
+</pkgmetadata>
diff --git a/sys-libs/talloc/talloc-1.3.0.ebuild b/sys-libs/talloc/talloc-1.3.0.ebuild
new file mode 100644
index 000000000000..46e46e8fc7c5
--- /dev/null
+++ b/sys-libs/talloc/talloc-1.3.0.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/talloc/talloc-1.3.0.ebuild,v 1.1 2009/10/09 17:18:07 patrick Exp $
+
+EAPI="2"
+
+inherit confutils eutils
+
+DESCRIPTION="talloc"
+HOMEPAGE="http://talloc.samba.org/"
+SRC_URI="http://samba.org/ftp/talloc/${P}.tar.gz"
+LICENSE="GPL-3"
+IUSE=""
+SLOT="0"
+KEYWORDS="~amd64 ~hppa ~ppc64 ~x86"
+
+DEPEND="!net-fs/samba-libs[talloc]"
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+
+ ./autogen.sh || die "autogen.sh failed"
+
+ sed -i \
+ -e 's|SHLD_FLAGS = @SHLD_FLAGS@|SHLD_FLAGS = @SHLD_FLAGS@ @LDFLAGS@|' \
+ -e 's|CC = @CC@|CC = @CC@\
+LDFLAGS = @LDFLAGS@|' \
+ Makefile.in || die "sed failed"
+
+}
+
+src_configure() {
+
+ econf \
+ --sysconfdir=/etc/samba \
+ --localstatedir=/var \
+ --enable-largefile \
+ || die "econf failed"
+
+}
+
+src_compile() {
+
+ emake showflags || die "emake showflags failed"
+ emake shared-build || die "emake shared-build failed"
+
+}
+
+src_install() {
+
+ emake install DESTDIR="${D}" || die "emake install failed"
+ dolib.a sharedbuild/lib/libtalloc.a
+ dolib.so sharedbuild/lib/libtalloc.so
+
+}
diff --git a/sys-libs/talloc/talloc-1.3.1.ebuild b/sys-libs/talloc/talloc-1.3.1.ebuild
new file mode 100644
index 000000000000..38e8d047dd4c
--- /dev/null
+++ b/sys-libs/talloc/talloc-1.3.1.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/talloc/talloc-1.3.1.ebuild,v 1.1 2009/10/09 17:18:07 patrick Exp $
+
+EAPI="2"
+
+inherit confutils eutils
+
+DESCRIPTION="talloc"
+HOMEPAGE="http://talloc.samba.org/"
+SRC_URI="http://samba.org/ftp/talloc/${P}.tar.gz"
+LICENSE="GPL-3"
+IUSE=""
+SLOT="0"
+KEYWORDS="~amd64 ~hppa ~ppc64 ~x86"
+
+DEPEND="!net-fs/samba-libs[talloc]"
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+
+ ./autogen.sh || die "autogen.sh failed"
+
+ sed -i \
+ -e 's|SHLD_FLAGS = @SHLD_FLAGS@|SHLD_FLAGS = @SHLD_FLAGS@ @LDFLAGS@|' \
+ -e 's|CC = @CC@|CC = @CC@\
+LDFLAGS = @LDFLAGS@|' \
+ Makefile.in || die "sed failed"
+
+}
+
+src_configure() {
+
+ econf \
+ --sysconfdir=/etc/samba \
+ --localstatedir=/var \
+ --enable-largefile \
+ || die "econf failed"
+
+}
+
+src_compile() {
+
+ emake showflags || die "emake showflags failed"
+ emake shared-build || die "emake shared-build failed"
+
+}
+
+src_install() {
+
+ emake install DESTDIR="${D}" || die "emake install failed"
+ dolib.a sharedbuild/lib/libtalloc.a
+ dolib.so sharedbuild/lib/libtalloc.so
+
+}
diff --git a/sys-libs/talloc/talloc-2.0.0.ebuild b/sys-libs/talloc/talloc-2.0.0.ebuild
new file mode 100644
index 000000000000..c6b3fd40a8fa
--- /dev/null
+++ b/sys-libs/talloc/talloc-2.0.0.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/talloc/talloc-2.0.0.ebuild,v 1.1 2009/10/09 17:18:07 patrick Exp $
+
+EAPI="2"
+
+inherit confutils eutils
+
+DESCRIPTION="talloc"
+HOMEPAGE="http://talloc.samba.org/"
+SRC_URI="http://samba.org/ftp/talloc/${P}.tar.gz"
+LICENSE="GPL-3"
+IUSE="compat"
+SLOT="0"
+KEYWORDS="~amd64 ~hppa ~ppc64 ~x86"
+
+DEPEND="!net-fs/samba-libs[talloc]"
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+
+ ./autogen.sh || die "autogen.sh failed"
+
+ sed -i \
+ -e 's|SHLD_FLAGS = @SHLD_FLAGS@|SHLD_FLAGS = @SHLD_FLAGS@ @LDFLAGS@|' \
+ -e 's|CC = @CC@|CC = @CC@\
+LDFLAGS = @LDFLAGS@|' \
+ Makefile.in || die "sed failed"
+
+}
+
+src_configure() {
+
+ econf \
+ --sysconfdir=/etc/samba \
+ --localstatedir=/var \
+ --enable-largefile \
+ $(use_enable compat talloc-compat1) \
+ || die "econf failed"
+
+}
+
+src_compile() {
+
+ emake showflags || die "emake showflags failed"
+ emake shared-build || die "emake shared-build failed"
+
+}
+
+src_install() {
+
+ emake install DESTDIR="${D}" || die "emake install failed"
+ dolib.a sharedbuild/lib/libtalloc.a
+ dolib.so sharedbuild/lib/libtalloc.so
+
+}