summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2005-03-25 06:17:28 +0000
committerMike Frysinger <vapier@gentoo.org>2005-03-25 06:17:28 +0000
commit48952ae4ef706c4437c985da49e5c90a54d730e0 (patch)
tree93659b0fcecf5406975bba1e977b37824029953c /sys-libs
parentUpdate gtk2 patch (from Arnaud Lech via bug #86156); tidy ebuild (diff)
downloadhistorical-48952ae4ef706c4437c985da49e5c90a54d730e0.tar.gz
historical-48952ae4ef706c4437c985da49e5c90a54d730e0.tar.bz2
historical-48952ae4ef706c4437c985da49e5c90a54d730e0.zip
use Stefan suggestion of executing ld-linux and having it setup the library path so we get a 'clean' env for the simple tests #86465
Package-Manager: portage-2.0.51.19
Diffstat (limited to 'sys-libs')
-rw-r--r--sys-libs/glibc/Manifest4
-rw-r--r--sys-libs/glibc/glibc-2.3.4.20041102-r1.ebuild14
-rw-r--r--sys-libs/glibc/glibc-2.3.4.20050125-r1.ebuild14
3 files changed, 22 insertions, 10 deletions
diff --git a/sys-libs/glibc/Manifest b/sys-libs/glibc/Manifest
index b9d9c864d99d..1dfdd9d14bf7 100644
--- a/sys-libs/glibc/Manifest
+++ b/sys-libs/glibc/Manifest
@@ -6,10 +6,10 @@ MD5 567094e03359ffc1c95af7356395228d metadata.xml 162
MD5 a26e42322d862d7095594da1f136355d glibc-2.3.3.20040420-r2.ebuild 21675
MD5 767c346185a37cd59e79614af21e9d7b glibc-2.3.4.20040619-r2.ebuild 21251
MD5 aec4e31cb25fa6043f71ca4940acaae6 glibc-2.3.4.20040808-r1.ebuild 27641
-MD5 1fb1097666f68aefbbf8847e7996e6a5 glibc-2.3.4.20041102-r1.ebuild 33257
+MD5 f38816c382b39bdfb6b8b8b13005dbe4 glibc-2.3.4.20041102-r1.ebuild 33460
MD5 5c6ef4eae3725638db24b736365d2786 glibc-2.3.4.20041102.ebuild 32910
MD5 9c5ecabb9eb1f7311e9b3b44f825347b glibc-2.3.4.20050125.ebuild 35419
-MD5 e17b49f8f56e7346c0fb61460a6e2b3d glibc-2.3.4.20050125-r1.ebuild 37478
+MD5 b19573606a6ee0ce3a675a51282841c8 glibc-2.3.4.20050125-r1.ebuild 37681
MD5 9cc1e6b6f749dba7c8759bd07266f7d9 files/digest-glibc-2.2.5-r9 143
MD5 2d5306ef875573750af642a9f93b634a files/digest-glibc-2.3.2-r12 312
MD5 42af7e35fe2404a49954f91fd1aee891 files/digest-glibc-2.3.3.20040420-r2 312
diff --git a/sys-libs/glibc/glibc-2.3.4.20041102-r1.ebuild b/sys-libs/glibc/glibc-2.3.4.20041102-r1.ebuild
index 66411e9aa745..2558498bc880 100644
--- a/sys-libs/glibc/glibc-2.3.4.20041102-r1.ebuild
+++ b/sys-libs/glibc/glibc-2.3.4.20041102-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/glibc/glibc-2.3.4.20041102-r1.ebuild,v 1.4 2005/03/24 23:21:14 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/glibc/glibc-2.3.4.20041102-r1.ebuild,v 1.5 2005/03/25 06:17:28 vapier Exp $
inherit eutils multilib flag-o-matic toolchain-funcs versionator
@@ -1003,9 +1003,15 @@ EOF
# example host.conf with multicast dns disabled by default
doins ${FILESDIR}/2.3.4/host.conf
- for x in ls ps date ; do
- [[ -z $(type -p ${x}) ]] && continue
- env LD_LIBRARY_PATH="${D}/$(get_libdir)" ${x} > /dev/null \
+ # simple test to make sure our new glibc isnt completely broken.
+ # for now, skip the multilib scenario.
+ [[ $(get_libdir) != "lib" ]] && return 0
+ for x in date env ls true uname ; do
+ x=$(type -p ${x})
+ [[ -z ${x} ]] && continue
+ "${D}"/$(get_libdir)/ld-*.so \
+ --library-path "${D}"/$(get_libdir) \
+ ${x} > /dev/null \
|| die "simple run test (${x}) failed"
done
}
diff --git a/sys-libs/glibc/glibc-2.3.4.20050125-r1.ebuild b/sys-libs/glibc/glibc-2.3.4.20050125-r1.ebuild
index 8c985fbf5eb5..7157e8e27947 100644
--- a/sys-libs/glibc/glibc-2.3.4.20050125-r1.ebuild
+++ b/sys-libs/glibc/glibc-2.3.4.20050125-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/glibc/glibc-2.3.4.20050125-r1.ebuild,v 1.31 2005/03/24 23:21:14 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/glibc/glibc-2.3.4.20050125-r1.ebuild,v 1.32 2005/03/25 06:17:28 vapier Exp $
# Here's how the cross-compile logic breaks down ...
# CTARGET - machine that will target the binaries
@@ -484,9 +484,15 @@ toolchain-glibc_src_install() {
# example host.conf with multicast dns disabled by default
doins ${FILESDIR}/2.3.4/host.conf
- for x in ls ps date ; do
- [[ -z $(type -p ${x}) ]] && continue
- env LD_LIBRARY_PATH="${D}/$(get_libdir)" ${x} > /dev/null \
+ # simple test to make sure our new glibc isnt completely broken.
+ # for now, skip the multilib scenario.
+ [[ $(get_libdir) != "lib" ]] && return 0
+ for x in date env ls true uname ; do
+ x=$(type -p ${x})
+ [[ -z ${x} ]] && continue
+ "${D}"/$(get_libdir)/ld-*.so \
+ --library-path "${D}"/$(get_libdir) \
+ ${x} > /dev/null \
|| die "simple run test (${x}) failed"
done
}