summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMartin Schlemmer <azarah@gentoo.org>2002-10-23 18:00:57 +0000
committerMartin Schlemmer <azarah@gentoo.org>2002-10-23 18:00:57 +0000
commit561875140204befcac07ccb0975b6814fd15c69b (patch)
treed97268fce37665dc3c6f8b94362c13aad3b51853 /sys-libs
parentheader fixes (diff)
downloadhistorical-561875140204befcac07ccb0975b6814fd15c69b.tar.gz
historical-561875140204befcac07ccb0975b6814fd15c69b.tar.bz2
historical-561875140204befcac07ccb0975b6814fd15c69b.zip
fix some bootstrap issues with 5.3
Diffstat (limited to 'sys-libs')
-rw-r--r--sys-libs/ncurses/ChangeLog10
-rw-r--r--sys-libs/ncurses/ncurses-5.3.ebuild19
2 files changed, 26 insertions, 3 deletions
diff --git a/sys-libs/ncurses/ChangeLog b/sys-libs/ncurses/ChangeLog
index e087f36c0839..cf14bf067ae6 100644
--- a/sys-libs/ncurses/ChangeLog
+++ b/sys-libs/ncurses/ChangeLog
@@ -1,9 +1,17 @@
# ChangeLog for sys-libs/ncurses
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/ncurses/ChangeLog,v 1.14 2002/10/17 17:52:14 raker Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/ncurses/ChangeLog,v 1.15 2002/10/23 18:00:57 azarah Exp $
*ncurses-5.3 (17 Oct 2002)
+ 23 Oct 2002; Martin Schlemmer <azarah@gentoo.org> ncurses-5.3.ebuild :
+
+ Because ncurses-5.3 have c++ bindings, we cannot enable them during
+ bootstrap. Thus disable it if "build" or "bootstrap" in USE, and
+ then get bootstrap.sh to rebuild it afterwards without those flags.
+ Also fix a problem where old build images had ncurses-5.2 libs, which
+ did not get removed.
+
17 Oct 2002; Nick Hadaway <raker@gentoo.org> ncurses-5.3.ebuild,
files/digest-ncurses-5.3 :
New version of ncurses. Many years worth of fixes culminating to a
diff --git a/sys-libs/ncurses/ncurses-5.3.ebuild b/sys-libs/ncurses/ncurses-5.3.ebuild
index d55437f8c2c0..45a5cd134550 100644
--- a/sys-libs/ncurses/ncurses-5.3.ebuild
+++ b/sys-libs/ncurses/ncurses-5.3.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2002 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/ncurses/ncurses-5.3.ebuild,v 1.2 2002/10/20 06:06:47 azarah Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/ncurses/ncurses-5.3.ebuild,v 1.3 2002/10/23 18:00:57 azarah Exp $
IUSE=""
@@ -22,6 +22,14 @@ src_compile() {
[ -z "${DEBUGBUILD}" ] && myconf="${myconf} --without-debug"
+ # From version 5.3, ncurses also build c++ bindings, and as
+ # we do not have a c++ compiler during bootstrap, disable
+ # building it. We will rebuild ncurses after gcc's second
+ # build in bootstrap.sh.
+ # <azarah@gentoo.org> (23 Oct 2002)
+ ( use build || use bootstrap ) \
+ && myconf="${myconf} --without-cxx --without-cxx-binding"
+
econf \
--libdir=/lib \
--disable-termcap \
@@ -29,7 +37,8 @@ src_compile() {
--with-rcs-ids \
${myconf} || die "configure failed"
- emake || die "parallel make failed"
+ # do not work with -j2 on P4 - <azarah@gentoo.org> (23 Oct 2002)
+ make || die "parallel make failed"
}
src_install() {
@@ -70,3 +79,9 @@ src_install() {
fi
}
+pkg_postinst() {
+
+ # Old ncurses may still be around from old build tbz2's.
+ rm -f /lib/libncurses.so.5.2
+ rm -f /usr/lib/lib{form,menu,panel}.so.5.2
+}