summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTravis Tilley <lv@gentoo.org>2004-08-29 05:15:38 +0000
committerTravis Tilley <lv@gentoo.org>2004-08-29 05:15:38 +0000
commit72736a102d96977a8cf8b1f900c83c6e536f7b52 (patch)
treeedd8ecef67e20289f4804ad9639abdb58368f8fc /sys-libs
parentfix DESCRIPTION (bug #62066) (diff)
downloadhistorical-72736a102d96977a8cf8b1f900c83c6e536f7b52.tar.gz
historical-72736a102d96977a8cf8b1f900c83c6e536f7b52.tar.bz2
historical-72736a102d96977a8cf8b1f900c83c6e536f7b52.zip
bump
Diffstat (limited to 'sys-libs')
-rw-r--r--sys-libs/libstdc++-v3/ChangeLog7
-rw-r--r--sys-libs/libstdc++-v3/Manifest4
-rw-r--r--sys-libs/libstdc++-v3/files/digest-libstdc++-v3-3.3.41
-rw-r--r--sys-libs/libstdc++-v3/libstdc++-v3-3.3.4.ebuild234
4 files changed, 244 insertions, 2 deletions
diff --git a/sys-libs/libstdc++-v3/ChangeLog b/sys-libs/libstdc++-v3/ChangeLog
index cfe1a9464233..e24f8492080e 100644
--- a/sys-libs/libstdc++-v3/ChangeLog
+++ b/sys-libs/libstdc++-v3/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sys-libs/libstdc++-v3
# Copyright 2000-2004 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/libstdc++-v3/ChangeLog,v 1.20 2004/08/28 15:51:25 solar Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/libstdc++-v3/ChangeLog,v 1.21 2004/08/29 05:15:37 lv Exp $
+
+*libstdc++-v3-3.3.4 (29 Aug 2004)
+
+ 29 Aug 2004; Travis Tilley <lv@gentoo.org> +libstdc++-v3-3.3.4.ebuild:
+ version bump
28 Aug 2004; <solar@gentoo.org> libstdc++-v3-3.3.3-r1.ebuild:
added call to gnuconfig_update
diff --git a/sys-libs/libstdc++-v3/Manifest b/sys-libs/libstdc++-v3/Manifest
index a3c5e876fb91..4c0cb1dcc6b1 100644
--- a/sys-libs/libstdc++-v3/Manifest
+++ b/sys-libs/libstdc++-v3/Manifest
@@ -1,5 +1,7 @@
MD5 83ad16cfcb4ae981035ef8c9f8127d93 libstdc++-v3-3.3.3-r1.ebuild 6296
-MD5 25a914ef0e12f0e5cdd15e2a436da419 ChangeLog 3155
+MD5 baddea7d9d3ee61cc907f5ce960b3449 libstdc++-v3-3.3.4.ebuild 6329
+MD5 41b93016ef40d3f610cddbd0dbab4fec ChangeLog 3276
MD5 b6c1db1060c4e856b248a22adec1ff53 metadata.xml 220
MD5 b2a96584f4cee72362695ba44c911c40 files/libstdc++_amd64_multilib_hack.patch 350
+MD5 4068b84d9ce9d440b063718549cfc354 files/digest-libstdc++-v3-3.3.4 64
MD5 14f4d6619c938dbb907e2420c0eeefd9 files/digest-libstdc++-v3-3.3.3-r1 64
diff --git a/sys-libs/libstdc++-v3/files/digest-libstdc++-v3-3.3.4 b/sys-libs/libstdc++-v3/files/digest-libstdc++-v3-3.3.4
new file mode 100644
index 000000000000..fe96fb0b69f8
--- /dev/null
+++ b/sys-libs/libstdc++-v3/files/digest-libstdc++-v3-3.3.4
@@ -0,0 +1 @@
+MD5 a1c267b34f05c8660b24251865614d8b gcc-3.3.4.tar.bz2 23331664
diff --git a/sys-libs/libstdc++-v3/libstdc++-v3-3.3.4.ebuild b/sys-libs/libstdc++-v3/libstdc++-v3-3.3.4.ebuild
new file mode 100644
index 000000000000..9a5731b93d2d
--- /dev/null
+++ b/sys-libs/libstdc++-v3/libstdc++-v3-3.3.4.ebuild
@@ -0,0 +1,234 @@
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/libstdc++-v3/libstdc++-v3-3.3.4.ebuild,v 1.1 2004/08/29 05:15:37 lv Exp $
+
+inherit eutils flag-o-matic libtool gnuconfig
+
+do_filter_flags() {
+ declare setting
+
+ strip-flags
+
+ # In general gcc does not like optimization, and add -O2 where
+ # it is safe. This is especially true for gcc 3.3 + 3.4
+ replace-flags -O? -O2
+
+ if use amd64
+ then
+ # gcc 3.3 doesn't support -march=k8/etc on amd64, so xgcc will fail
+ setting="`get-flag march`"
+ [ ! -z "${setting}" ] && filter-flags -march="${setting}"
+ fi
+
+ # and on x86, we just need to filter the 3.4 specific amd64 -marchs
+ filter-flags -march=k8
+ filter-flags -march=athlon64
+ filter-flags -march=opteron
+
+ # gcc 3.3 doesn't support -march=pentium-m
+ replace-flags -march=pentium-m -march=pentium3
+
+ # gcc 3.3 doesn't support -mtune on numerous archs, so xgcc will fail
+ if use x86 || use amd64 ; then
+ setting="`get-flag mtune`"
+ [ ! -z "${setting}" ] && filter-flags -mtune="${setting}"
+ fi
+
+ # xgcc wont understand gcc 3.4 flags...
+ filter-flags -fno-unit-at-a-time
+ filter-flags -funit-at-a-time
+ filter-flags -fweb
+ filter-flags -fno-web
+
+ # xgcc isnt patched with propolice
+ filter-flags -fstack-protector-all
+ filter-flags -fno-stack-protector-all
+ filter-flags -fstack-protector
+ filter-flags -fno-stack-protector
+
+ # xgcc isnt patched with the gcc symbol visibility patch
+ filter-flags -fvisibility-inlines-hidden
+ filter-flags -fvisibility=hidden
+
+ # ...sure, why not?
+ strip-unsupported-flags
+}
+
+S=${WORKDIR}/gcc-${PV}
+
+# Theoretical cross compiler support
+[ ! -n "${CCHOST}" ] && export CCHOST="${CHOST}"
+
+LOC="/usr"
+MY_PV="`echo ${PV} | awk -F. '{ gsub(/_pre.*|_alpha.*/, ""); print $1 "." $2 }'`"
+MY_PV_FULL="`echo ${PV} | awk '{ gsub(/_pre.*|_alpha.*/, ""); print $0 }'`"
+
+LIBPATH="${LOC}/lib/gcc-lib/${CCHOST}/${MY_PV_FULL}"
+BINPATH="${LOC}/${CCHOST}/gcc-bin/${MY_PV}"
+DATAPATH="${LOC}/share/gcc-data/${CCHOST}/${MY_PV}"
+# Dont install in /usr/include/g++-v3/, but in gcc internal directory.
+# We will handle /usr/include/g++-v3/ with gcc-config ...
+STDCXX_INCDIR="${LIBPATH}/include/g++-v${MY_PV/\.*/}"
+
+SRC_URI="ftp://gcc.gnu.org/pub/gcc/releases/gcc-${PV}/gcc-${PV}.tar.bz2"
+
+DESCRIPTION="Compatibility package for running binaries linked against a pre gcc 3.4 libstdc++"
+HOMEPAGE="http://gcc.gnu.org/libstdc++/"
+
+LICENSE="GPL-2 LGPL-2.1"
+
+KEYWORDS="-* ~x86 ~mips ~amd64 ~ppc64 ~ppc"
+IUSE="nls"
+
+if [ "${CHOST}" == "${CCHOST}" ]
+then
+ SLOT="3.3.3"
+else
+ SLOT="${CCHOST}-3.3.3"
+fi
+
+DEPEND="virtual/libc
+ !nptl? ( !uclibc? ( >=sys-libs/glibc-2.3.2-r3 ) )
+ >=sys-devel/binutils-2.14.90.0.6-r1
+ >=sys-devel/bison-1.875
+ >=sys-devel/gcc-config-1.3.1
+ >=sys-devel/gcc-3.3.3_pre20040130
+ !build? ( >=sys-libs/ncurses-5.2-r2
+ nls? ( sys-devel/gettext ) )"
+
+RDEPEND="virtual/libc
+ !nptl? ( !uclibc? ( >=sys-libs/glibc-2.3.2-r3 ) )
+ >=sys-devel/gcc-config-1.3.1
+ >=sys-libs/zlib-1.1.4
+ >=sys-apps/texinfo-4.2-r4
+ !build? ( >=sys-libs/ncurses-5.2-r2 )"
+
+PDEPEND="sys-devel/gcc-config"
+
+src_unpack() {
+ unpack ${A}
+
+ cd ${S}
+ # Fixup libtool to correctly generate .la files with portage
+ elibtoolize --portage --shallow
+
+ use amd64 && epatch ${FILESDIR}/libstdc++_amd64_multilib_hack.patch
+
+ # Misdesign in libstdc++ (Redhat)
+ cp -a ${S}/libstdc++-v3/config/cpu/i{4,3}86/atomicity.h
+
+ cd ${S}; ./contrib/gcc_update --touch &> /dev/null
+ gnuconfig_update
+}
+
+src_compile() {
+
+ local myconf=
+
+ if ! use nls || use build
+ then
+ myconf="${myconf} --disable-nls"
+ else
+ myconf="${myconf} --enable-nls --without-included-gettext"
+ fi
+
+ use amd64 && myconf="${myconf} --disable-multilib"
+
+ do_filter_flags
+ einfo "CFLAGS=\"${CFLAGS}\""
+ einfo "CXXFLAGS=\"${CXXFLAGS}\""
+
+ # Build in a separate build tree
+ mkdir -p ${WORKDIR}/build
+ cd ${WORKDIR}/build
+
+ einfo "Configuring libstdc++..."
+ addwrite "/dev/zero"
+ ${S}/configure --prefix=${LOC} \
+ --bindir=${BINPATH} \
+ --includedir=${LIBPATH}/include \
+ --datadir=${DATAPATH} \
+ --mandir=${DATAPATH}/man \
+ --infodir=${DATAPATH}/info \
+ --enable-shared \
+ --host=${CHOST} \
+ --target=${CCHOST} \
+ --with-system-zlib \
+ --enable-languages=c++ \
+ --enable-threads=posix \
+ --enable-long-long \
+ --disable-checking \
+ --enable-cstdio=stdio \
+ --enable-__cxa_atexit \
+ --enable-version-specific-runtime-libs \
+ --with-gxx-include-dir=${STDCXX_INCDIR} \
+ --with-local-prefix=${LOC}/local \
+ ${myconf} || die
+
+ touch ${S}/gcc/c-gperf.h
+
+ # Setup -j in MAKEOPTS
+ get_number_of_jobs
+
+ einfo "Compiling libstdc++..."
+ S="${WORKDIR}/build" \
+ emake all-target-libstdc++-v3 \
+ LIBPATH="${LIBPATH}" \
+ BOOT_CFLAGS="${CFLAGS}" STAGE1_CFLAGS="-O" || die
+}
+
+src_install() {
+ local x=
+
+ # Do allow symlinks in ${LOC}/lib/gcc-lib/${CHOST}/${PV}/include as
+ # this can break the build.
+ for x in ${WORKDIR}/build/gcc/include/*
+ do
+ if [ -L ${x} ]
+ then
+ rm -f ${x}
+ continue
+ fi
+ done
+ # Remove generated headers, as they can cause things to break
+ # (ncurses, openssl, etc).
+ for x in `find ${WORKDIR}/build/gcc/include/ -name '*.h'`
+ do
+ if grep -q 'It has been auto-edited by fixincludes from' ${x}
+ then
+ rm -f ${x}
+ fi
+ done
+
+ einfo "Installing libstdc++..."
+ # Do the 'make install' from the build directory
+ cd ${WORKDIR}/build
+ S="${WORKDIR}/build" \
+ make prefix=${LOC} \
+ bindir=${BINPATH} \
+ includedir=${LIBPATH}/include \
+ datadir=${DATAPATH} \
+ mandir=${DATAPATH}/man \
+ infodir=${DATAPATH}/info \
+ DESTDIR="${D}" \
+ LIBPATH="${LIBPATH}" \
+ install-target-libstdc++-v3 || die
+
+ # we'll move this into a directory we can put at the end of ld.so.conf
+ # other than the normal versioned directory, so that it doesnt conflict
+ # with gcc 3.3.3
+ mkdir -p ${D}/${LOC}/lib/libstdc++-v3/
+ mv ${D}/${LIBPATH}/lib* ${D}/${LOC}/lib/libstdc++-v3/
+ # we dont want the headers...
+ rm -rf ${D}/${LOC}/lib/gcc*
+ # or locales...
+ rm -rf ${D}/${LOC}/share
+ # or anything other than the .so files, really.
+ find ${D} | grep -e c++.la$ -e c++.a$ | xargs rm -f
+ # we dont even want the un-versioned .so symlink, as it confuses some
+ # apps and also causes others to link against the old libstdc++...
+ rm ${D}/${LOC}/lib/libstdc++-v3/libstdc++.so
+
+ mkdir -p ${D}/etc/env.d/
+ echo "LDPATH=\"${LOC}/lib/libstdc++-v3/\"" >> ${D}/etc/env.d/99libstdc++
+}