summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAnthony G. Basile <blueness@gentoo.org>2012-05-25 11:19:39 +0000
committerAnthony G. Basile <blueness@gentoo.org>2012-05-25 11:19:39 +0000
commitbb1440804da0957bd2dbc63696cb52fe32ea7b63 (patch)
tree33efc8ac530bc2d1c1b2634206cc54d59de36708 /sys-libs
parentFix passing of O3 to cflags. Thanks to ago. (diff)
downloadhistorical-bb1440804da0957bd2dbc63696cb52fe32ea7b63.tar.gz
historical-bb1440804da0957bd2dbc63696cb52fe32ea7b63.tar.bz2
historical-bb1440804da0957bd2dbc63696cb52fe32ea7b63.zip
Initial commit, thanks Ed Wildgoose, bug #292189
Package-Manager: portage-2.1.10.49/cvs/Linux x86_64
Diffstat (limited to 'sys-libs')
-rw-r--r--sys-libs/argp-standalone/ChangeLog11
-rw-r--r--sys-libs/argp-standalone/Manifest15
-rw-r--r--sys-libs/argp-standalone/argp-standalone-1.3.ebuild27
-rw-r--r--sys-libs/argp-standalone/files/argp-standalone-1.3-throw-in-funcdef.patch79
-rw-r--r--sys-libs/argp-standalone/metadata.xml12
5 files changed, 144 insertions, 0 deletions
diff --git a/sys-libs/argp-standalone/ChangeLog b/sys-libs/argp-standalone/ChangeLog
new file mode 100644
index 000000000000..079f56ca001b
--- /dev/null
+++ b/sys-libs/argp-standalone/ChangeLog
@@ -0,0 +1,11 @@
+# ChangeLog for sys-libs/argp-standalone
+# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/argp-standalone/ChangeLog,v 1.1 2012/05/25 11:19:38 blueness Exp $
+
+*argp-standalone-1.3 (25 May 2012)
+
+ 25 May 2012; Anthony G. Basile <blueness@gentoo.org>
+ +argp-standalone-1.3.ebuild,
+ +files/argp-standalone-1.3-throw-in-funcdef.patch, +metadata.xml:
+ Initial commit, thanks Ed Wildgoose, bug #292189
+
diff --git a/sys-libs/argp-standalone/Manifest b/sys-libs/argp-standalone/Manifest
new file mode 100644
index 000000000000..4a4188eeefc7
--- /dev/null
+++ b/sys-libs/argp-standalone/Manifest
@@ -0,0 +1,15 @@
+-----BEGIN PGP SIGNED MESSAGE-----
+Hash: SHA256
+
+AUX argp-standalone-1.3-throw-in-funcdef.patch 2500 RMD160 58f55f827d1f154e8587f9d9bf44e82dacab7bc5 SHA1 d03426a8de2b7f6f16ca32917ed344464d8a0ad2 SHA256 46b9b6c8dba584694ae9fc17c5fa301056500128f1f0c548360574afe6b3a184
+DIST argp-standalone-1.3.tar.gz 130255 RMD160 1c5cd0b1c382d93774be636a1ea2758d530cfef4 SHA1 815c560680ebdc11694b88de2f8ec15133e0bfa0 SHA256 dec79694da1319acd2238ce95df57f3680fea2482096e483323fddf3d818d8be
+EBUILD argp-standalone-1.3.ebuild 665 RMD160 5de6af1be8ae0c6ed8a70497d0d1dc6b07dbd6fc SHA1 b1a583b26b23fa4604e9ba34bbc717e711f2f978 SHA256 3879b8e6c115335b0f98e64c664ebc4d838b4e1e3f40dc8e42b480f668b17246
+MISC ChangeLog 465 RMD160 014aa6c1c691c8c426f39d48a51d495f771120b9 SHA1 8c87293bca27e1eaf7c88a8f71e6f258912779ce SHA256 ce2e274b233bb92ca13cf6c9bb4190d168ffc5b42ed18ee638f61fcb45f3bac9
+MISC metadata.xml 334 RMD160 82b9b14c604874758d6f657421a14481ce3bf10b SHA1 798756600d80f9db6e2cb34e8fcf84ce3b19d75b SHA256 a567bcc7b260890a6dc0c29d46f23a37ebb4ca3c26a51e62d2bef4899d76afeb
+-----BEGIN PGP SIGNATURE-----
+Version: GnuPG v2.0.17 (GNU/Linux)
+
+iEYEAREIAAYFAk+/atgACgkQl5yvQNBFVTU3gwCfWFZBYY0/Pv3BMYwX/ZIgE19R
+GeEAoKN1S+ATFGxMT4ejn9HKqN/IG2YB
+=T0F8
+-----END PGP SIGNATURE-----
diff --git a/sys-libs/argp-standalone/argp-standalone-1.3.ebuild b/sys-libs/argp-standalone/argp-standalone-1.3.ebuild
new file mode 100644
index 000000000000..7e617cae1398
--- /dev/null
+++ b/sys-libs/argp-standalone/argp-standalone-1.3.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/argp-standalone/argp-standalone-1.3.ebuild,v 1.1 2012/05/25 11:19:38 blueness Exp $
+
+EAPI="4"
+
+inherit eutils
+
+DESCRIPTION="Standalone argp library for use with uclibc"
+HOMEPAGE="http://www.lysator.liu.se/~nisse/misc/"
+SRC_URI="http://www.lysator.liu.se/~nisse/misc/argp-standalone-1.3.tar.gz"
+
+LICENSE="public-domain"
+SLOT="0"
+KEYWORDS="~amd64 ~mips ~ppc ~x86"
+IUSE=""
+
+src_prepare() {
+ epatch "${FILESDIR}/${P}-throw-in-funcdef.patch"
+}
+
+src_install() {
+ dolib.a libargp.a
+
+ insinto /usr/include
+ doins argp.h
+}
diff --git a/sys-libs/argp-standalone/files/argp-standalone-1.3-throw-in-funcdef.patch b/sys-libs/argp-standalone/files/argp-standalone-1.3-throw-in-funcdef.patch
new file mode 100644
index 000000000000..4a90751e1e62
--- /dev/null
+++ b/sys-libs/argp-standalone/files/argp-standalone-1.3-throw-in-funcdef.patch
@@ -0,0 +1,79 @@
+# --- T2-COPYRIGHT-NOTE-BEGIN ---
+# This copyright note is auto-generated by ./scripts/Create-CopyPatch.
+#
+# T2 SDE: package/.../rng-tools/throw-in-funcdef.patch.argp-standalone
+# Copyright (C) 2006 The T2 SDE Project
+#
+# More information can be found in the files COPYING and README.
+#
+# This patch file is dual-licensed. It is available under the license the
+# patched project is licensed under, as long as it is an OpenSource license
+# as defined at http://www.opensource.org/ (e.g. BSD, X11) or under the terms
+# of the GNU General Public License as published by the Free Software
+# Foundation; either version 2 of the License, or (at your option) any later
+# version.
+# --- T2-COPYRIGHT-NOTE-END ---
+
+
+No __THROW in function implementation.
+ --jsaw
+
+--- argp-standalone-1.4-test2/argp.h.orig 2006-01-06 02:29:59.000000000 +0100
++++ argp-standalone-1.4-test2/argp.h 2006-01-06 02:41:10.000000000 +0100
+@@ -560,17 +560,17 @@
+ # endif
+
+ # ifndef ARGP_EI
+-# define ARGP_EI extern __inline__
++# define ARGP_EI extern inline
+ # endif
+
+ ARGP_EI void
+-__argp_usage (__const struct argp_state *__state) __THROW
++__argp_usage (__const struct argp_state *__state)
+ {
+ __argp_state_help (__state, stderr, ARGP_HELP_STD_USAGE);
+ }
+
+ ARGP_EI int
+-__option_is_short (__const struct argp_option *__opt) __THROW
++__option_is_short (__const struct argp_option *__opt)
+ {
+ if (__opt->flags & OPTION_DOC)
+ return 0;
+@@ -582,7 +582,7 @@
+ }
+
+ ARGP_EI int
+-__option_is_end (__const struct argp_option *__opt) __THROW
++__option_is_end (__const struct argp_option *__opt)
+ {
+ return !__opt->key && !__opt->name && !__opt->doc && !__opt->group;
+ }
+--- argp-standalone-1.4-test2/argp-parse.c.orig 2006-01-06 02:47:48.000000000 +0100
++++ argp-standalone-1.4-test2/argp-parse.c 2006-01-06 02:48:16.000000000 +0100
+@@ -1290,13 +1290,13 @@
+ /* Defined here, in case a user is not inlining the definitions in
+ * argp.h */
+ void
+-__argp_usage (__const struct argp_state *__state) __THROW
++__argp_usage (__const struct argp_state *__state)
+ {
+ __argp_state_help (__state, stderr, ARGP_HELP_STD_USAGE);
+ }
+
+ int
+-__option_is_short (__const struct argp_option *__opt) __THROW
++__option_is_short (__const struct argp_option *__opt)
+ {
+ if (__opt->flags & OPTION_DOC)
+ return 0;
+@@ -1310,7 +1310,7 @@
+ }
+
+ int
+-__option_is_end (__const struct argp_option *__opt) __THROW
++__option_is_end (__const struct argp_option *__opt)
+ {
+ return !__opt->key && !__opt->name && !__opt->doc && !__opt->group;
+ }
diff --git a/sys-libs/argp-standalone/metadata.xml b/sys-libs/argp-standalone/metadata.xml
new file mode 100644
index 000000000000..d4bc42416584
--- /dev/null
+++ b/sys-libs/argp-standalone/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>blueness@gentoo.org</email>
+ <name>Anthony G. Basile</name>
+ </maintainer>
+ <maintainer>
+ <email>gentoo@wildgooses.com</email>
+ <name>Ed Wildgoose</name>
+ </maintainer>
+</pkgmetadata>