summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2005-05-13 00:32:18 +0000
committerRobin H. Johnson <robbat2@gentoo.org>2005-05-13 00:32:18 +0000
commitdfff3e80e3b47c3c9d92e12e78d9b2fa1359914f (patch)
treecae3407fe6b5db034dbecc59af9e1aefa504d546 /sys-power/iasl/iasl-20050309.ebuild
parenthave_NPTL isnt used anymore (diff)
downloadhistorical-dfff3e80e3b47c3c9d92e12e78d9b2fa1359914f.tar.gz
historical-dfff3e80e3b47c3c9d92e12e78d9b2fa1359914f.tar.bz2
historical-dfff3e80e3b47c3c9d92e12e78d9b2fa1359914f.zip
Initial commit. Based on ebuild by Micheal <michi2k@web.de>, bug #52511.
Package-Manager: portage-2.0.51.21
Diffstat (limited to 'sys-power/iasl/iasl-20050309.ebuild')
-rw-r--r--sys-power/iasl/iasl-20050309.ebuild25
1 files changed, 25 insertions, 0 deletions
diff --git a/sys-power/iasl/iasl-20050309.ebuild b/sys-power/iasl/iasl-20050309.ebuild
new file mode 100644
index 000000000000..1953a7e4f153
--- /dev/null
+++ b/sys-power/iasl/iasl-20050309.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2005 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-power/iasl/iasl-20050309.ebuild,v 1.1 2005/05/13 00:32:18 robbat2 Exp $
+
+MY_PN="acpica-unix"
+MY_P="${MY_PN}-${PV}"
+DESCRIPTION="Intel ACPI Source Language (ASL) compiler"
+HOMEPAGE="http://www.intel.com/technology/iapc/acpi/"
+SRC_URI="${HOMEPAGE}/downloads/${MY_P}.tar.gz"
+LICENSE="iASL"
+SLOT="0"
+KEYWORDS="~x86"
+IUSE=""
+DEPEND="virtual/libc"
+S="${WORKDIR}/${MY_P}"
+
+src_compile() {
+ cd ${S}/compiler
+ emake || die "make failed"
+}
+
+src_install() {
+ dobin compiler/iasl || die "iasl binary not created"
+ dodoc ${S}/README || die "README not found"
+}