summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2009-12-18 15:58:30 +0000
committerMike Frysinger <vapier@gentoo.org>2009-12-18 15:58:30 +0000
commite3bfa728be3bad11a3bfcec48df76ddedf81fbe5 (patch)
tree6a6c47e4f40fb31c163cae2da537fea5c2ce1f77 /sys-process/latencytop/latencytop-0.5.ebuild
parentMarked ~x86-solaris and ~ppc-macos, new dependency for inkscape (diff)
downloadhistorical-e3bfa728be3bad11a3bfcec48df76ddedf81fbe5.tar.gz
historical-e3bfa728be3bad11a3bfcec48df76ddedf81fbe5.tar.bz2
historical-e3bfa728be3bad11a3bfcec48df76ddedf81fbe5.zip
Version bump #297161 by Xake.
Package-Manager: portage-2.2_rc55/cvs/Linux x86_64
Diffstat (limited to 'sys-process/latencytop/latencytop-0.5.ebuild')
-rw-r--r--sys-process/latencytop/latencytop-0.5.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/sys-process/latencytop/latencytop-0.5.ebuild b/sys-process/latencytop/latencytop-0.5.ebuild
new file mode 100644
index 000000000000..12cfe7b89567
--- /dev/null
+++ b/sys-process/latencytop/latencytop-0.5.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-process/latencytop/latencytop-0.5.ebuild,v 1.1 2009/12/18 15:58:29 vapier Exp $
+
+inherit eutils toolchain-funcs
+
+DESCRIPTION="tool for identifying where in the system latency is happening"
+HOMEPAGE="http://www.latencytop.org/"
+SRC_URI="http://www.latencytop.org/download/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="gtk unicode"
+
+RDEPEND="=dev-libs/glib-2*
+ gtk? ( =x11-libs/gtk+-2* )
+ sys-libs/ncurses"
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}"/${P}-*.patch
+}
+
+src_compile() {
+ tc-export CC PKG_CONFIG
+ emake HAS_GTK_GUI=$(use gtk && echo 1) || die
+}
+
+src_install() {
+ emake install DESTDIR="${D}" || die
+}