summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGilles Dartiguelongue <eva@gentoo.org>2010-08-31 18:37:36 +0000
committerGilles Dartiguelongue <eva@gentoo.org>2010-08-31 18:37:36 +0000
commit74b1ff8f35a898e323e450e4ff4168d7318e2328 (patch)
tree550c48f57e2ac5680b84d0eb015c172feecfa8ee /www-client/epiphany-extensions
parentVersion bump. Backported fixes from master. (diff)
downloadhistorical-74b1ff8f35a898e323e450e4ff4168d7318e2328.tar.gz
historical-74b1ff8f35a898e323e450e4ff4168d7318e2328.tar.bz2
historical-74b1ff8f35a898e323e450e4ff4168d7318e2328.zip
Version bump.
Package-Manager: portage-2.2_rc72/cvs/Linux x86_64
Diffstat (limited to 'www-client/epiphany-extensions')
-rw-r--r--www-client/epiphany-extensions/ChangeLog9
-rw-r--r--www-client/epiphany-extensions/epiphany-extensions-2.26.1.ebuild89
-rw-r--r--www-client/epiphany-extensions/epiphany-extensions-2.30.1.ebuild5
-rw-r--r--www-client/epiphany-extensions/epiphany-extensions-2.30.2.ebuild65
4 files changed, 75 insertions, 93 deletions
diff --git a/www-client/epiphany-extensions/ChangeLog b/www-client/epiphany-extensions/ChangeLog
index 780e33c74642..03db8c225ae2 100644
--- a/www-client/epiphany-extensions/ChangeLog
+++ b/www-client/epiphany-extensions/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for www-client/epiphany-extensions
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/www-client/epiphany-extensions/ChangeLog,v 1.133 2010/08/01 11:55:08 fauli Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-client/epiphany-extensions/ChangeLog,v 1.134 2010/08/31 18:37:36 eva Exp $
+
+*epiphany-extensions-2.30.2 (31 Aug 2010)
+
+ 31 Aug 2010; Gilles Dartiguelongue <eva@gentoo.org>
+ -epiphany-extensions-2.26.1.ebuild, epiphany-extensions-2.30.1.ebuild,
+ +epiphany-extensions-2.30.2.ebuild:
+ Version bump.
01 Aug 2010; Christian Faulhammer <fauli@gentoo.org>
epiphany-extensions-2.30.1.ebuild:
diff --git a/www-client/epiphany-extensions/epiphany-extensions-2.26.1.ebuild b/www-client/epiphany-extensions/epiphany-extensions-2.26.1.ebuild
deleted file mode 100644
index 47f6a31a77b6..000000000000
--- a/www-client/epiphany-extensions/epiphany-extensions-2.26.1.ebuild
+++ /dev/null
@@ -1,89 +0,0 @@
-# Copyright 1999-2010 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/www-client/epiphany-extensions/epiphany-extensions-2.26.1.ebuild,v 1.10 2010/07/20 15:46:36 jer Exp $
-
-inherit autotools eutils gnome2 python versionator
-
-MY_MAJORV=$(get_version_component_range 1-2)
-
-DESCRIPTION="Extensions for the Epiphany web browser"
-HOMEPAGE="http://www.gnome.org/projects/epiphany/extensions.html"
-SRC_URI="${SRC_URI} mirror://gentoo/${PN}-2.21.92-sessionsaver-v4.patch.gz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="alpha amd64 ia64 ppc ~ppc64 sparc x86"
-IUSE="dbus examples pcre python"
-
-RDEPEND="=www-client/epiphany-${MY_MAJORV}*
- app-text/opensp
- >=dev-libs/glib-2.15.5
- >=gnome-base/gconf-2.0
- >=dev-libs/libxml2-2.6
- >=x11-libs/gtk+-2.11.6
- >=gnome-base/libglade-2
- =net-libs/xulrunner-1.9*
- dbus? ( >=dev-libs/dbus-glib-0.34 )
- pcre? ( >=dev-libs/libpcre-3.9-r2 )
- python? ( >=dev-python/pygtk-2.11 )"
-DEPEND="${RDEPEND}
- gnome-base/gnome-common
- >=dev-util/intltool-0.40
- >=dev-util/pkgconfig-0.20
- >=app-text/gnome-doc-utils-0.3.2"
-
-DOCS="AUTHORS ChangeLog HACKING NEWS README"
-
-pkg_setup() {
- local extensions=""
-
- extensions="actions auto-reload auto-scroller certificates \
- error-viewer extensions-manager-ui gestures java-console \
- livehttpheaders page-info permissions push-scroller \
- select-stylesheet sessionsaver sidebar smart-bookmarks \
- tab-groups tab-states"
-
- use dbus && extensions="${extensions} rss"
-
- use pcre && extensions="${extensions} adblock greasemonkey"
-
- use python && extensions="${extensions} python-console favicon cc-license-viewer epilicious"
- use python && use examples && extensions="${extensions} sample-python"
-
- use examples && extensions="${extensions} sample sample-mozilla"
-
- G2CONF="${G2CONF} --with-extensions=$(echo "${extensions}" | sed -e 's/[[:space:]]\+/,/g')"
-
- G2CONF="${G2CONF} --with-gecko=libxul-embedding"
-}
-
-src_unpack() {
- gnome2_src_unpack
-
- # disable pyc compiling
- mv py-compile py-compile.orig
- ln -s $(type -P true) py-compile
-
- # Don't remove sessionsaver, please. -dang
- epatch "${WORKDIR}"/${PN}-2.21.92-sessionsaver-v4.patch
- echo "extensions/sessionsaver/ephy-sessionsaver-extension.c" >> po/POTFILES.in
-
- # Fix building with libtool-1 bug #257337
- rm m4/lt* m4/libtool.m4 m4/ltmain.m4
-
- intltoolize --force --copy --automake || die "intltoolize failed"
- eautoreconf
-}
-
-pkg_postinst() {
- gnome2_pkg_postinst
-
- if use python; then
- python_mod_optimize /usr/$(get_libdir)/epiphany/${MY_MAJORV}/extensions
- fi
-}
-
-pkg_postrm() {
- gnome2_pkg_postrm
- python_mod_cleanup /usr/$(get_libdir)/epiphany/${MY_MAJORV}/extensions
-}
diff --git a/www-client/epiphany-extensions/epiphany-extensions-2.30.1.ebuild b/www-client/epiphany-extensions/epiphany-extensions-2.30.1.ebuild
index eb96a1abc8da..8b03ed401efa 100644
--- a/www-client/epiphany-extensions/epiphany-extensions-2.30.1.ebuild
+++ b/www-client/epiphany-extensions/epiphany-extensions-2.30.1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/www-client/epiphany-extensions/epiphany-extensions-2.30.1.ebuild,v 1.4 2010/08/01 11:55:08 fauli Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-client/epiphany-extensions/epiphany-extensions-2.30.1.ebuild,v 1.5 2010/08/31 18:37:36 eva Exp $
EAPI="2"
@@ -21,8 +21,7 @@ RDEPEND=">=www-client/epiphany-${MY_MAJORV}
>=dev-libs/glib-2.15.5
>=gnome-base/gconf-2.0
>=dev-libs/libxml2-2.6
- >=x11-libs/gtk+-2.12.0
- >=gnome-base/libglade-2
+ >=x11-libs/gtk+-2.19.5
>=net-libs/webkit-gtk-1.1
dbus? ( >=dev-libs/dbus-glib-0.34 )
diff --git a/www-client/epiphany-extensions/epiphany-extensions-2.30.2.ebuild b/www-client/epiphany-extensions/epiphany-extensions-2.30.2.ebuild
new file mode 100644
index 000000000000..c99cbdefb917
--- /dev/null
+++ b/www-client/epiphany-extensions/epiphany-extensions-2.30.2.ebuild
@@ -0,0 +1,65 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/www-client/epiphany-extensions/epiphany-extensions-2.30.2.ebuild,v 1.1 2010/08/31 18:37:36 eva Exp $
+
+EAPI="2"
+
+inherit gnome2 versionator
+
+MY_MAJORV=$(get_version_component_range 1-2)
+
+DESCRIPTION="Extensions for the Epiphany web browser"
+HOMEPAGE="http://www.gnome.org/projects/epiphany/extensions.html"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~ia64 ~sparc ~x86"
+IUSE="dbus examples pcre"
+
+RDEPEND=">=www-client/epiphany-${MY_MAJORV}
+ app-text/opensp
+ >=dev-libs/glib-2.15.5
+ >=gnome-base/gconf-2.0
+ >=dev-libs/libxml2-2.6
+ >=x11-libs/gtk+-2.19.5
+ >=net-libs/webkit-gtk-1.1
+
+ dbus? ( >=dev-libs/dbus-glib-0.34 )
+ pcre? ( >=dev-libs/libpcre-3.9-r2 )"
+DEPEND="${RDEPEND}
+ >=dev-util/intltool-0.40
+ >=dev-util/pkgconfig-0.20
+ >=app-text/gnome-doc-utils-0.3.2"
+# eautoreconf dependencies:
+# gnome-base/gnome-common
+
+DOCS="AUTHORS ChangeLog HACKING NEWS README"
+
+# FIXME: Open security issues:
+# FIXME: - adblock ( https://bugzilla.gnome.org/show_bug.cgi?id=595255 )
+# FIXME: broken extensions:
+# FIXME: - session-saver ( https://bugzilla.gnome.org/show_bug.cgi?id=316245 )
+
+pkg_setup() {
+ local extensions=""
+
+ extensions="actions auto-reload auto-scroller certificates \
+ error-viewer extensions-manager-ui gestures html5tube \
+ java-console livehttpheaders page-info permissions \
+ push-scroller select-stylesheet \
+ smart-bookmarks soup-fly tab-groups tab-states"
+ use dbus && extensions="${extensions} rss"
+
+ use pcre && extensions="${extensions} greasemonkey"
+
+ use examples && extensions="${extensions} sample"
+
+ G2CONF="${G2CONF}
+ --disable-maintainer-mode
+ --with-extensions=$(echo "${extensions}" | sed -e 's/[[:space:]]\+/,/g')"
+}
+
+src_install() {
+ gnome2_src_install
+ find "${D}" -name "*.la" -delete || die "remove of la files failed"
+}