summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick Lauer <patrick@gentoo.org>2009-08-17 14:32:29 +0000
committerPatrick Lauer <patrick@gentoo.org>2009-08-17 14:32:29 +0000
commit2c13d18a7d05d0d303238e8b6183edabf56d3ee0 (patch)
treea9b3c5a1ba9e8858a9b9fb6294b02776dac80208 /x11-drivers
parentold (diff)
downloadhistorical-2c13d18a7d05d0d303238e8b6183edabf56d3ee0.tar.gz
historical-2c13d18a7d05d0d303238e8b6183edabf56d3ee0.tar.bz2
historical-2c13d18a7d05d0d303238e8b6183edabf56d3ee0.zip
Bump to 3.0.4, fixes #280157. Thanks to Alessio Cassibba
Package-Manager: portage-2.2_rc38/cvs/Linux x86_64
Diffstat (limited to 'x11-drivers')
-rw-r--r--x11-drivers/xf86-input-virtualbox/ChangeLog8
-rw-r--r--x11-drivers/xf86-input-virtualbox/xf86-input-virtualbox-3.0.4.ebuild105
-rw-r--r--x11-drivers/xf86-video-virtualbox/ChangeLog8
-rw-r--r--x11-drivers/xf86-video-virtualbox/xf86-video-virtualbox-3.0.4.ebuild151
4 files changed, 270 insertions, 2 deletions
diff --git a/x11-drivers/xf86-input-virtualbox/ChangeLog b/x11-drivers/xf86-input-virtualbox/ChangeLog
index 5e2303e64299..a3d4e9a4125f 100644
--- a/x11-drivers/xf86-input-virtualbox/ChangeLog
+++ b/x11-drivers/xf86-input-virtualbox/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for x11-drivers/xf86-input-virtualbox
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-drivers/xf86-input-virtualbox/ChangeLog,v 1.14 2009/07/16 21:40:30 patrick Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-drivers/xf86-input-virtualbox/ChangeLog,v 1.15 2009/08/17 14:32:07 patrick Exp $
+
+*xf86-input-virtualbox-3.0.4 (17 Aug 2009)
+
+ 17 Aug 2009; Patrick Lauer <patrick@gentoo.org>
+ +xf86-input-virtualbox-3.0.4.ebuild:
+ Bump to 3.0.4, fixes #280157. Thanks to Alessio Cassibba
*xf86-input-virtualbox-3.0.2 (16 Jul 2009)
diff --git a/x11-drivers/xf86-input-virtualbox/xf86-input-virtualbox-3.0.4.ebuild b/x11-drivers/xf86-input-virtualbox/xf86-input-virtualbox-3.0.4.ebuild
new file mode 100644
index 000000000000..b2532ddecf40
--- /dev/null
+++ b/x11-drivers/xf86-input-virtualbox/xf86-input-virtualbox-3.0.4.ebuild
@@ -0,0 +1,105 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-drivers/xf86-input-virtualbox/xf86-input-virtualbox-3.0.4.ebuild,v 1.1 2009/08/17 14:32:07 patrick Exp $
+
+EAPI=2
+
+inherit x-modular eutils multilib
+
+MY_P=VirtualBox-${PV}-OSE
+DESCRIPTION="VirtualBox input driver"
+HOMEPAGE="http://www.virtualbox.org/"
+SRC_URI="http://download.virtualbox.org/virtualbox/${PV}/${MY_P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="hal"
+
+RDEPEND="x11-base/xorg-server
+ hal? ( sys-apps/hal )"
+DEPEND="${RDEPEND}
+ >=dev-util/kbuild-0.1.5-r1
+ >=dev-lang/yasm-0.6.2
+ sys-devel/dev86
+ sys-power/iasl
+ x11-proto/inputproto
+ x11-proto/randrproto
+ x11-proto/xproto"
+
+S=${WORKDIR}/${MY_P/-OSE/_OSE}
+
+src_prepare() {
+ # Remove shipped binaries (kBuild,yasm), see bug #232775
+ rm -rf kBuild/bin tools
+
+ # Disable things unused or splitted into separate ebuilds
+ cp "${FILESDIR}/${PN}-2-localconfig" LocalConfig.kmk
+}
+
+src_configure() {
+ # build the user-space tools, warnings are harmless
+ ./configure --nofatal \
+ --disable-xpcom \
+ --disable-sdl-ttf \
+ --disable-pulse \
+ --disable-alsa \
+ --build-headless || die "configure failed"
+ source ./env.sh
+}
+
+src_compile() {
+ for each in /src/VBox/{Runtime,Additions/common/VBoxGuestLib} \
+ /src/VBox/Additions/x11/vboxmouse ; do
+ cd "${S}"${each}
+ MAKE="kmk" emake TOOL_YASM_AS=yasm \
+ KBUILD_PATH="${S}/kBuild" \
+ || die "kmk failed"
+ done
+}
+
+src_install() {
+ cd "${S}/out/linux.${ARCH}/release/bin/additions"
+ insinto /usr/$(get_libdir)/xorg/modules/input
+
+ # xorg-server-1.6.x (currently on the official x11 overlay)
+ if has_version ">=x11-base/xorg-server-1.6" ; then
+ newins vboxmouse_drv_16.so vboxmouse_drv.so
+ # xorg-server-1.5.x
+ elif has_version ">=x11-base/xorg-server-1.5" \
+ && has_version "<x11-base/xorg-server-1.6" ; then
+ newins vboxmouse_drv_15.so vboxmouse_drv.so
+ # xorg-server-1.4.x
+ elif has_version ">=x11-base/xorg-server-1.4" \
+ && has_version "<x11-base/xorg-server-1.5" ; then
+ newins vboxmouse_drv_14.so vboxmouse_drv.so
+ # xorg-server-1.3.x
+ else
+ newins vboxmouse_drv_71.so vboxmouse_drv.so
+ fi
+
+ # install hal information file about the mouse driver
+ if use hal; then
+ cd "${S}/src/VBox/Additions/linux/installer"
+ insinto /usr/share/hal/fdi/information/20thirdparty
+ doins 90-vboxguest.fdi
+ fi
+}
+
+pkg_postinst() {
+ elog "You need to edit the file /etc/X11/xorg.conf and set:"
+ elog ""
+ elog " Driver \"vboxmouse\""
+ elog ""
+ elog "in the Core Pointer's InputDevice section (Section \"InputDevice\")"
+ elog ""
+ if has_version ">=x11-base/xorg-server-1.5" ; then
+ elog "Starting with 1.5 version, X.Org Server can do mouse auto-detection"
+ elog "you may install the hal information file about the mouse driver:"
+ elog ""
+ elog "/usr/share/hal/fdi/information/20thirdparty/90-vboxguest.fdi"
+ elog ""
+ elog "dropping it into: /etc/hal/fdi/policy/"
+ elog ""
+ fi
+}
diff --git a/x11-drivers/xf86-video-virtualbox/ChangeLog b/x11-drivers/xf86-video-virtualbox/ChangeLog
index 5f8c98457c1b..b81131ebf31d 100644
--- a/x11-drivers/xf86-video-virtualbox/ChangeLog
+++ b/x11-drivers/xf86-video-virtualbox/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for x11-drivers/xf86-video-virtualbox
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-drivers/xf86-video-virtualbox/ChangeLog,v 1.13 2009/07/16 21:41:01 patrick Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-drivers/xf86-video-virtualbox/ChangeLog,v 1.14 2009/08/17 14:32:29 patrick Exp $
+
+*xf86-video-virtualbox-3.0.4 (17 Aug 2009)
+
+ 17 Aug 2009; Patrick Lauer <patrick@gentoo.org>
+ +xf86-video-virtualbox-3.0.4.ebuild:
+ Bump to 3.0.4, fixes #280157. Thanks to Alessio Cassibba
*xf86-video-virtualbox-3.0.2 (16 Jul 2009)
diff --git a/x11-drivers/xf86-video-virtualbox/xf86-video-virtualbox-3.0.4.ebuild b/x11-drivers/xf86-video-virtualbox/xf86-video-virtualbox-3.0.4.ebuild
new file mode 100644
index 000000000000..963e4457726c
--- /dev/null
+++ b/x11-drivers/xf86-video-virtualbox/xf86-video-virtualbox-3.0.4.ebuild
@@ -0,0 +1,151 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-drivers/xf86-video-virtualbox/xf86-video-virtualbox-3.0.4.ebuild,v 1.1 2009/08/17 14:32:29 patrick Exp $
+
+EAPI=2
+
+inherit x-modular eutils linux-mod multilib
+
+MY_P=VirtualBox-${PV}-OSE
+DESCRIPTION="VirtualBox video driver"
+HOMEPAGE="http://www.virtualbox.org/"
+SRC_URI="http://download.virtualbox.org/virtualbox/${PV}/${MY_P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="dri"
+
+RDEPEND="x11-base/xorg-server"
+DEPEND="${RDEPEND}
+ >=dev-util/kbuild-0.1.5-r1
+ >=dev-lang/yasm-0.6.2
+ sys-devel/dev86
+ sys-power/iasl
+ x11-proto/fontsproto
+ x11-proto/randrproto
+ x11-proto/renderproto
+ x11-proto/xextproto
+ x11-proto/xineramaproto
+ x11-proto/xproto
+ x11-libs/libXdmcp
+ x11-libs/libXcomposite
+ x11-libs/libXau
+ x11-libs/libX11
+ x11-libs/libXfixes
+ x11-libs/libXext
+ dri? ( x11-proto/xf86driproto
+ >=x11-libs/libdrm-2.4.5 )"
+
+BUILD_TARGETS="all"
+BUILD_TARGET_ARCH="${ARCH}"
+MODULE_NAMES="vboxvideo(misc:${WORKDIR}/vboxvideo_drm:${WORKDIR}/vboxvideo_drm)"
+
+S=${WORKDIR}/${MY_P/-OSE/_OSE}
+
+pkg_setup() {
+ linux-mod_pkg_setup
+ BUILD_PARAMS="KERN_DIR=${KV_DIR} KERNOUT=${KV_OUT_DIR}"
+}
+
+src_unpack() {
+ unpack ${A}
+
+ # Prepare the vboxvideo_drm sources and Makefile in ${WORKDIR}
+ cp -a "${MY_P/-OSE/_OSE}"/src/VBox/Additions/linux/drm \
+ "${WORKDIR}/vboxvideo_drm"
+ cp "${FILESDIR}/${PN}-3-vboxvideo_drm.makefile" \
+ "${WORKDIR}/vboxvideo_drm/Makefile"
+}
+
+src_prepare() {
+ # Remove shipped binaries (kBuild,yasm), see bug #232775
+ rm -rf kBuild/bin tools
+
+ # Disable things unused or splitted into separate ebuilds
+ cp "${FILESDIR}/${PN}-2-localconfig" LocalConfig.kmk
+
+ # Ugly hack to build the opengl part of the video driver
+ epatch "${FILESDIR}/${PN}-2.2.0-enable-opengl.patch"
+
+ # unset useless/problematic mesa checks in configure
+ epatch "${FILESDIR}/${PN}-3.0.0-mesa-check.patch"
+}
+
+src_configure() {
+ # build the user-space tools, warnings are harmless
+ ./configure --nofatal \
+ --disable-xpcom \
+ --disable-sdl-ttf \
+ --disable-pulse \
+ --disable-alsa \
+ --build-headless || die "configure failed"
+ source ./env.sh
+}
+
+src_compile() {
+ if use dri; then
+ linux-mod_src_compile
+ fi
+
+ for each in /src/VBox/{Runtime,Additions/common/VBoxGuestLib} \
+ /src/VBox/{GuestHost/OpenGL,Additions/x11/x11stubs,Additions/common/crOpenGL} \
+ /src/VBox/Additions/x11/vboxvideo ; do
+ cd "${S}"${each}
+ MAKE="kmk" emake TOOL_YASM_AS=yasm \
+ KBUILD_PATH="${S}/kBuild" \
+ || die "kmk failed"
+ done
+}
+
+src_install() {
+ if use dri; then
+ linux-mod_src_install
+ fi
+
+ cd "${S}/out/linux.${ARCH}/release/bin/additions"
+ insinto /usr/$(get_libdir)/xorg/modules/drivers
+
+ # xorg-server-1.6.x (currently on the official x11 overlay)
+ if has_version ">=x11-base/xorg-server-1.6" ; then
+ newins vboxvideo_drv_16.so vboxvideo_drv.so
+ # xorg-server-1.5.x
+ elif has_version ">=x11-base/xorg-server-1.5" \
+ && has_version "<x11-base/xorg-server-1.6" ; then
+ newins vboxvideo_drv_15.so vboxvideo_drv.so
+ # xorg-server-1.4.x
+ elif has_version ">=x11-base/xorg-server-1.4" \
+ && has_version "<x11-base/xorg-server-1.5" ; then
+ newins vboxvideo_drv_14.so vboxvideo_drv.so
+ # xorg-server-1.3.x
+ else
+ newins vboxvideo_drv_13.so vboxvideo_drv.so
+ fi
+
+ # Guest OpenGL driver
+ insinto /usr/$(get_libdir)
+ doins -r VBoxOGL* || die
+
+ if use dri ; then
+ dosym /usr/$(get_libdir)/VBoxOGL.so /usr/$(get_libdir)/dri/vboxvideo_dri.so
+ fi
+}
+
+pkg_postinst() {
+ elog "You need to edit the file /etc/X11/xorg.conf and set:"
+ elog ""
+ elog " Driver \"vboxvideo\""
+ elog ""
+ elog "in the Graphics device section (Section \"Device\")"
+ elog ""
+ if use dri; then
+ elog "To use the kernel drm video driver, please add:"
+ elog "\"vboxvideo\" to:"
+ if has_version sys-apps/openrc; then
+ elog "/etc/conf.d/modules"
+ else
+ elog "/etc/modules.autoload.d/kernel-${KV_MAJOR}.${KV_MINOR}"
+ fi
+ elog ""
+ fi
+}