summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <ssuominen@gentoo.org>2011-02-13 12:21:56 +0000
committerSamuli Suominen <ssuominen@gentoo.org>2011-02-13 12:21:56 +0000
commit43d2920c2627aa3ba207c0e90c90b00d9c301fd6 (patch)
tree7d8dd6356021c417725c10869f91fe8b5ac277a9 /x11-drivers
parentDrop sparc keywords (diff)
downloadhistorical-43d2920c2627aa3ba207c0e90c90b00d9c301fd6.tar.gz
historical-43d2920c2627aa3ba207c0e90c90b00d9c301fd6.tar.bz2
historical-43d2920c2627aa3ba207c0e90c90b00d9c301fd6.zip
Remove USE="hal" since it's not present in stable X.org server anymore.
Package-Manager: portage-2.2.0_alpha23/cvs/Linux x86_64
Diffstat (limited to 'x11-drivers')
-rw-r--r--x11-drivers/xf86-input-virtualbox/ChangeLog8
-rw-r--r--x11-drivers/xf86-input-virtualbox/xf86-input-virtualbox-4.0.2-r2.ebuild103
-rw-r--r--x11-drivers/xf86-input-wacom/ChangeLog10
-rw-r--r--x11-drivers/xf86-input-wacom/xf86-input-wacom-0.10.8-r1.ebuild58
4 files changed, 176 insertions, 3 deletions
diff --git a/x11-drivers/xf86-input-virtualbox/ChangeLog b/x11-drivers/xf86-input-virtualbox/ChangeLog
index b76a40bfe5a6..91bfc9fb1aa2 100644
--- a/x11-drivers/xf86-input-virtualbox/ChangeLog
+++ b/x11-drivers/xf86-input-virtualbox/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for x11-drivers/xf86-input-virtualbox
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-drivers/xf86-input-virtualbox/ChangeLog,v 1.57 2011/02/03 07:53:05 tomka Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-drivers/xf86-input-virtualbox/ChangeLog,v 1.58 2011/02/13 12:19:32 ssuominen Exp $
+
+*xf86-input-virtualbox-4.0.2-r2 (13 Feb 2011)
+
+ 13 Feb 2011; Samuli Suominen <ssuominen@gentoo.org>
+ +xf86-input-virtualbox-4.0.2-r2.ebuild:
+ Remove USE="hal" since it's not present in stable X.org server anymore.
03 Feb 2011; Thomas Kahle <tomka@gentoo.org>
xf86-input-virtualbox-3.2.12.ebuild:
diff --git a/x11-drivers/xf86-input-virtualbox/xf86-input-virtualbox-4.0.2-r2.ebuild b/x11-drivers/xf86-input-virtualbox/xf86-input-virtualbox-4.0.2-r2.ebuild
new file mode 100644
index 000000000000..9ac2d1023353
--- /dev/null
+++ b/x11-drivers/xf86-input-virtualbox/xf86-input-virtualbox-4.0.2-r2.ebuild
@@ -0,0 +1,103 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-drivers/xf86-input-virtualbox/xf86-input-virtualbox-4.0.2-r2.ebuild,v 1.1 2011/02/13 12:19:32 ssuominen Exp $
+
+EAPI=2
+
+inherit eutils multilib linux-info
+
+MY_P=VirtualBox-${PV}
+DESCRIPTION="VirtualBox input driver"
+HOMEPAGE="http://www.virtualbox.org/"
+SRC_URI="http://download.virtualbox.org/virtualbox/${PV}/${MY_P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="x11-base/xorg-server
+ || ( x11-drivers/xf86-input-mouse
+ x11-drivers/xf86-input-evdev )"
+DEPEND="${RDEPEND}
+ >=dev-util/kbuild-0.1.5-r1
+ >=dev-lang/yasm-0.6.2
+ sys-devel/dev86
+ sys-power/iasl
+ x11-proto/inputproto
+ x11-proto/randrproto
+ x11-proto/xproto"
+
+S="${WORKDIR}/${MY_P}_OSE"
+
+src_prepare() {
+ if kernel_is -ge 2 6 33 ; then
+ # evil patch for new kernels - header moved
+ grep -lR linux/autoconf.h * | xargs sed -i -e 's:<linux/autoconf.h>:<generated/autoconf.h>:' || die "Failed replacing"
+ fi
+ # Remove shipped binaries (kBuild,yasm), see bug #232775
+ rm -rf kBuild/bin tools
+
+ # Disable things unused or splitted into separate ebuilds
+ cp "${FILESDIR}/${PN}-3-localconfig" LocalConfig.kmk
+}
+
+src_configure() {
+ # build the user-space tools, warnings are harmless
+ ./configure --nofatal \
+ --disable-xpcom \
+ --disable-sdl-ttf \
+ --disable-pulse \
+ --disable-alsa \
+ --build-headless || die "configure failed"
+ source ./env.sh
+}
+
+src_compile() {
+ for each in /src/VBox/{Runtime,Additions/common/VBoxGuestLib} \
+ /src/VBox/Additions/x11/vboxmouse ; do
+ cd "${S}"${each}
+ MAKE="kmk" emake TOOL_YASM_AS=yasm \
+ KBUILD_PATH="${S}/kBuild" \
+ || die "kmk failed"
+ done
+}
+
+src_install() {
+ cd "${S}/out/linux.${ARCH}/release/bin/additions"
+ insinto /usr/$(get_libdir)/xorg/modules/input
+
+ # xorg-server-1.9
+ if has_version "=x11-base/xorg-server-1.9*" ; then
+ newins vboxmouse_drv_19.so vboxmouse_drv.so
+ # xorg-server-1.8
+ elif has_version "=x11-base/xorg-server-1.8*" ; then
+ newins vboxmouse_drv_18.so vboxmouse_drv.so
+ # xorg-server-1.7
+ else
+ newins vboxmouse_drv_17.so vboxmouse_drv.so
+ fi
+
+ cd "${S}/src/VBox/Additions/linux/installer" || die
+
+ if has_version ">=x11-base/xorg-server-1.8" ; then
+ # install udev information file about the mouse driver
+ insinto /etc/udev/rules.d
+ doins 70-xorg-vboxmouse.rules
+
+ # install X11 information file about the mouse driver
+ insinto /etc/X11/xorg.conf.d
+ doins "${S}/src/VBox/Additions/x11/Installer/50-vboxmouse.conf"
+ fi
+}
+
+pkg_postinst() {
+ elog "You need to edit the file /etc/X11/xorg.conf and set:"
+ elog ""
+ elog " Driver \"vboxmouse\""
+ elog ""
+ elog "in the Core Pointer's InputDevice section (Section \"InputDevice\")"
+ elog ""
+ elog "This is no longer necessary for X.Org Server 1.9 or higher. Use"
+ elog "the server's udev autodetection with such versions."
+}
diff --git a/x11-drivers/xf86-input-wacom/ChangeLog b/x11-drivers/xf86-input-wacom/ChangeLog
index a21da349b998..598a9bc9ed76 100644
--- a/x11-drivers/xf86-input-wacom/ChangeLog
+++ b/x11-drivers/xf86-input-wacom/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for x11-drivers/xf86-input-wacom
-# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-drivers/xf86-input-wacom/ChangeLog,v 1.29 2010/12/25 20:17:58 fauli Exp $
+# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/x11-drivers/xf86-input-wacom/ChangeLog,v 1.30 2011/02/13 12:21:56 ssuominen Exp $
+
+*xf86-input-wacom-0.10.8-r1 (13 Feb 2011)
+
+ 13 Feb 2011; Samuli Suominen <ssuominen@gentoo.org>
+ +xf86-input-wacom-0.10.8-r1.ebuild:
+ Remove USE="hal" since it's not present in stable X.org server anymore.
25 Dec 2010; Christian Faulhammer <fauli@gentoo.org>
xf86-input-wacom-0.10.8.ebuild:
diff --git a/x11-drivers/xf86-input-wacom/xf86-input-wacom-0.10.8-r1.ebuild b/x11-drivers/xf86-input-wacom/xf86-input-wacom-0.10.8-r1.ebuild
new file mode 100644
index 000000000000..d13f1a2305db
--- /dev/null
+++ b/x11-drivers/xf86-input-wacom/xf86-input-wacom-0.10.8-r1.ebuild
@@ -0,0 +1,58 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-drivers/xf86-input-wacom/xf86-input-wacom-0.10.8-r1.ebuild,v 1.1 2011/02/13 12:21:56 ssuominen Exp $
+
+EAPI=3
+
+inherit linux-info xorg-2
+
+DESCRIPTION="Driver for Wacom tablets and drawing devices"
+HOMEPAGE="http://linuxwacom.sourceforge.net/"
+LICENSE="GPL-2"
+EGIT_REPO_URI="git://linuxwacom.git.sourceforge.net/gitroot/linuxwacom/${PN}"
+[[ ${PV} != 9999* ]] && \
+ SRC_URI="mirror://sourceforge/linuxwacom/${PN}/${P}.tar.bz2"
+
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
+IUSE="debug"
+
+RDEPEND="!x11-drivers/linuxwacom
+ >=x11-base/xorg-server-1.7
+ x11-libs/libX11
+ x11-libs/libXext
+ x11-libs/libXi
+ x11-libs/libXrandr"
+DEPEND="${RDEPEND}
+ x11-proto/inputproto
+ x11-proto/kbproto
+ x11-proto/randrproto
+ x11-proto/xproto"
+
+pkg_setup() {
+ linux-info_pkg_setup
+
+ CONFIGURE_OPTIONS="$(use_enable debug)"
+}
+
+src_install() {
+ xorg-2_src_install
+
+ rm -rf "${D}"/usr/share/hal
+}
+
+pkg_postinst() {
+ xorg-2_pkg_postinst
+
+ if ! linux_config_exists \
+ || ! linux_chkconfig_present TABLET_USB_WACOM \
+ || ! linux_chkconfig_present INPUT_EVDEV; then
+ echo
+ ewarn "If you use a USB Wacom tablet, you need to enable support in your kernel"
+ ewarn " Device Drivers --->"
+ ewarn " Input device support --->"
+ ewarn " <*> Event interface"
+ ewarn " [*] Tablets --->"
+ ewarn " <*> Wacom Intuos/Graphire tablet support (USB)"
+ echo
+ fi
+}