summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNguyen Thai Ngoc Duy <pclouds@gentoo.org>2005-02-16 07:24:58 +0000
committerNguyen Thai Ngoc Duy <pclouds@gentoo.org>2005-02-16 07:24:58 +0000
commitf44d2c04189d70c575852aba1c2168f3ff5aad0e (patch)
tree6b6cae846a60e0b6bda427be98c3115239765460 /x11-libs/dnd
parentInitial ebuild for the Tree PEAR package. (diff)
downloadhistorical-f44d2c04189d70c575852aba1c2168f3ff5aad0e.tar.gz
historical-f44d2c04189d70c575852aba1c2168f3ff5aad0e.tar.bz2
historical-f44d2c04189d70c575852aba1c2168f3ff5aad0e.zip
Fixed sandbox violation on installing /usr/lib/*
Package-Manager: portage-2.0.51.16
Diffstat (limited to 'x11-libs/dnd')
-rw-r--r--x11-libs/dnd/ChangeLog8
-rw-r--r--x11-libs/dnd/Manifest6
-rw-r--r--x11-libs/dnd/dnd-1.1.ebuild6
-rw-r--r--x11-libs/dnd/files/Makefile-fix.patch9
4 files changed, 21 insertions, 8 deletions
diff --git a/x11-libs/dnd/ChangeLog b/x11-libs/dnd/ChangeLog
index 7a182c826ca7..acd883714461 100644
--- a/x11-libs/dnd/ChangeLog
+++ b/x11-libs/dnd/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for x11-libs/dnd
-# Copyright 2002-2004 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-libs/dnd/ChangeLog,v 1.11 2004/07/21 03:02:04 tgall Exp $
+# Copyright 2002-2005 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/dnd/ChangeLog,v 1.12 2005/02/16 07:24:58 pclouds Exp $
+
+ 16 Feb 2005; <pclouds@gentoo.org> files/Makefile-fix.patch,
+ dnd-1.1.ebuild:
+ Fixed sandbox violation on installing /usr/lib/*
20 Jul 2004; Tom Tgall <tgall@gentoo.org> dnd-1.1.ebuild:
stable on ppc64, bug #57174
diff --git a/x11-libs/dnd/Manifest b/x11-libs/dnd/Manifest
index 9f7d0eb2840d..126ab027bb62 100644
--- a/x11-libs/dnd/Manifest
+++ b/x11-libs/dnd/Manifest
@@ -1,5 +1,5 @@
-MD5 b1492789c6123c188e03305e4766d277 ChangeLog 1307
-MD5 9fc6ea971e1dfaf019f0450b7c31d966 dnd-1.1.ebuild 727
+MD5 7f6ce175e84c0530ae6d4dd47b95e221 dnd-1.1.ebuild 742
+MD5 3953f064e3274c866d4ae7382fc19278 ChangeLog 1441
MD5 5bcbf95d481a26737a32374140b6f910 files/digest-dnd-1.1 56
+MD5 1d76f13dff28550723f994fd008c172f files/Makefile-fix.patch 1100
MD5 0004edf0ec28c4b590e0832ba2463d04 files/dnd-1.1-gentoo.diff 1533
-MD5 a17aed1aac031151c9954e2803bdb2f4 files/Makefile-fix.patch 908
diff --git a/x11-libs/dnd/dnd-1.1.ebuild b/x11-libs/dnd/dnd-1.1.ebuild
index 50d4a90fbf51..e7b8605b0403 100644
--- a/x11-libs/dnd/dnd-1.1.ebuild
+++ b/x11-libs/dnd/dnd-1.1.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2004 Gentoo Foundation
+# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-libs/dnd/dnd-1.1.ebuild,v 1.19 2004/07/21 03:02:04 tgall Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/dnd/dnd-1.1.ebuild,v 1.20 2005/02/16 07:24:58 pclouds Exp $
inherit eutils
@@ -28,5 +28,5 @@ src_compile() {
}
src_install () {
- make prefix=${D}/usr install || die
+ make DESTDIR=${D} prefix=${D}/usr install || die
}
diff --git a/x11-libs/dnd/files/Makefile-fix.patch b/x11-libs/dnd/files/Makefile-fix.patch
index ca129175b25f..5ab0672d0f4d 100644
--- a/x11-libs/dnd/files/Makefile-fix.patch
+++ b/x11-libs/dnd/files/Makefile-fix.patch
@@ -1,5 +1,14 @@
--- Makefile.in.orig 1997-05-22 22:18:22.000000000 -0400
+++ Makefile.in 2004-06-16 14:41:19.673035936 -0400
+@@ -16,7 +16,7 @@
+
+ prefix = @prefix@
+ exec_prefix = @exec_prefix@
+-LIB_DIR = @libdir@
++LIB_DIR = $(DESTDIR)@libdir@
+ INC_DIR = @includedir@/OffiX
+
+ COMPILE = $(CC) $(INCLUDES) $(CFLAGS) -c
@@ -42,19 +42,22 @@
$(COMPILE) dndtest.c
$(LINK) dndtest.o -L. -lDnd $(LIBS)