summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBen de Groot <yngwin@gentoo.org>2008-09-19 00:19:07 +0000
committerBen de Groot <yngwin@gentoo.org>2008-09-19 00:19:07 +0000
commite58d212d41657b20cf06cc1a0d39b98350c85814 (patch)
treea627dcfd8d78d895e18c6f25752847d4fc7b9f11 /x11-libs/qt-test
parentVersion bump. (diff)
downloadhistorical-e58d212d41657b20cf06cc1a0d39b98350c85814.tar.gz
historical-e58d212d41657b20cf06cc1a0d39b98350c85814.tar.bz2
historical-e58d212d41657b20cf06cc1a0d39b98350c85814.zip
qt-4.4.2 version bump
Package-Manager: portage-2.2_rc8/cvs/Linux 2.6.26.5 i686
Diffstat (limited to 'x11-libs/qt-test')
-rw-r--r--x11-libs/qt-test/ChangeLog7
-rw-r--r--x11-libs/qt-test/qt-test-4.4.2.ebuild33
2 files changed, 39 insertions, 1 deletions
diff --git a/x11-libs/qt-test/ChangeLog b/x11-libs/qt-test/ChangeLog
index 2808fa7b1f2a..59b809eafbe8 100644
--- a/x11-libs/qt-test/ChangeLog
+++ b/x11-libs/qt-test/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for x11-libs/qt-test
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-libs/qt-test/ChangeLog,v 1.11 2008/08/11 13:12:06 yngwin Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/qt-test/ChangeLog,v 1.12 2008/09/19 00:17:34 yngwin Exp $
+
+*qt-test-4.4.2 (19 Sep 2008)
+
+ 19 Sep 2008; Ben de Groot <yngwin@gentoo.org> +qt-test-4.4.2.ebuild:
+ Version bump
*qt-test-4.4.1 (11 Aug 2008)
diff --git a/x11-libs/qt-test/qt-test-4.4.2.ebuild b/x11-libs/qt-test/qt-test-4.4.2.ebuild
new file mode 100644
index 000000000000..72aa655dc1b1
--- /dev/null
+++ b/x11-libs/qt-test/qt-test-4.4.2.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/qt-test/qt-test-4.4.2.ebuild,v 1.1 2008/09/19 00:17:34 yngwin Exp $
+
+EAPI="1"
+inherit qt4-build
+
+DESCRIPTION="The testing framework module for the Qt toolkit."
+HOMEPAGE="http://www.trolltech.com/"
+
+LICENSE="|| ( GPL-3 GPL-2 )"
+SLOT="4"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE=""
+
+DEPEND="~x11-libs/qt-core-${PV}
+ !<=x11-libs/qt-4.4.0_alpha:${SLOT}"
+RDEPEND="${DEPEND}"
+
+QT4_TARGET_DIRECTORIES="src/testlib"
+QT4_EXTRACT_DIRECTORIES="${QT4_TARGET_DIRECTORIES}"
+
+src_compile() {
+ local myconf
+ myconf="${myconf} -no-xkb -no-tablet -no-fontconfig -no-xrender -no-xrandr
+ -no-xfixes -no-xcursor -no-xinerama -no-xshape -no-sm -no-opengl
+ -no-nas-sound -no-dbus -iconv -no-cups -no-nis -no-gif -no-libpng
+ -no-libmng -no-libjpeg -no-openssl -system-zlib -no-webkit -no-phonon
+ -no-qt3support -no-xmlpatterns -no-freetype -no-libtiff -no-accessibility
+ -no-fontconfig -no-glib -no-opengl -no-svg"
+
+ qt4-build_src_compile
+}