summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJonathan Callen <jcallen@gentoo.org>2009-12-25 15:47:33 +0000
committerJonathan Callen <jcallen@gentoo.org>2009-12-25 15:47:33 +0000
commit8f02994d72dede100a307cbdc1ba3a3c4bb2df23 (patch)
treedc22ba5531e86f30ace82c4c073006d0c920ef9f /x11-libs/qt-webkit
parentjson works fine with Ruby 1.9 as well. (diff)
downloadhistorical-8f02994d72dede100a307cbdc1ba3a3c4bb2df23.tar.gz
historical-8f02994d72dede100a307cbdc1ba3a3c4bb2df23.tar.bz2
historical-8f02994d72dede100a307cbdc1ba3a3c4bb2df23.zip
Add prefix support, revbump due to otherwise unresolvable USE deps
Package-Manager: portage--svn/cvs/Linux i686
Diffstat (limited to 'x11-libs/qt-webkit')
-rw-r--r--x11-libs/qt-webkit/ChangeLog9
-rw-r--r--x11-libs/qt-webkit/files/qt-webkit-4.6.0-solaris-jsvalue.patch21
-rw-r--r--x11-libs/qt-webkit/files/qt-webkit-4.6.0-solaris-strnstr.patch27
-rw-r--r--x11-libs/qt-webkit/qt-webkit-4.6.0-r1.ebuild (renamed from x11-libs/qt-webkit/qt-webkit-4.6.0.ebuild)20
4 files changed, 67 insertions, 10 deletions
diff --git a/x11-libs/qt-webkit/ChangeLog b/x11-libs/qt-webkit/ChangeLog
index c5e0b9fb2622..8961b40b8a05 100644
--- a/x11-libs/qt-webkit/ChangeLog
+++ b/x11-libs/qt-webkit/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for x11-libs/qt-webkit
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-libs/qt-webkit/ChangeLog,v 1.73 2009/12/18 15:25:11 yngwin Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/qt-webkit/ChangeLog,v 1.74 2009/12/25 15:46:59 abcd Exp $
+
+*qt-webkit-4.6.0-r1 (25 Dec 2009)
+
+ 25 Dec 2009; Jonathan Callen <abcd@gentoo.org> -qt-webkit-4.6.0.ebuild,
+ +qt-webkit-4.6.0-r1.ebuild, +files/qt-webkit-4.6.0-solaris-jsvalue.patch,
+ +files/qt-webkit-4.6.0-solaris-strnstr.patch:
+ Add prefix support, revbump due to otherwise unresolvable USE deps
18 Dec 2009; Ben de Groot <yngwin@gentoo.org> qt-webkit-4.6.0.ebuild:
Add dependency on qt-xmlpatterns, bug 297291.
diff --git a/x11-libs/qt-webkit/files/qt-webkit-4.6.0-solaris-jsvalue.patch b/x11-libs/qt-webkit/files/qt-webkit-4.6.0-solaris-jsvalue.patch
new file mode 100644
index 000000000000..1244d48ea251
--- /dev/null
+++ b/x11-libs/qt-webkit/files/qt-webkit-4.6.0-solaris-jsvalue.patch
@@ -0,0 +1,21 @@
+../JavaScriptCore/runtime/JSValue.h:479: error: cast from ‘JSC::JSCell*’
+to ‘int32_t’ loses precision
+
+Fix inspired by:
+http://bugreports.qt.nokia.com/browse/QTBUG-6948
+
+Seems already to have been fixed upstream webkit in a different way
+(PLATFORM(UNIX) iso DARWIN/LINUX/SOLARIS)
+
+
+--- src/3rdparty/webkit/JavaScriptCore/wtf/Platform.h
++++ src/3rdparty/webkit/JavaScriptCore/wtf/Platform.h
+@@ -709,7 +709,7 @@
+ #endif
+
+ #if !defined(WTF_USE_JSVALUE64) && !defined(WTF_USE_JSVALUE32) && !defined(WTF_USE_JSVALUE32_64)
+-#if PLATFORM(X86_64) && (PLATFORM(DARWIN) || PLATFORM(LINUX) || PLATFORM(WIN_OS))
++#if PLATFORM(X86_64) && (PLATFORM(DARWIN) || PLATFORM(LINUX) || PLATFORM(WIN_OS) || PLATFORM(SOLARIS))
+ #define WTF_USE_JSVALUE64 1
+ #elif PLATFORM(ARM) || PLATFORM(PPC64)
+ #define WTF_USE_JSVALUE32 1
diff --git a/x11-libs/qt-webkit/files/qt-webkit-4.6.0-solaris-strnstr.patch b/x11-libs/qt-webkit/files/qt-webkit-4.6.0-solaris-strnstr.patch
new file mode 100644
index 000000000000..e71f5c0aa115
--- /dev/null
+++ b/x11-libs/qt-webkit/files/qt-webkit-4.6.0-solaris-strnstr.patch
@@ -0,0 +1,27 @@
+(Open)Solaris doesn't have strnstr either:
+https://bugs.webkit.org/show_bug.cgi?id=30647
+http://trac.webkit.org/changeset/50533
+
+
+--- src/3rdparty/webkit/JavaScriptCore/wtf/StringExtras.h
++++ src/3rdparty/webkit/JavaScriptCore/wtf/StringExtras.h
+@@ -85,7 +85,7 @@
+
+ #endif
+
+-#if PLATFORM(WIN_OS) || PLATFORM(LINUX)
++#if PLATFORM(WIN_OS) || PLATFORM(LINUX) || PLATFORM(SOLARIS)
+
+ inline char* strnstr(const char* buffer, const char* target, size_t bufferLength)
+ {
+--- src/3rdparty/javascriptcore/JavaScriptCore/wtf/StringExtras.h
++++ src/3rdparty/javascriptcore/JavaScriptCore/wtf/StringExtras.h
+@@ -85,7 +85,7 @@
+
+ #endif
+
+-#if PLATFORM(WIN_OS) || PLATFORM(LINUX)
++#if PLATFORM(WIN_OS) || PLATFORM(LINUX) || PLATFORM(SOLARIS)
+
+ inline char* strnstr(const char* buffer, const char* target, size_t bufferLength)
+ {
diff --git a/x11-libs/qt-webkit/qt-webkit-4.6.0.ebuild b/x11-libs/qt-webkit/qt-webkit-4.6.0-r1.ebuild
index 7811618c7e57..24c54efe7d1b 100644
--- a/x11-libs/qt-webkit/qt-webkit-4.6.0.ebuild
+++ b/x11-libs/qt-webkit/qt-webkit-4.6.0-r1.ebuild
@@ -1,22 +1,22 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-libs/qt-webkit/qt-webkit-4.6.0.ebuild,v 1.2 2009/12/18 15:25:11 yngwin Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/qt-webkit/qt-webkit-4.6.0-r1.ebuild,v 1.1 2009/12/25 15:46:59 abcd Exp $
EAPI="2"
inherit qt4-build
DESCRIPTION="The Webkit module for the Qt toolkit"
SLOT="4"
-KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 -sparc ~x86 ~x86-fbsd"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 -sparc ~x86 ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos ~x64-solaris ~x86-solaris"
IUSE="kde"
-DEPEND="~x11-libs/qt-core-${PV}[debug=,ssl]
- ~x11-libs/qt-dbus-${PV}[debug=]
- ~x11-libs/qt-gui-${PV}[dbus,debug=]
- ~x11-libs/qt-xmlpatterns-${PV}[debug=]
- !kde? ( || ( ~x11-libs/qt-phonon-${PV}:${SLOT}[dbus,debug=]
- media-sound/phonon ) )
- kde? ( media-sound/phonon )"
+DEPEND="~x11-libs/qt-core-${PV}[aqua=,debug=,ssl]
+ ~x11-libs/qt-dbus-${PV}[aqua=,debug=]
+ ~x11-libs/qt-gui-${PV}[aqua=,dbus,debug=]
+ ~x11-libs/qt-xmlpatterns-${PV}[aqua=,debug=]
+ !kde? ( || ( ~x11-libs/qt-phonon-${PV}:${SLOT}[aqua=,dbus,debug=]
+ media-sound/phonon[aqua=] ) )
+ kde? ( media-sound/phonon[aqua=] )"
RDEPEND="${DEPEND}"
QT4_TARGET_DIRECTORIES="src/3rdparty/webkit/WebCore tools/designer/src/plugins/qwebview"
@@ -32,6 +32,8 @@ src_prepare() {
if use sparc; then
epatch "${FILESDIR}"/sparc-qt-webkit-sigbus.patch
fi
+ epatch "${FILESDIR}"/${P}-solaris-jsvalue.patch
+ epatch "${FILESDIR}"/${P}-solaris-strnstr.patch
qt4-build_src_prepare
}