summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorD.M.D. Ljungmark <spider@gentoo.org>2002-03-28 17:45:56 +0000
committerD.M.D. Ljungmark <spider@gentoo.org>2002-03-28 17:45:56 +0000
commit211e15391071a22533e33e64fd23dc4ae9764612 (patch)
tree9d2097aa94a0c369bd03a26992d36e89b9ff4fd3 /x11-libs
parentnew upstream version. kde3 version so masked for now. (diff)
downloadhistorical-211e15391071a22533e33e64fd23dc4ae9764612.tar.gz
historical-211e15391071a22533e33e64fd23dc4ae9764612.tar.bz2
historical-211e15391071a22533e33e64fd23dc4ae9764612.zip
stable branch of wxGTK added
Diffstat (limited to 'x11-libs')
-rw-r--r--x11-libs/wxGTK/ChangeLog7
-rw-r--r--x11-libs/wxGTK/files/digest-wxGTK-2.2.91
-rw-r--r--x11-libs/wxGTK/wxGTK-2.2.9.ebuild85
3 files changed, 92 insertions, 1 deletions
diff --git a/x11-libs/wxGTK/ChangeLog b/x11-libs/wxGTK/ChangeLog
index 8c109a497b75..f1003e7e4d8b 100644
--- a/x11-libs/wxGTK/ChangeLog
+++ b/x11-libs/wxGTK/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for x11-libs/wxGTK
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
-# $Header: /var/cvsroot/gentoo-x86/x11-libs/wxGTK/ChangeLog,v 1.1 2002/02/01 21:53:38 gbevin Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/wxGTK/ChangeLog,v 1.2 2002/03/28 17:45:55 spider Exp $
+
+*wxGTK-2.2.9 (28 Mar 2002)
+ Spider <spider@gentoo.org>
+ Well, backported this thing to a stable branch, since hte other version is verified as working, I added this without masking anything, should be transparent except that it provides the dependency some people want.
+
*wxGTK-2.3.2 (1 Feb 2002)
diff --git a/x11-libs/wxGTK/files/digest-wxGTK-2.2.9 b/x11-libs/wxGTK/files/digest-wxGTK-2.2.9
new file mode 100644
index 000000000000..176a5207dbac
--- /dev/null
+++ b/x11-libs/wxGTK/files/digest-wxGTK-2.2.9
@@ -0,0 +1 @@
+MD5 f9bf738050fca93e33a65081b1c55905 wxGTK-2.2.9.tar.bz2 3829283
diff --git a/x11-libs/wxGTK/wxGTK-2.2.9.ebuild b/x11-libs/wxGTK/wxGTK-2.2.9.ebuild
new file mode 100644
index 000000000000..820a2a6e69a5
--- /dev/null
+++ b/x11-libs/wxGTK/wxGTK-2.2.9.ebuild
@@ -0,0 +1,85 @@
+# Copyright 1999-2001 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author Tod Neidt <tneidt@fidnet.com>
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/wxGTK/wxGTK-2.2.9.ebuild,v 1.1 2002/03/28 17:45:56 spider Exp $
+
+S=${WORKDIR}/${P}
+
+DESCRIPTION="GTK+ version of wxWindows, a cross-platform C++ GUI toolkit."
+
+SRC_URI="http://prdownloads.sourceforge.net/wxwindows/${P}.tar.bz2"
+
+HOMEPAGE="http://www.wxwindows.org/"
+
+DEPEND="=x11-libs/gtk+-1.2*
+ dev-libs/libunicode
+ media-libs/libpng
+ media-libs/jpeg
+ media-libs/tiff
+ media-libs/netpbm
+ nls? ( sys-devel/gettext )
+ odbc? ( dev-db/unixODBC )
+ gif? ( media-libs/giflib )
+ opengl? ( virtual/opengl )"
+
+#Possible future dependancies
+# motif? ( x11-libs/openmotif )
+# ungif? ( media-libs/libungif )
+
+#RDEPEND=""
+
+src_compile() {
+
+
+ #cp configure.in configure.in.orig
+ #sed '1610i\ /usr/include/freetype2 \\' configure.in.orig > configure.in
+
+
+ local myconf
+ #--with-gtk enabled by default, if you want to build against motif,
+ #replace --with-gtk with --with-motif and --without-gtk. You will
+ #also need openmotif installed. Unfortunately, the package build tools
+ #only support installation of one currently.
+
+ myconf="--with-gtk"
+
+ #Build static library too, shared library is enabled by default.
+ #Enable useful config options that don't have USE flags
+ myconf="$myconf --enable-static --with-zlib --with-unicode"
+
+ #Note: png,jpeg,tiff,pnm, and pcx image support enabled by default if found.
+ #Also, all wxWindows gui features are enabled by default. If you
+ #want to build a smaller library you can disable features by adding
+ #the appropriate flags to myconf (see INSTALL.txt).
+
+ #The build tools include a --with-freetype option, however it doesn't
+ #seem to be implemented in the source yet.
+
+ #confiure options that have corresponding USE variable.
+
+ use odbc && myconf="$myconf --with-odbc" #disabled by default
+ use gif || myconf="$myconf --disable-gif" #enabled by default
+ use opengl && myconf="$myconf --with-opengl" #disabled by default
+
+ ./configure --infodir=/usr/share/info \
+ --mandir=/usr/share/man \
+ --prefix=/usr \
+ --host=${CHOST} \
+ ${myconf}|| die
+
+ emake || die
+
+}
+
+src_install () {
+
+ make infodir=${D}/usr/share/info \
+ mandir=${D}/usr/share/man \
+ prefix=${D}/usr \
+ install || die
+
+ dodoc CHANGES.txt COPYING.LIB INSTALL.txt \
+ LICENCE.txt README.txt SYMBOLS.txt TODO.txt
+
+}
+