summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorCarsten Lohrke <carlo@gentoo.org>2006-05-28 21:57:24 +0000
committerCarsten Lohrke <carlo@gentoo.org>2006-05-28 21:57:24 +0000
commit79633de6003a8f7eb9532461a487a204e3cc38b6 (patch)
tree73815296653a975cd5e8ebfbca454c1a13c777d8 /x11-libs
parentInitial import of texlive (diff)
downloadhistorical-79633de6003a8f7eb9532461a487a204e3cc38b6.tar.gz
historical-79633de6003a8f7eb9532461a487a204e3cc38b6.tar.bz2
historical-79633de6003a8f7eb9532461a487a204e3cc38b6.zip
Build against MySQL 4.0.
Diffstat (limited to 'x11-libs')
-rw-r--r--x11-libs/qt/ChangeLog6
-rw-r--r--x11-libs/qt/files/qt-4.1.3-mysql4-support.diff24
-rw-r--r--x11-libs/qt/qt-4.1.3.ebuild3
3 files changed, 31 insertions, 2 deletions
diff --git a/x11-libs/qt/ChangeLog b/x11-libs/qt/ChangeLog
index e5f76edf16f9..d6ecad70476d 100644
--- a/x11-libs/qt/ChangeLog
+++ b/x11-libs/qt/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for x11-libs/qt
# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-libs/qt/ChangeLog,v 1.321 2006/05/26 14:27:48 wolf31o2 Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/qt/ChangeLog,v 1.322 2006/05/28 21:57:24 carlo Exp $
+
+ 28 May 2006; Carsten Lohrke <carlo@gentoo.org>
+ +files/qt-4.1.3-mysql4-support.diff, qt-4.1.3.ebuild:
+ Build against MySQL 4.0.
26 May 2006; Chris Gianelloni <wolf31o2@gentoo.org> qt-3.3.6-r1.ebuild:
Stable on amd64 wrt bug #132887.
diff --git a/x11-libs/qt/files/qt-4.1.3-mysql4-support.diff b/x11-libs/qt/files/qt-4.1.3-mysql4-support.diff
new file mode 100644
index 000000000000..8a5f343059ec
--- /dev/null
+++ b/x11-libs/qt/files/qt-4.1.3-mysql4-support.diff
@@ -0,0 +1,24 @@
+--- qt-x11-opensource-src-4.1.3/src/sql/drivers/mysql/qsql_mysql.cpp.orig 2006-05-26 01:34:24.000000000 +0200
++++ qt-x11-opensource-src-4.1.3/src/sql/drivers/mysql/qsql_mysql.cpp 2006-05-26 01:37:42.000000000 +0200
+@@ -43,6 +43,12 @@
+ # define Q_NO_MYSQL_EMBEDDED
+ #endif
+
++#if MYSQL_VERSION_ID >= 40100
++# define Q_CLIENT_MULTI_STATEMENTS CLIENT_MULTI_STATEMENTS
++#else
++# define Q_CLIENT_MULTI_STATEMENTS 0
++#endif
++
+ Q_DECLARE_METATYPE(MYSQL_RES*)
+ Q_DECLARE_METATYPE(MYSQL*)
+
+@@ -962,7 +968,7 @@
+ we have to enable CLIEN_MULTI_STATEMENTS here, otherwise _any_
+ stored procedure call will fail.
+ */
+- unsigned int optionFlags = CLIENT_MULTI_STATEMENTS;
++ unsigned int optionFlags = Q_CLIENT_MULTI_STATEMENTS;
+ const QStringList opts(connOpts.split(QLatin1Char(';'), QString::SkipEmptyParts));
+
+ // extract the real options from the string
diff --git a/x11-libs/qt/qt-4.1.3.ebuild b/x11-libs/qt/qt-4.1.3.ebuild
index ddf87c09f31b..58017f52e8cd 100644
--- a/x11-libs/qt/qt-4.1.3.ebuild
+++ b/x11-libs/qt/qt-4.1.3.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-libs/qt/qt-4.1.3.ebuild,v 1.1 2006/05/25 16:37:01 caleb Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/qt/qt-4.1.3.ebuild,v 1.2 2006/05/28 21:57:24 carlo Exp $
inherit eutils flag-o-matic toolchain-funcs multilib
@@ -83,6 +83,7 @@ qt_mkspecs_dir() {
src_unpack() {
unpack ${A}
+ epatch ${FILESDIR}/qt-4.1.3-mysql4-support.diff
cd ${S}
sed -i -e 's:read acceptance:acceptance=yes:' configure