summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKrzysztof Pawlik <nelchael@gentoo.org>2007-02-03 12:54:10 +0000
committerKrzysztof Pawlik <nelchael@gentoo.org>2007-02-03 12:54:10 +0000
commit129abc6c879ac856ab7088d9befc2c395a7a260c (patch)
tree51642bd006a24e08981cd4e7f5662464c1e4805b /x11-misc/gmrun/gmrun-0.9.2.ebuild
parentamd64 stable, bug 161760 (diff)
downloadhistorical-129abc6c879ac856ab7088d9befc2c395a7a260c.tar.gz
historical-129abc6c879ac856ab7088d9befc2c395a7a260c.tar.bz2
historical-129abc6c879ac856ab7088d9befc2c395a7a260c.zip
Remove code to check for STLport, see bug #164339.
Package-Manager: portage-2.1.2-r5
Diffstat (limited to 'x11-misc/gmrun/gmrun-0.9.2.ebuild')
-rw-r--r--x11-misc/gmrun/gmrun-0.9.2.ebuild15
1 files changed, 13 insertions, 2 deletions
diff --git a/x11-misc/gmrun/gmrun-0.9.2.ebuild b/x11-misc/gmrun/gmrun-0.9.2.ebuild
index 546a5f8f299e..1f95fa5857db 100644
--- a/x11-misc/gmrun/gmrun-0.9.2.ebuild
+++ b/x11-misc/gmrun/gmrun-0.9.2.ebuild
@@ -1,6 +1,8 @@
-# Copyright 1999-2006 Gentoo Foundation
+# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-misc/gmrun/gmrun-0.9.2.ebuild,v 1.12 2006/10/23 06:52:39 omp Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/gmrun/gmrun-0.9.2.ebuild,v 1.13 2007/02/03 12:54:10 nelchael Exp $
+
+inherit autotools
DESCRIPTION="A GTK-2 based launcher box with bash style auto completion!"
HOMEPAGE="http://www.bazon.net/mishoo/gmrun.epl"
@@ -16,6 +18,15 @@ RDEPEND=">=x11-libs/gtk+-2.2.0
DEPEND="${RDEPEND}
dev-util/pkgconfig"
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ # Disable check for STLport due to bug #164339
+ sed -i -e 's,^AC_PATH_STLPORT,dnl REMOVED ,g' configure.in
+ sed -i -e 's,@STLPORT_[A-Z]\+@,,g' src/Makefile.am
+ eautoreconf
+}
+
src_install() {
make DESTDIR="${D}" install || die "make install failed"
dodoc AUTHORS ChangeLog README NEWS