summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChí-Thanh Christopher Nguyễn <chithanh@gentoo.org>2013-07-24 00:18:09 +0000
committerChí-Thanh Christopher Nguyễn <chithanh@gentoo.org>2013-07-24 00:18:09 +0000
commitdae101faa1a4b3ce83edcc18aa0b702aeb710698 (patch)
tree9b8fdeacdeb8cba5cc399a8a06be9ef710fd2783 /x11-misc/imake/imake-1.0.6.ebuild
parentVersion bump. (diff)
downloadhistorical-dae101faa1a4b3ce83edcc18aa0b702aeb710698.tar.gz
historical-dae101faa1a4b3ce83edcc18aa0b702aeb710698.tar.bz2
historical-dae101faa1a4b3ce83edcc18aa0b702aeb710698.zip
Version bump.
Package-Manager: portage-2.1.12.2/cvs/Linux x86_64
Diffstat (limited to 'x11-misc/imake/imake-1.0.6.ebuild')
-rw-r--r--x11-misc/imake/imake-1.0.6.ebuild24
1 files changed, 24 insertions, 0 deletions
diff --git a/x11-misc/imake/imake-1.0.6.ebuild b/x11-misc/imake/imake-1.0.6.ebuild
new file mode 100644
index 000000000000..d70cb930c778
--- /dev/null
+++ b/x11-misc/imake/imake-1.0.6.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/imake/imake-1.0.6.ebuild,v 1.1 2013/07/24 00:17:30 chithanh Exp $
+
+EAPI=4
+
+XORG_STATIC=no
+inherit xorg-2
+
+DESCRIPTION="C preprocessor interface to the make utility"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~x86-interix ~amd64-linux ~arm-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~x64-solaris ~x86-solaris"
+IUSE=""
+
+RDEPEND="x11-misc/xorg-cf-files"
+DEPEND="${RDEPEND}
+ x11-proto/xproto"
+
+src_prepare() {
+ # don't use Sun compilers on Solaris, we want GCC from prefix
+ sed -i \
+ -e "1s/^/#if defined(sun)\n# undef sun\n#endif/" \
+ imake.c imakemdep.h || die "sed failed"
+ xorg-2_src_prepare
+}