summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Januszewski <spock@gentoo.org>2006-09-13 13:36:39 +0000
committerMichael Januszewski <spock@gentoo.org>2006-09-13 13:36:39 +0000
commitc49eb744632b40da333566107e9ecb09e60101ba (patch)
treeef7e7259c8ff523337a866077bdbe1963f679ac4 /x11-misc/xfractint/xfractint-20.4.03.ebuild
parentAnother attempt at bug 145167. Removing the stale wrappers in pkg_preinst. (diff)
downloadhistorical-c49eb744632b40da333566107e9ecb09e60101ba.tar.gz
historical-c49eb744632b40da333566107e9ecb09e60101ba.tar.bz2
historical-c49eb744632b40da333566107e9ecb09e60101ba.zip
Added fix for bug #147030.
Package-Manager: portage-2.1.1
Diffstat (limited to 'x11-misc/xfractint/xfractint-20.4.03.ebuild')
-rw-r--r--x11-misc/xfractint/xfractint-20.4.03.ebuild7
1 files changed, 6 insertions, 1 deletions
diff --git a/x11-misc/xfractint/xfractint-20.4.03.ebuild b/x11-misc/xfractint/xfractint-20.4.03.ebuild
index 665ae7cd2d68..2c86e592cfea 100644
--- a/x11-misc/xfractint/xfractint-20.4.03.ebuild
+++ b/x11-misc/xfractint/xfractint-20.4.03.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-misc/xfractint/xfractint-20.4.03.ebuild,v 1.2 2006/01/29 22:37:37 spock Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/xfractint/xfractint-20.4.03.ebuild,v 1.3 2006/09/13 13:36:39 spock Exp $
inherit eutils flag-o-matic
@@ -37,6 +37,7 @@ src_install() {
make DESTDIR="${D}" install || die
chmod 0644 -R ${D}usr/share/xfractint/*
+ chmod a+X -R ${D}usr/share/xfractint/*
insinto /etc/env.d
newins ${FILESDIR}/xfractint.envd 60xfractint
@@ -47,4 +48,8 @@ pkg_postinst() {
einfo "XFractInt requires the FRACTDIR variable to be set in order to start."
einfo "Please re-login or \`source /etc/profile\` to have this variable set automatically."
einfo
+
+ # Fix directory permissions as they might be broken because
+ # of an earlier installation.
+ chmod a+X -R ${ROOT}/usr/share/xfractint/*
}