summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGraham Forest <vitaminmoo@gentoo.org>2003-03-18 07:05:15 +0000
committerGraham Forest <vitaminmoo@gentoo.org>2003-03-18 07:05:15 +0000
commit40fbe6e1fe7291a2e97b77c4b421ad18a5c308ec (patch)
tree24dd8c816cb06d062df844c95d1a47cfcda719b6 /x11-misc/xplanet
parentusability additions, see online distcc docs for more info (diff)
downloadhistorical-40fbe6e1fe7291a2e97b77c4b421ad18a5c308ec.tar.gz
historical-40fbe6e1fe7291a2e97b77c4b421ad18a5c308ec.tar.bz2
historical-40fbe6e1fe7291a2e97b77c4b421ad18a5c308ec.zip
version bump
Diffstat (limited to 'x11-misc/xplanet')
-rw-r--r--x11-misc/xplanet/ChangeLog7
-rw-r--r--x11-misc/xplanet/files/digest-xplanet-1.0.11
-rw-r--r--x11-misc/xplanet/xplanet-1.0.1.ebuild76
3 files changed, 83 insertions, 1 deletions
diff --git a/x11-misc/xplanet/ChangeLog b/x11-misc/xplanet/ChangeLog
index 50d63764be2f..0d9219089cde 100644
--- a/x11-misc/xplanet/ChangeLog
+++ b/x11-misc/xplanet/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for x11-misc/xplanet
# Copyright 2002-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-misc/xplanet/ChangeLog,v 1.8 2003/03/14 05:55:51 seemant Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/xplanet/ChangeLog,v 1.9 2003/03/18 07:05:15 vladimir Exp $
+
+*xplanet-1.0.1 (17 Mar 2003)
+
+ 17 Mar 2003; Graham Forest <vladimir@gentoo.org> xplanet-1.0.1.ebuild:
+ version bump
*xplanet-1.0.0 (13 Mar 2003)
diff --git a/x11-misc/xplanet/files/digest-xplanet-1.0.1 b/x11-misc/xplanet/files/digest-xplanet-1.0.1
new file mode 100644
index 000000000000..9a27f6ed66d2
--- /dev/null
+++ b/x11-misc/xplanet/files/digest-xplanet-1.0.1
@@ -0,0 +1 @@
+MD5 402fe65bece7adf2fcbf1c0df1e59602 xplanet-1.0.1.tar.gz 951540
diff --git a/x11-misc/xplanet/xplanet-1.0.1.ebuild b/x11-misc/xplanet/xplanet-1.0.1.ebuild
new file mode 100644
index 000000000000..f488fe2629b7
--- /dev/null
+++ b/x11-misc/xplanet/xplanet-1.0.1.ebuild
@@ -0,0 +1,76 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/xplanet/xplanet-1.0.1.ebuild,v 1.1 2003/03/18 07:05:15 vladimir Exp $
+
+IUSE="gif jpeg X opengl truetype tiff png"
+
+S=${WORKDIR}/${P}
+DESCRIPTION="A program to render images of the earth into the X root window"
+SRC_URI="http://unc.dl.sourceforge.net/sourceforge/${PN}/${P}.tar.gz"
+HOMEPAGE="http://xplanet.sourceforge.net/"
+
+RDEPEND="virtual/x11
+ opengl? ( virtual/opengl
+ media-libs/glut )
+ gif? ( media-libs/giflib
+ media-libs/libungif )
+ jpeg? ( media-libs/jpeg )
+ tiff? ( media-libs/tiff )
+ png? ( media-libs/libpng )
+ truetype? ( =media-libs/freetype-2* )"
+DEPEND="${RDEPEND}"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~x86 ~ppc ~sparc ~alpha ~mips ~hppa"
+
+src_unpack() {
+ unpack ${A}
+ # fix GCC3.2 include re-ordering bug.
+ D=${S}/ dosed 's,-I$prefix/include,,' configure
+}
+
+src_compile() {
+ local myconf
+
+ use X \
+ && myconf="$myconf --with-x" \
+ || myconf="$myconf --with-x=no"
+
+ use opengl \
+ && myconf="--with-gl --with-glut --with-animation" \
+ || myconf="--with-gl=no --with-glut=no --with-animation=no"
+
+ use gif \
+ && myconf="$myconf --with-gif" \
+ || myconf="$myconf --with-gif=no"
+
+ use jpeg \
+ && myconf="${myconf} --with-jpeg" \
+ || myconf="${myconf} --with-jpeg=no"
+
+ use tiff \
+ && myconf="${myconf} --with-tiff" \
+ || myconf="${myconf} --with-tiff=no"
+
+ use png \
+ && myconf="${myconf} --with-png --with-pnm" \
+ || myconf="${myconf} --with-png=no --with-pnm=no"
+
+# Compilation fails with freetype enabled, checking upstream
+# use truetype \
+# && myconf="${myconf} --with-freetype" \
+# || myconf="${myconf} --with-freetype=no"
+ myconf="${myconf} --with-freetype=no"
+
+ econf ${myconf} || die
+
+ # xplanet doesn't like to build parallel
+ make || die
+}
+
+src_install () {
+ einstall || die
+
+ dodoc README COPYING CREDITS FAQ INSTALL
+}