summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2014-09-03 09:03:58 +0000
committerJeroen Roovers <jer@gentoo.org>2014-09-03 09:03:58 +0000
commitaa667a8e5cb790475497a35a60409341dd982ee5 (patch)
treed9b3989ccdd7b12aa18e86b21f7b0fb0c08d0ed1 /x11-misc/xsetleds/xsetleds-0.1.3.ebuild
parenteinstall -> EAPI 5 default (bug #521672). (diff)
downloadhistorical-aa667a8e5cb790475497a35a60409341dd982ee5.tar.gz
historical-aa667a8e5cb790475497a35a60409341dd982ee5.tar.bz2
historical-aa667a8e5cb790475497a35a60409341dd982ee5.zip
einstall -> EAPI 5 default (bug #521674). Respect CC. Fix some coding issues.
Package-Manager: portage-2.2.12/cvs/Linux x86_64 Manifest-Sign-Key: 0xA792A613
Diffstat (limited to 'x11-misc/xsetleds/xsetleds-0.1.3.ebuild')
-rw-r--r--x11-misc/xsetleds/xsetleds-0.1.3.ebuild30
1 files changed, 20 insertions, 10 deletions
diff --git a/x11-misc/xsetleds/xsetleds-0.1.3.ebuild b/x11-misc/xsetleds/xsetleds-0.1.3.ebuild
index 277bd89da7a1..6f06f623d1c8 100644
--- a/x11-misc/xsetleds/xsetleds-0.1.3.ebuild
+++ b/x11-misc/xsetleds/xsetleds-0.1.3.ebuild
@@ -1,6 +1,9 @@
-# Copyright 1999-2008 Gentoo Foundation
+# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-misc/xsetleds/xsetleds-0.1.3.ebuild,v 1.16 2008/01/07 10:42:10 nelchael Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/xsetleds/xsetleds-0.1.3.ebuild,v 1.17 2014/09/03 09:03:56 jer Exp $
+
+EAPI=5
+inherit eutils toolchain-funcs
DESCRIPTION="small tool to report and change the keyboard LED states of an X display"
HOMEPAGE="ftp://ftp.unix-ag.org/user/bmeurer/xsetleds/"
@@ -9,16 +12,23 @@ SRC_URI="ftp://ftp.unix-ag.org/user/bmeurer/xsetleds/src/${P}.tar.gz"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="x86 ppc sparc alpha hppa ~mips amd64 ia64"
-IUSE=""
-RDEPEND="x11-libs/libX11
- x11-libs/libXtst"
-DEPEND="${RDEPEND}
+RDEPEND="
+ x11-libs/libX11
+ x11-libs/libXtst
+"
+DEPEND="
+ ${RDEPEND}
x11-proto/inputproto
x11-proto/xextproto
- x11-proto/xproto"
+ x11-proto/xproto
+"
-src_install() {
- einstall || die
- dodoc AUTHORS ChangeLog README TODO
+src_prepare() {
+ epatch \
+ "${FILESDIR}"/${P}-assignment.patch \
+ "${FILESDIR}"/${P}-isalpha.patch
+ tc-export CC
}
+
+DOCS=( AUTHORS ChangeLog README TODO )