summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJim Ramsay <lack@gentoo.org>2008-07-28 14:00:10 +0000
committerJim Ramsay <lack@gentoo.org>2008-07-28 14:00:10 +0000
commit9dfac1496dd16c747baad79bc2f38f6361c75855 (patch)
tree14ddcc71a4cd75561e7beced0232927059b31071 /x11-plugins/gkrellmss/gkrellmss-2.6-r1.ebuild
parentRemoved nokia6600 USE flag from libwbxml (diff)
downloadhistorical-9dfac1496dd16c747baad79bc2f38f6361c75855.tar.gz
historical-9dfac1496dd16c747baad79bc2f38f6361c75855.tar.bz2
historical-9dfac1496dd16c747baad79bc2f38f6361c75855.zip
Added 'die' if you try to build without at least one of USE=alsa or USE=esd (Bug #233025)
Package-Manager: portage-2.2_rc3/cvs/Linux 2.6.23-gentoo-r5 i686
Diffstat (limited to 'x11-plugins/gkrellmss/gkrellmss-2.6-r1.ebuild')
-rw-r--r--x11-plugins/gkrellmss/gkrellmss-2.6-r1.ebuild8
1 files changed, 7 insertions, 1 deletions
diff --git a/x11-plugins/gkrellmss/gkrellmss-2.6-r1.ebuild b/x11-plugins/gkrellmss/gkrellmss-2.6-r1.ebuild
index d3cd1fba0730..49ff2cabd84c 100644
--- a/x11-plugins/gkrellmss/gkrellmss-2.6-r1.ebuild
+++ b/x11-plugins/gkrellmss/gkrellmss-2.6-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-plugins/gkrellmss/gkrellmss-2.6-r1.ebuild,v 1.1 2008/04/11 15:12:26 lack Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-plugins/gkrellmss/gkrellmss-2.6-r1.ebuild,v 1.2 2008/07/28 14:00:10 lack Exp $
inherit gkrellm-plugin
@@ -23,6 +23,12 @@ KEYWORDS="~alpha ~amd64 ~ppc ~sparc ~x86"
PLUGIN_SO="src/gkrellmss.so"
PLUGIN_DOCS="Themes"
+pkg_preinst() {
+ if ! use esd && ! use alsa; then
+ die "You must enable at least one of USE=esd or USE=alsa"
+ fi
+}
+
src_compile() {
local myconf