summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMartin Holzer <mholzer@gentoo.org>2003-08-18 19:03:21 +0000
committerMartin Holzer <mholzer@gentoo.org>2003-08-18 19:03:21 +0000
commit6cc9292a966d456ba85b2c8af345f21fbc4bbf21 (patch)
tree7a4a439e908b24829ada06c7169dd4c5fdabb6c0 /x11-plugins/gkrellweather/gkrellweather-2.0.6.ebuild
parent*** empty log message *** (diff)
downloadhistorical-6cc9292a966d456ba85b2c8af345f21fbc4bbf21.tar.gz
historical-6cc9292a966d456ba85b2c8af345f21fbc4bbf21.tar.bz2
historical-6cc9292a966d456ba85b2c8af345f21fbc4bbf21.zip
*** empty log message ***
Diffstat (limited to 'x11-plugins/gkrellweather/gkrellweather-2.0.6.ebuild')
-rw-r--r--x11-plugins/gkrellweather/gkrellweather-2.0.6.ebuild43
1 files changed, 43 insertions, 0 deletions
diff --git a/x11-plugins/gkrellweather/gkrellweather-2.0.6.ebuild b/x11-plugins/gkrellweather/gkrellweather-2.0.6.ebuild
new file mode 100644
index 000000000000..8182f0a43634
--- /dev/null
+++ b/x11-plugins/gkrellweather/gkrellweather-2.0.6.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-plugins/gkrellweather/gkrellweather-2.0.6.ebuild,v 1.1 2003/08/18 19:03:10 mholzer Exp $
+
+S=${WORKDIR}/${P}
+DESCRIPTION="GKrellM2 Plugin that monitors a METAR station and displays weather
+info"
+SRC_URI="http://kmlinux.fjfi.cvut.cz/~makovick/gkrellm/${P}.tgz"
+HOMEPAGE="http://kmlinux.fjfi.cvut.cz/~makovick/gkrellm/index.html"
+
+SLOT="2"
+LICENSE="GPL-2"
+KEYWORDS="~x86 ~ppc ~sparc"
+
+DEPEND="=app-admin/gkrellm-2*
+ >=sys-apps/sed-4.0.5
+ >=net-misc/wget-1.5.3"
+
+RDEPEND="${DEPEND}
+ >=dev-lang/perl-5.6.1"
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+
+ sed -i \
+ -e "s:/usr/local/bin:/usr/share/gkrellm:g" \
+ -e "s:GrabWeather:GrabWeather2:g" \
+ gkrellweather.c
+}
+
+src_compile() {
+ emake || die
+}
+
+src_install () {
+ exeinto /usr/share/gkrellm
+ newexe GrabWeather GrabWeather2
+
+ insinto /usr/lib/gkrellm2/plugins
+ doins gkrellweather.so
+ dodoc README ChangeLog COPYING
+}