summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSerkan Kaba <serkan@gentoo.org>2010-07-08 19:45:13 +0000
committerSerkan Kaba <serkan@gentoo.org>2010-07-08 19:45:13 +0000
commit317301b921b28378a6c1521d36cf662655553560 (patch)
tree7ba021c499a8ab400959d3b92b8915c658a41854 /x11-plugins/pidgin-musictracker/pidgin-musictracker-0.4.21-r1.ebuild
parentDelete older ebuild. (diff)
downloadhistorical-317301b921b28378a6c1521d36cf662655553560.tar.gz
historical-317301b921b28378a6c1521d36cf662655553560.tar.bz2
historical-317301b921b28378a6c1521d36cf662655553560.zip
Revbump to fix bug #327239. Remove old.
Package-Manager: portage-2.2_rc67/cvs/Linux x86_64
Diffstat (limited to 'x11-plugins/pidgin-musictracker/pidgin-musictracker-0.4.21-r1.ebuild')
-rw-r--r--x11-plugins/pidgin-musictracker/pidgin-musictracker-0.4.21-r1.ebuild39
1 files changed, 39 insertions, 0 deletions
diff --git a/x11-plugins/pidgin-musictracker/pidgin-musictracker-0.4.21-r1.ebuild b/x11-plugins/pidgin-musictracker/pidgin-musictracker-0.4.21-r1.ebuild
new file mode 100644
index 000000000000..fc2540ebd0da
--- /dev/null
+++ b/x11-plugins/pidgin-musictracker/pidgin-musictracker-0.4.21-r1.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-plugins/pidgin-musictracker/pidgin-musictracker-0.4.21-r1.ebuild,v 1.1 2010/07/08 19:45:13 serkan Exp $
+
+EAPI="2"
+
+inherit autotools
+
+DESCRIPTION="A Pidgin now playing plugin to publicise the songs you are listening to in your status message"
+HOMEPAGE="http://code.google.com/p/pidgin-musictracker/"
+SRC_URI="http://pidgin-musictracker.googlecode.com/files/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="debug"
+
+DEPEND=">=net-im/pidgin-2.0.0
+ >=dev-libs/dbus-glib-0.73
+ dev-libs/libpcre
+ >=sys-devel/gettext-0.17"
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+ sed -i -e "s/musictracker_la_LDFLAGS =/musictracker_la_LDFLAGS = -shared/g" src/Makefile.am
+ eautoreconf
+}
+
+src_configure() {
+ econf \
+ $(use_enable debug) \
+ --disable-werror
+}
+
+src_install() {
+ emake install DESTDIR="${D}" || die "make install failure"
+ dodoc AUTHORS ChangeLog INSTALL README THANKS || die "dodoc failed"
+ find "${D}" -name "*.la" -delete || die "error cleaning la file."
+}