summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNick Hadaway <raker@gentoo.org>2002-10-03 15:03:16 +0000
committerNick Hadaway <raker@gentoo.org>2002-10-03 15:03:16 +0000
commitbbaf5149b858f08ff1b6eb55fcc8ff7d044ddde5 (patch)
tree20ca810f458ccae752a2b6898c128475d46345ee /x11-plugins
parentSecurity update (diff)
downloadhistorical-bbaf5149b858f08ff1b6eb55fcc8ff7d044ddde5.tar.gz
historical-bbaf5149b858f08ff1b6eb55fcc8ff7d044ddde5.tar.bz2
historical-bbaf5149b858f08ff1b6eb55fcc8ff7d044ddde5.zip
Updated wmnet with "... || die "blah"" constructs. Bug #1236 closed.
Added wmmemmon to x11-plugins. Closes bug #1324
Diffstat (limited to 'x11-plugins')
-rw-r--r--x11-plugins/wmmemmon/files/digest-wmmemmon-0.7.01
-rw-r--r--x11-plugins/wmmemmon/wmmemmon-0.7.0.ebuild37
-rw-r--r--x11-plugins/wmnet/ChangeLog7
-rw-r--r--x11-plugins/wmnet/wmnet-1.06.ebuild16
4 files changed, 55 insertions, 6 deletions
diff --git a/x11-plugins/wmmemmon/files/digest-wmmemmon-0.7.0 b/x11-plugins/wmmemmon/files/digest-wmmemmon-0.7.0
new file mode 100644
index 000000000000..f9ffe2e476da
--- /dev/null
+++ b/x11-plugins/wmmemmon/files/digest-wmmemmon-0.7.0
@@ -0,0 +1 @@
+MD5 25f45b3fe8c18a6fc4da9f00d71cd94b wmmemmon-0.7.0.tar.gz 126188
diff --git a/x11-plugins/wmmemmon/wmmemmon-0.7.0.ebuild b/x11-plugins/wmmemmon/wmmemmon-0.7.0.ebuild
new file mode 100644
index 000000000000..2eb39af57d62
--- /dev/null
+++ b/x11-plugins/wmmemmon/wmmemmon-0.7.0.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-plugins/wmmemmon/wmmemmon-0.7.0.ebuild,v 1.1 2002/10/03 15:03:16 raker Exp $
+
+S=${WORKDIR}/${P}
+
+DESCRIPTION="A program to monitor memory/swap usages."
+SRC_URI="http://www.sh.rim.or.jp/~ssato/src/${P}.tar.gz"
+HOMEPAGE="http://www.sh.rim.or.jp/~ssato/dockapp/index.shtml#wmmemmon"
+
+LICENSE="GPL-2"
+KEYWORDS="x86 sparc sparc64"
+SLOT="0"
+
+DEPEND="virtual/glibc x11-base/xfree"
+RDEPEND="${DEPEND}"
+
+src_compile() {
+
+ econf || die "configure failed"
+
+ emake || die "parallel make failed"
+
+}
+
+src_install () {
+
+ einstall || die "make install failed"
+
+ doman doc/wmmemmon.1
+
+ dodoc AUTHORS THANKS TODO Changelog README
+
+ dobin src/wmmemmon
+
+}
+
diff --git a/x11-plugins/wmnet/ChangeLog b/x11-plugins/wmnet/ChangeLog
index 3f5636c4acc5..41d3de173bf2 100644
--- a/x11-plugins/wmnet/ChangeLog
+++ b/x11-plugins/wmnet/ChangeLog
@@ -1,13 +1,14 @@
# ChangeLog for x11-plugins/wmnet
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
-# $Header: /var/cvsroot/gentoo-x86/x11-plugins/wmnet/ChangeLog,v 1.1 2002/08/30 07:44:13 seemant Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-plugins/wmnet/ChangeLog,v 1.2 2002/10/03 15:03:16 raker Exp $
*wmnet-1.06.ebuild (8 Jun 2002)
- 30 Aug 2002; Seemant Kulleen <seemant@gentoo.org> * :
+ 04 Oct 2002; Nick Hadaway <raker@gentoo.org> wmnet-1.06.ebuild :
+ Added "... || die "blah"" to ebuild where appropriate.
+ 30 Aug 2002; Seemant Kulleen <seemant@gentoo.org> * :
Relocated to x11-plugins
8 Jun 2002; Donny Davies <woodchip@gentoo.org> :
-
New port from eyez@infinite.fsw.leidenuniv.nl (Y-z).
diff --git a/x11-plugins/wmnet/wmnet-1.06.ebuild b/x11-plugins/wmnet/wmnet-1.06.ebuild
index cf5afb276779..c89286cd2cbb 100644
--- a/x11-plugins/wmnet/wmnet-1.06.ebuild
+++ b/x11-plugins/wmnet/wmnet-1.06.ebuild
@@ -1,26 +1,36 @@
# Copyright 1999-2002 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-plugins/wmnet/wmnet-1.06.ebuild,v 1.1 2002/08/30 07:44:13 seemant Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-plugins/wmnet/wmnet-1.06.ebuild,v 1.2 2002/10/03 15:03:16 raker Exp $
S=${WORKDIR}/${P}
+
DESCRIPTION="WMnet is a dock.app network monitor"
SRC_URI="http://www.digitalkaos.net/linux/${PN}/download/${P}.tar.gz"
HOMEPAGE="http://http://www.digitalkaos.net/linux/wmnet/"
DEPEND="virtual/x11"
+RDEPEND="${DEPEND}"
SLOT="0"
LICENSE="GPL-2"
KEYWORDS="x86 sparc sparc64"
src_compile() {
- xmkmf
- emake || die
+
+ xmkmf || die "xmkmf failed"
+
+ emake || die "parallel make failed"
+
}
src_install() {
+
dobin wmnet
+
dohtml wmnet.1x.html
+
newman wmnet.man wmnet.1
+
dodoc README Changelog
+
}