summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Weber <xmw@gentoo.org>2010-08-31 09:04:56 +0000
committerMichael Weber <xmw@gentoo.org>2010-08-31 09:04:56 +0000
commitb6d6d4cd7196c60496d6dbb184a1d589ad9e9501 (patch)
tree742cfad6df7f72ee32400328ca3a1d940b87346e /x11-wm/parti
parentMake package honour LDFLAGS. Closes bug #335029. (diff)
downloadhistorical-b6d6d4cd7196c60496d6dbb184a1d589ad9e9501.tar.gz
historical-b6d6d4cd7196c60496d6dbb184a1d589ad9e9501.tar.bz2
historical-b6d6d4cd7196c60496d6dbb184a1d589ad9e9501.zip
Initial import
Package-Manager: portage-2.1.8.3/cvs/Linux x86_64
Diffstat (limited to 'x11-wm/parti')
-rw-r--r--x11-wm/parti/ChangeLog13
-rw-r--r--x11-wm/parti/Manifest6
-rw-r--r--x11-wm/parti/files/parti-0.0.6-python-2.6-sets-deprecation.patch52
-rw-r--r--x11-wm/parti/files/parti-0.0.6-python-import.patch15
-rw-r--r--x11-wm/parti/metadata.xml10
-rw-r--r--x11-wm/parti/parti-0.0.6.ebuild46
6 files changed, 142 insertions, 0 deletions
diff --git a/x11-wm/parti/ChangeLog b/x11-wm/parti/ChangeLog
new file mode 100644
index 000000000000..b91123bd8d59
--- /dev/null
+++ b/x11-wm/parti/ChangeLog
@@ -0,0 +1,13 @@
+# ChangeLog for x11-wm/parti
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/x11-wm/parti/ChangeLog,v 1.1 2010/08/31 09:04:56 xmw Exp $
+
+*parti-0.0.6 (31 Aug 2010)
+
+ 31 Aug 2010; Michael Weber <xmw@gentoo.org> +parti-0.0.6.ebuild,
+ +files/parti-0.0.6-python-2.6-sets-deprecation.patch,
+ +files/parti-0.0.6-python-import.patch, +metadata.xml:
+ Initial commit, fixed bug #271527, thanks to Pinkbyte <pinkbyte@mail.ru>,
+ Dan <dtyler@csh.rit.edu> and Eric Johnson <tokenmathematician@gmail.com>
+ for their great work on bug #271527.
+
diff --git a/x11-wm/parti/Manifest b/x11-wm/parti/Manifest
new file mode 100644
index 000000000000..b7c4b754d9e7
--- /dev/null
+++ b/x11-wm/parti/Manifest
@@ -0,0 +1,6 @@
+AUX parti-0.0.6-python-2.6-sets-deprecation.patch 1834 RMD160 24c84d4195b5a99c52c8b5059c9c2c905b610473 SHA1 03476c2af9f1aa5a790a8914a93f220f3faed2be SHA256 cf926d62e0c9abc024f3db55ac9bf0cd85f3775395cb94f4d76ac7af28872bbf
+AUX parti-0.0.6-python-import.patch 380 RMD160 25cc357c1518fbd0280f5a7000261d714cc27a0f SHA1 0dd77b9119e031f46f77025e1fe2d96e686f85de SHA256 58e415ab3dc0f1f254137cf8ef252be57ffd12f5b3d89ed28a68a621e43d0342
+DIST parti-all-0.0.6.tar.gz 805514 RMD160 0019ea81b5f530caf75b20b1f336b191e0c2e54f SHA1 618da8ba931a186668caf1ee8534aa78230db38b SHA256 1aa66b9cbf29bf487d2717cb7e220990dcc562f2abf07ad63e57afb59efee614
+EBUILD parti-0.0.6.ebuild 1130 RMD160 deeb01acf18262a17d9df8711ef79ee7414e241a SHA1 19ed7808d657521cee018a17619c4bd181aa6789 SHA256 308248f535b3d182adef6ec4f67e84f2784b965ca47915d0ef509d84d1aa0d2c
+MISC ChangeLog 593 RMD160 e70aa4bc72394b5581e501bd051c61f5c04f8d4e SHA1 e9e3098d8afd2e93245188126a0f6dd0e3391f1d SHA256 e878a32e9fae05e4c5522d2dbcc863310ca581bf1ccd83a82b7278f3e6764088
+MISC metadata.xml 245 RMD160 6b03982a4d5f32d9fa6b9259ae36f9fcb07c8404 SHA1 fb16c7b4c5ab071dd979f761b8bb075f5396b737 SHA256 375a1da02cd2c393ce2378a73c1ce08134bc030b3bb378c6a4d6ca9cd5be1f8d
diff --git a/x11-wm/parti/files/parti-0.0.6-python-2.6-sets-deprecation.patch b/x11-wm/parti/files/parti-0.0.6-python-2.6-sets-deprecation.patch
new file mode 100644
index 000000000000..91cbebd1d19c
--- /dev/null
+++ b/x11-wm/parti/files/parti-0.0.6-python-2.6-sets-deprecation.patch
@@ -0,0 +1,52 @@
+upsream changeset 620a831d81
+hg clone https://partiwm.googlecode.com/hg/ partiwm
+hg diff -c 620a831d81
+
+diff -r 35cf8653d223 -r 620a831d81d1 wimpiggy/window.py
+--- a/wimpiggy/window.py Sun Jul 18 16:08:36 2010 -0700
++++ b/wimpiggy/window.py Sat Jul 31 08:36:22 2010 -0700
+@@ -8,7 +8,13 @@
+ Most of the gunk required to be a valid window manager (reparenting, synthetic
+ events, mucking about with properties, etc. etc.) is wrapped up in here."""
+
+-import sets
++# Maintain compatibility with old versions of Python, while avoiding a
++# deprecation warning on new versions:
++import sys
++if sys.version_info < (2, 6):
++ from sets import ImmutableSet
++else:
++ ImmutableSet = frozenset
+ import gobject
+ import gtk
+ import gtk.gdk
+@@ -775,9 +781,9 @@
+ net_wm_state = prop_get(self.client_window,
+ "_NET_WM_STATE", ["atom"])
+ if net_wm_state:
+- self._internal_set_property("state", sets.ImmutableSet(net_wm_state))
++ self._internal_set_property("state", ImmutableSet(net_wm_state))
+ else:
+- self._internal_set_property("state", sets.ImmutableSet())
++ self._internal_set_property("state", ImmutableSet())
+
+ for mutable in ["WM_HINTS", "WM_NORMAL_HINTS",
+ "WM_NAME", "_NET_WM_NAME",
+diff -r 35cf8653d223 -r 620a831d81d1 wimpiggy/wm.py
+--- a/wimpiggy/wm.py Sun Jul 18 16:08:36 2010 -0700
++++ b/wimpiggy/wm.py Sat Jul 31 08:36:22 2010 -0700
+@@ -6,7 +6,13 @@
+ import gtk
+ import gobject
+
+-from sets import ImmutableSet
++# Maintain compatibility with old versions of Python, while avoiding a
++# deprecation warning on new versions:
++import sys
++if sys.version_info < (2, 6):
++ from sets import ImmutableSet
++else:
++ ImmutableSet = frozenset
+
+ from wimpiggy.error import *
+ import wimpiggy.selection
diff --git a/x11-wm/parti/files/parti-0.0.6-python-import.patch b/x11-wm/parti/files/parti-0.0.6-python-import.patch
new file mode 100644
index 000000000000..9668d774b103
--- /dev/null
+++ b/x11-wm/parti/files/parti-0.0.6-python-import.patch
@@ -0,0 +1,15 @@
+upsream changeset fedd8b2841
+hg clone https://partiwm.googlecode.com/hg/ partiwm
+hg diff -c fedd8b2841
+
+diff -r d35431b2028f -r fedd8b284197 xpra/server.py
+--- a/xpra/server.py Tue May 05 21:49:16 2009 +0000
++++ b/xpra/server.py Sun May 10 22:15:46 2009 +0000
+@@ -14,6 +14,7 @@
+ import cairo
+ import os
+ import os.path
++import sys
+ import subprocess
+
+ from wimpiggy.wm import Wm
diff --git a/x11-wm/parti/metadata.xml b/x11-wm/parti/metadata.xml
new file mode 100644
index 000000000000..02b909e46b7e
--- /dev/null
+++ b/x11-wm/parti/metadata.xml
@@ -0,0 +1,10 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>no-herd</herd>
+<maintainer>
+<email>xmw@gentoo.org</email>
+<name>Michael Weber</name>
+</maintainer>
+</pkgmetadata>
+
diff --git a/x11-wm/parti/parti-0.0.6.ebuild b/x11-wm/parti/parti-0.0.6.ebuild
new file mode 100644
index 000000000000..8d076c0fbd20
--- /dev/null
+++ b/x11-wm/parti/parti-0.0.6.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-wm/parti/parti-0.0.6.ebuild,v 1.1 2010/08/31 09:04:56 xmw Exp $
+
+EAPI=2
+
+PYTHON_DEPEND=2
+
+inherit distutils eutils python
+
+DESCRIPTION="X Persistent Remote Apps (xpra) and Partitioning WM (parti) based on wimpiggy"
+HOMEPAGE="http://partiwm.googlecode.com/"
+MY_P="${PN}-all-${PV}"
+SRC_URI="http://${PN}wm.googlecode.com/files/${MY_P}.tar.gz"
+
+LICENSE="GPL-2 LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+COMMON_DEPEND="dev-python/pygtk
+ x11-libs/libX11
+ x11-libs/libXcomposite
+ x11-libs/libXdamage
+ x11-libs/libXtst"
+
+RDEPEND="${COMMON_RDEPEND}
+ dev-python/ipython
+ x11-apps/xmodmap"
+DEPEND="${COMMON_RDEPEND}
+ dev-python/pyrex
+ dev-util/pkgconfig"
+
+S=${WORKDIR}/${MY_P}
+
+pkg_setup() {
+ python_set_active_version 2
+}
+
+src_prepare() {
+ # upstream changeset 620a831d81, solved deprecation warnings on module sets
+ epatch "${FILESDIR}"/${P}-python-2.6-sets-deprecation.patch
+
+ # upstream changeset fedd8b2841, adds missing import sys
+ epatch "${FILESDIR}"/${P}-python-import.patch
+}