summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <ssuominen@gentoo.org>2012-04-21 05:43:14 +0000
committerSamuli Suominen <ssuominen@gentoo.org>2012-04-21 05:43:14 +0000
commitb87f96b4c85055af6484f878cdd65ef1a53f9175 (patch)
tree556d74fe146288cd8e6452b353dc7c0b696f4db8 /xfce-extra
parenttidy. use libdir instead of libexecdir (diff)
downloadhistorical-b87f96b4c85055af6484f878cdd65ef1a53f9175.tar.gz
historical-b87f96b4c85055af6484f878cdd65ef1a53f9175.tar.bz2
historical-b87f96b4c85055af6484f878cdd65ef1a53f9175.zip
Install to libdir instead of libexecdir.
Package-Manager: portage-2.2.0_alpha100/cvs/Linux x86_64
Diffstat (limited to 'xfce-extra')
-rw-r--r--xfce-extra/xfce4-cellmodem-plugin/ChangeLog8
-rw-r--r--xfce-extra/xfce4-cellmodem-plugin/xfce4-cellmodem-plugin-0.0.5.ebuild24
-rw-r--r--xfce-extra/xfce4-cpugraph-plugin/ChangeLog8
-rw-r--r--xfce-extra/xfce4-cpugraph-plugin/xfce4-cpugraph-plugin-1.0.1.ebuild22
-rw-r--r--xfce-extra/xfce4-modemlights-plugin/ChangeLog8
-rw-r--r--xfce-extra/xfce4-modemlights-plugin/xfce4-modemlights-plugin-0.1.3.99.ebuild18
-rw-r--r--xfce-extra/xfce4-timer-plugin/ChangeLog6
-rw-r--r--xfce-extra/xfce4-timer-plugin/xfce4-timer-plugin-0.6.4.ebuild8
8 files changed, 67 insertions, 35 deletions
diff --git a/xfce-extra/xfce4-cellmodem-plugin/ChangeLog b/xfce-extra/xfce4-cellmodem-plugin/ChangeLog
index 2bcbccc9e382..dfc3d99c0655 100644
--- a/xfce-extra/xfce4-cellmodem-plugin/ChangeLog
+++ b/xfce-extra/xfce4-cellmodem-plugin/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for xfce-extra/xfce4-cellmodem-plugin
-# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/xfce-extra/xfce4-cellmodem-plugin/ChangeLog,v 1.2 2010/08/05 23:13:58 ssuominen Exp $
+# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/xfce-extra/xfce4-cellmodem-plugin/ChangeLog,v 1.3 2012/04/21 05:39:16 ssuominen Exp $
+
+ 21 Apr 2012; Samuli Suominen <ssuominen@gentoo.org>
+ xfce4-cellmodem-plugin-0.0.5.ebuild:
+ Install to libdir instead of libexecdir.
05 Aug 2010; Samuli Suominen <ssuominen@gentoo.org>
xfce4-cellmodem-plugin-0.0.5.ebuild,
diff --git a/xfce-extra/xfce4-cellmodem-plugin/xfce4-cellmodem-plugin-0.0.5.ebuild b/xfce-extra/xfce4-cellmodem-plugin/xfce4-cellmodem-plugin-0.0.5.ebuild
index b5520139eb1b..33a9a30fd9eb 100644
--- a/xfce-extra/xfce4-cellmodem-plugin/xfce4-cellmodem-plugin-0.0.5.ebuild
+++ b/xfce-extra/xfce4-cellmodem-plugin/xfce4-cellmodem-plugin-0.0.5.ebuild
@@ -1,25 +1,25 @@
-# Copyright 1999-2011 Gentoo Foundation
+# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/xfce-extra/xfce4-cellmodem-plugin/xfce4-cellmodem-plugin-0.0.5.ebuild,v 1.4 2011/05/19 21:38:50 ssuominen Exp $
+# $Header: /var/cvsroot/gentoo-x86/xfce-extra/xfce4-cellmodem-plugin/xfce4-cellmodem-plugin-0.0.5.ebuild,v 1.5 2012/04/21 05:39:16 ssuominen Exp $
EAPI=4
EAUTORECONF=yes
EINTLTOOLIZE=yes
-inherit xfconf
+inherit multilib xfconf
-DESCRIPTION="Panel plugin for monitoring cellular modems - GPRS/UMTS(3G)/HSDPA(3.5G)"
+DESCRIPTION="A panel plug-in with monitoring support for GPRS/UMTS(3G)/HSDPA(3.5G) modems"
HOMEPAGE="http://goodies.xfce.org/projects/panel-plugins/xfce4-cellmodem-plugin"
-SRC_URI="mirror://xfce/src/panel-plugins/${PN}/0.0/${P}.tar.gz"
+SRC_URI="mirror://xfce/src/panel-plugins/${PN}/${PV%.*}/${P}.tar.gz"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="amd64 x86"
IUSE="debug"
-RDEPEND=">=xfce-base/xfce4-panel-4.8
+RDEPEND="sys-apps/pciutils[zlib]
+ virtual/libusb:0
>=xfce-base/libxfcegui4-4.8
- sys-apps/pciutils[zlib]
- virtual/libusb:0"
+ >=xfce-base/xfce4-panel-4.8"
DEPEND="${RDEPEND}
dev-util/intltool
dev-util/pkgconfig"
@@ -30,11 +30,15 @@ pkg_setup() {
"${FILESDIR}"/${P}-link_for_xfce_warn.patch
)
- XFCONF=( $(use_enable debug) )
+ XFCONF=(
+ --libexecdir="${EPREFIX}"/usr/$(get_libdir)
+ $(use_enable debug)
+ )
+
DOCS=( AUTHORS ChangeLog README )
}
src_prepare() {
- echo panel-plugin/cellmodem.desktop.in.in >> po/POTFILES.skip
+ echo panel-plugin/cellmodem.desktop.in.in > po/POTFILES.skip
xfconf_src_prepare
}
diff --git a/xfce-extra/xfce4-cpugraph-plugin/ChangeLog b/xfce-extra/xfce4-cpugraph-plugin/ChangeLog
index 7f2f585cbac1..9f37ae4e5364 100644
--- a/xfce-extra/xfce4-cpugraph-plugin/ChangeLog
+++ b/xfce-extra/xfce4-cpugraph-plugin/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for xfce-extra/xfce4-cpugraph-plugin
-# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/xfce-extra/xfce4-cpugraph-plugin/ChangeLog,v 1.17 2011/04/23 17:34:03 ssuominen Exp $
+# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/xfce-extra/xfce4-cpugraph-plugin/ChangeLog,v 1.18 2012/04/21 05:41:50 ssuominen Exp $
+
+ 21 Apr 2012; Samuli Suominen <ssuominen@gentoo.org>
+ xfce4-cpugraph-plugin-1.0.1.ebuild:
+ Install to libdir instead of libexecdir.
23 Apr 2011; Samuli Suominen <ssuominen@gentoo.org>
xfce4-cpugraph-plugin-1.0.1.ebuild:
diff --git a/xfce-extra/xfce4-cpugraph-plugin/xfce4-cpugraph-plugin-1.0.1.ebuild b/xfce-extra/xfce4-cpugraph-plugin/xfce4-cpugraph-plugin-1.0.1.ebuild
index 59503d65fe1e..ed9374db4e4b 100644
--- a/xfce-extra/xfce4-cpugraph-plugin/xfce4-cpugraph-plugin-1.0.1.ebuild
+++ b/xfce-extra/xfce4-cpugraph-plugin/xfce4-cpugraph-plugin-1.0.1.ebuild
@@ -1,28 +1,32 @@
-# Copyright 1999-2011 Gentoo Foundation
+# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/xfce-extra/xfce4-cpugraph-plugin/xfce4-cpugraph-plugin-1.0.1.ebuild,v 1.8 2011/05/19 20:42:04 ssuominen Exp $
+# $Header: /var/cvsroot/gentoo-x86/xfce-extra/xfce4-cpugraph-plugin/xfce4-cpugraph-plugin-1.0.1.ebuild,v 1.9 2012/04/21 05:41:50 ssuominen Exp $
EAPI=4
-inherit xfconf
+inherit multilib xfconf
DESCRIPTION="A system load plug-in for the Xfce panel"
HOMEPAGE="http://goodies.xfce.org/projects/panel-plugins/xfce4-cpugraph-plugin"
-SRC_URI="mirror://xfce/src/panel-plugins/${PN}/1.0/${P}.tar.bz2"
+SRC_URI="mirror://xfce/src/panel-plugins/${PN}/${PV%.*}/${P}.tar.bz2"
-LICENSE="BSD GPL-2"
+LICENSE="BSD-2 GPL-2"
SLOT="0"
KEYWORDS="alpha amd64 arm hppa ia64 ppc ppc64 sparc x86 ~x86-fbsd ~x86-freebsd ~amd64-linux ~ia64-linux ~x86-linux"
IUSE="debug"
-RDEPEND=">=xfce-base/libxfcegui4-4.8
- >=xfce-base/xfce4-panel-4.8
- >=x11-libs/gtk+-2.12:2"
+RDEPEND=">=x11-libs/gtk+-2.12:2
+ >=xfce-base/libxfcegui4-4.8
+ >=xfce-base/xfce4-panel-4.8"
DEPEND="${RDEPEND}
dev-util/intltool
dev-util/pkgconfig
sys-devel/gettext"
pkg_setup() {
- XFCONF=( $(xfconf_use_debug) )
+ XFCONF=(
+ --libexecdir="${EPREFIX}"/usr/$(get_libdir)
+ $(xfconf_use_debug)
+ )
+
DOCS=( AUTHORS ChangeLog NEWS README )
}
diff --git a/xfce-extra/xfce4-modemlights-plugin/ChangeLog b/xfce-extra/xfce4-modemlights-plugin/ChangeLog
index 2b14a84e14ce..f041663c3efd 100644
--- a/xfce-extra/xfce4-modemlights-plugin/ChangeLog
+++ b/xfce-extra/xfce4-modemlights-plugin/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for xfce-extra/xfce4-modemlights-plugin
-# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/xfce-extra/xfce4-modemlights-plugin/ChangeLog,v 1.3 2011/05/19 21:00:00 ssuominen Exp $
+# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/xfce-extra/xfce4-modemlights-plugin/ChangeLog,v 1.4 2012/04/21 05:34:23 ssuominen Exp $
+
+ 21 Apr 2012; Samuli Suominen <ssuominen@gentoo.org>
+ xfce4-modemlights-plugin-0.1.3.99.ebuild:
+ Install to libdir instead of libexecdir.
19 May 2011; Samuli Suominen <ssuominen@gentoo.org>
xfce4-modemlights-plugin-0.1.3.99.ebuild:
diff --git a/xfce-extra/xfce4-modemlights-plugin/xfce4-modemlights-plugin-0.1.3.99.ebuild b/xfce-extra/xfce4-modemlights-plugin/xfce4-modemlights-plugin-0.1.3.99.ebuild
index 89202dd0bfe0..0fc9710dbdde 100644
--- a/xfce-extra/xfce4-modemlights-plugin/xfce4-modemlights-plugin-0.1.3.99.ebuild
+++ b/xfce-extra/xfce4-modemlights-plugin/xfce4-modemlights-plugin-0.1.3.99.ebuild
@@ -1,21 +1,21 @@
-# Copyright 1999-2011 Gentoo Foundation
+# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/xfce-extra/xfce4-modemlights-plugin/xfce4-modemlights-plugin-0.1.3.99.ebuild,v 1.5 2011/05/19 21:00:00 ssuominen Exp $
+# $Header: /var/cvsroot/gentoo-x86/xfce-extra/xfce4-modemlights-plugin/xfce4-modemlights-plugin-0.1.3.99.ebuild,v 1.6 2012/04/21 05:34:23 ssuominen Exp $
EAPI=4
-inherit xfconf
+inherit multilib xfconf
DESCRIPTION="A panel plug-in intended to simplify establishing a ppp connection"
HOMEPAGE="http://goodies.xfce.org/projects/panel-plugins/xfce4-modemlights-plugin"
-SRC_URI="mirror://xfce/src/panel-plugins/${PN}/0.1/${P}.tar.bz2"
+SRC_URI="mirror://xfce/src/panel-plugins/${PN}/${PV%.*.*}/${P}.tar.bz2"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="amd64 x86"
IUSE="debug"
-RDEPEND=">=dev-libs/glib-2.8:2
- >=x11-libs/gtk+-2.6:2
+RDEPEND=">=dev-libs/glib-2
+ x11-libs/gtk+:2
>=xfce-base/libxfce4util-4.8
>=xfce-base/libxfcegui4-4.8
>=xfce-base/xfce4-panel-4.8"
@@ -24,6 +24,10 @@ DEPEND="${RDEPEND}
dev-util/pkgconfig"
pkg_setup() {
- XFCONF=( $(use_enable debug) )
+ XFCONF=(
+ --libexecdir="${EPREFIX}"/usr/$(get_libdir)
+ $(use_enable debug)
+ )
+
DOCS=( AUTHORS ChangeLog NEWS README )
}
diff --git a/xfce-extra/xfce4-timer-plugin/ChangeLog b/xfce-extra/xfce4-timer-plugin/ChangeLog
index d4f6d194d195..3a7aba3c350c 100644
--- a/xfce-extra/xfce4-timer-plugin/ChangeLog
+++ b/xfce-extra/xfce4-timer-plugin/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for xfce-extra/xfce4-timer-plugin
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/xfce-extra/xfce4-timer-plugin/ChangeLog,v 1.23 2012/04/17 07:33:31 ssuominen Exp $
+# $Header: /var/cvsroot/gentoo-x86/xfce-extra/xfce4-timer-plugin/ChangeLog,v 1.24 2012/04/21 05:43:14 ssuominen Exp $
+
+ 21 Apr 2012; Samuli Suominen <ssuominen@gentoo.org>
+ xfce4-timer-plugin-0.6.4.ebuild:
+ Install to libdir instead of libexecdir.
17 Apr 2012; Samuli Suominen <ssuominen@gentoo.org>
-xfce4-timer-plugin-0.6.2.ebuild:
diff --git a/xfce-extra/xfce4-timer-plugin/xfce4-timer-plugin-0.6.4.ebuild b/xfce-extra/xfce4-timer-plugin/xfce4-timer-plugin-0.6.4.ebuild
index 9339108ca17a..c4836236dc0e 100644
--- a/xfce-extra/xfce4-timer-plugin/xfce4-timer-plugin-0.6.4.ebuild
+++ b/xfce-extra/xfce4-timer-plugin/xfce4-timer-plugin-0.6.4.ebuild
@@ -1,9 +1,9 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/xfce-extra/xfce4-timer-plugin/xfce4-timer-plugin-0.6.4.ebuild,v 1.1 2012/02/14 04:20:45 ssuominen Exp $
+# $Header: /var/cvsroot/gentoo-x86/xfce-extra/xfce4-timer-plugin/xfce4-timer-plugin-0.6.4.ebuild,v 1.2 2012/04/21 05:43:14 ssuominen Exp $
EAPI=4
-inherit xfconf
+inherit multilib xfconf
DESCRIPTION="A simple timer plug-in for the Xfce desktop environment"
HOMEPAGE="http://goodies.xfce.org/projects/panel-plugins/xfce4-timer-plugin"
@@ -22,5 +22,9 @@ DEPEND="${RDEPEND}
dev-util/pkgconfig"
pkg_setup() {
+ XFCONF=(
+ --libexecdir="${EPREFIX}"/usr/$(get_libdir)
+ )
+
DOCS=( AUTHORS ChangeLog README TODO )
}