summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--games-arcade/apricots/ChangeLog8
-rw-r--r--games-arcade/apricots/Manifest5
-rw-r--r--games-arcade/apricots/apricots-0.2.6-r1.ebuild10
-rw-r--r--games-arcade/apricots/files/apricots-0.2.6-ldflags.patch20
4 files changed, 35 insertions, 8 deletions
diff --git a/games-arcade/apricots/ChangeLog b/games-arcade/apricots/ChangeLog
index 636f4465e120..171278c11364 100644
--- a/games-arcade/apricots/ChangeLog
+++ b/games-arcade/apricots/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for games-arcade/apricots
-# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-arcade/apricots/ChangeLog,v 1.15 2009/05/06 01:50:54 mr_bones_ Exp $
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/games-arcade/apricots/ChangeLog,v 1.16 2010/10/11 14:58:49 tupone Exp $
+
+ 11 Oct 2010; Tupone Alfredo <tupone@gentoo.org> apricots-0.2.6-r1.ebuild,
+ +files/apricots-0.2.6-ldflags.patch:
+ Respect LDFLAGS. Bug #340139 by flameeyes@gentoo.org
06 May 2009; Michael Sterrett <mr_bones_@gentoo.org>
apricots-0.2.6-r1.ebuild:
diff --git a/games-arcade/apricots/Manifest b/games-arcade/apricots/Manifest
index 3fd8ef26c5a7..aa8677165f48 100644
--- a/games-arcade/apricots/Manifest
+++ b/games-arcade/apricots/Manifest
@@ -1,5 +1,6 @@
AUX apricots-0.2.6-freealut.patch 1596 RMD160 abed45089e3714dc116af6f0662ddece8938bfdb SHA1 7d6d42d8ad37705965ea2c4e5fedf1736d6653e3 SHA256 aca9d74921a9be155ad1ddf309d78aa059e8856b19799ba488659cd96fbd7c94
+AUX apricots-0.2.6-ldflags.patch 829 RMD160 3e2ce35af4cf77557fe4beec691a3ef5ae8b17b4 SHA1 5d2250936e95127dc4dc66cdaeeaa6c335057814 SHA256 0cc20803d7ad997825bedc494bfa909a1b3909a19379bb8d19e3644c25467647
DIST apricots-0.2.6.tar.gz 768568 RMD160 54377e287a7ce693a90a2387b4c53860f68487cb SHA1 4b5b4c867fc92d4fc717d16b30dbaf8411f24a48 SHA256 9c408722abbb0cb925384f12a65fe4f6e2b3373d5ce5d0e5afe3aeb738b9cd8f
-EBUILD apricots-0.2.6-r1.ebuild 1679 RMD160 0e34903aaed32ef3ef80b4ecb65e57b7e6ca23a6 SHA1 a4a890e22f60c4fd884f614de410e138f276f929 SHA256 fa6352f9834082382e7d666f65d03fecd5eaffa8decaf9cedceabd757c529fcd
-MISC ChangeLog 2164 RMD160 042697fed4d2e23c260499771d0776b3911f9557 SHA1 9837ab6859c2d45f1146a0b1d491c4c5285106df SHA256 b5097f254d18c72b3f4f61dfb8401fd1b4ade1cf08039575689073a23792d69c
+EBUILD apricots-0.2.6-r1.ebuild 1734 RMD160 857b0c936fa2153944128620a2bd1aa19921076c SHA1 a069c06953c3df74e52163030f16fdcfad3bda33 SHA256 5bdf068d9548d193e51f0c15251553e2f8ec251930466a8ed7a519e6d5bb54dd
+MISC ChangeLog 2332 RMD160 5f95c641858edff58502d5c19bc4f432ff7e74d2 SHA1 dc63fac4226c0223e57bf04e17e1a98bf5b95f8e SHA256 2ca207755d25345aa7aee64b71adf492cf401e2211404c9ac54c28ececabfaae
MISC metadata.xml 158 RMD160 cbd9984bb6b426c8c9cee5022fe0a26261612fea SHA1 be5251fa1dacef5c41b74761bb1c8c54fb633b9e SHA256 1423a4fdd4a79b1728a2056d9e300f7e1074253095d82726218d9e9b953888a3
diff --git a/games-arcade/apricots/apricots-0.2.6-r1.ebuild b/games-arcade/apricots/apricots-0.2.6-r1.ebuild
index d4af6a0f1bb1..bff0b2efba24 100644
--- a/games-arcade/apricots/apricots-0.2.6-r1.ebuild
+++ b/games-arcade/apricots/apricots-0.2.6-r1.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2009 Gentoo Foundation
+# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-arcade/apricots/apricots-0.2.6-r1.ebuild,v 1.8 2009/05/06 01:50:54 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-arcade/apricots/apricots-0.2.6-r1.ebuild,v 1.9 2010/10/11 14:58:49 tupone Exp $
EAPI=2
inherit autotools eutils games
@@ -14,12 +14,14 @@ SLOT="0"
KEYWORDS="amd64 ppc ~sparc x86 ~x86-fbsd"
IUSE=""
-DEPEND="media-libs/libsdl
+RDEPEND="media-libs/libsdl
media-libs/openal
media-libs/freealut"
+DEPEND="${RDEPEND}"
src_prepare() {
- epatch "${FILESDIR}"/${P}-freealut.patch
+ epatch "${FILESDIR}"/${P}-freealut.patch \
+ "${FILESDIR}"/${P}-ldflags.patch
cp admin/acinclude.m4.in acinclude.m4
diff --git a/games-arcade/apricots/files/apricots-0.2.6-ldflags.patch b/games-arcade/apricots/files/apricots-0.2.6-ldflags.patch
new file mode 100644
index 000000000000..5a2a34490b7e
--- /dev/null
+++ b/games-arcade/apricots/files/apricots-0.2.6-ldflags.patch
@@ -0,0 +1,20 @@
+--- apricots/Makefile.am.old 2010-10-11 15:58:18.000000000 +0200
++++ apricots/Makefile.am 2010-10-11 15:59:21.000000000 +0200
+@@ -4,7 +4,8 @@
+ ## INCLUDES were found outside kdevelop specific part
+
+ apricots_SOURCES = SDLfont.cpp shape.cpp setup.cpp sampleio.cpp init.cpp game.cpp finish.cpp fall.cpp drawall.cpp drak.cpp collide.cpp apricots.cpp all.cpp ai.cpp
+-apricots_LDADD =
++apricots_LDADD = $(all_libraries)
++
+
+ SUBDIRS = docs
+
+@@ -68,7 +69,3 @@
+ ####### kdevelop will overwrite this part!!! (end)############
+ # set the include path found by configure
+ INCLUDES= $(all_includes)
+-
+-# the library search path.
+-apricots_LDFLAGS = $(all_libraries)
+-