summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--eclass/distutils.eclass14
1 files changed, 12 insertions, 2 deletions
diff --git a/eclass/distutils.eclass b/eclass/distutils.eclass
index bb4e1eccbffe..76f2305a02ff 100644
--- a/eclass/distutils.eclass
+++ b/eclass/distutils.eclass
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/eclass/distutils.eclass,v 1.40 2007/06/30 09:44:40 lucass Exp $
+# $Header: /var/cvsroot/gentoo-x86/eclass/distutils.eclass,v 1.41 2007/07/04 19:38:06 lucass Exp $
#
# Author: Jon Nelson <jnelson@gentoo.org>
# Current Maintainer: Alastair Tse <liquidx@gentoo.org>
@@ -34,6 +34,16 @@ else
python="python"
fi
+distutils_src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ # remove ez_setup stuff to prevent packages
+ # from installing setuptools on their own
+ rm -rf ez_setup*
+ echo "def use_setuptools(): pass" > ez_setup.py
+}
+
distutils_src_compile() {
${python} setup.py build "$@" || die "compilation failed"
}
@@ -113,4 +123,4 @@ distutils_python_tkinter() {
python_tkinter_exists
}
-EXPORT_FUNCTIONS src_compile src_install pkg_postinst pkg_postrm
+EXPORT_FUNCTIONS src_unpack src_compile src_install pkg_postinst pkg_postrm