summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--xfce-extra/xfce4-battery-plugin/xfce4-battery-plugin-1.0.0-r1.ebuild18
-rw-r--r--xfce-extra/xfce4-cpugraph-plugin/xfce4-cpugraph-plugin-1.0.1.ebuild20
-rw-r--r--xfce-extra/xfce4-dict/xfce4-dict-0.6.0.ebuild22
-rw-r--r--xfce-extra/xfce4-fsguard-plugin/xfce4-fsguard-plugin-1.0.0.ebuild24
-rw-r--r--xfce-extra/xfce4-notes-plugin/xfce4-notes-plugin-1.7.7.ebuild23
-rw-r--r--xfce-extra/xfce4-screenshooter/xfce4-screenshooter-1.7.9-r1.ebuild22
6 files changed, 49 insertions, 80 deletions
diff --git a/xfce-extra/xfce4-battery-plugin/xfce4-battery-plugin-1.0.0-r1.ebuild b/xfce-extra/xfce4-battery-plugin/xfce4-battery-plugin-1.0.0-r1.ebuild
index f4e8a25d106e..6714bc486888 100644
--- a/xfce-extra/xfce4-battery-plugin/xfce4-battery-plugin-1.0.0-r1.ebuild
+++ b/xfce-extra/xfce4-battery-plugin/xfce4-battery-plugin-1.0.0-r1.ebuild
@@ -1,8 +1,8 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/xfce-extra/xfce4-battery-plugin/xfce4-battery-plugin-1.0.0-r1.ebuild,v 1.4 2011/05/05 11:06:01 phajdan.jr Exp $
+# $Header: /var/cvsroot/gentoo-x86/xfce-extra/xfce4-battery-plugin/xfce4-battery-plugin-1.0.0-r1.ebuild,v 1.5 2011/05/19 20:40:06 ssuominen Exp $
-EAPI=3
+EAPI=4
inherit xfconf
DESCRIPTION="A battery monitor panel plugin for the Xfce desktop environment"
@@ -15,19 +15,15 @@ KEYWORDS="amd64 ~arm ppc x86"
IUSE="debug"
RDEPEND=">=x11-libs/gtk+-2.6:2
- >=xfce-base/xfce4-panel-4.3.90.2
- >=xfce-base/libxfce4util-4.3.90.2
- >=xfce-base/libxfcegui4-4.3.90.2"
+ >=xfce-base/xfce4-panel-4.8
+ >=xfce-base/libxfce4util-4.8
+ >=xfce-base/libxfcegui4-4.8"
DEPEND="${RDEPEND}
dev-util/pkgconfig
dev-util/intltool"
pkg_setup() {
PATCHES=( "${FILESDIR}"/${P}-sysfs.patch )
- XFCONF=(
- --disable-dependency-tracking
- $(xfconf_use_debug)
- )
-
- DOCS="AUTHORS ChangeLog NEWS README"
+ XFCONF=( $(xfconf_use_debug) )
+ DOCS=( AUTHORS ChangeLog NEWS README )
}
diff --git a/xfce-extra/xfce4-cpugraph-plugin/xfce4-cpugraph-plugin-1.0.1.ebuild b/xfce-extra/xfce4-cpugraph-plugin/xfce4-cpugraph-plugin-1.0.1.ebuild
index c3dca5a79029..59503d65fe1e 100644
--- a/xfce-extra/xfce4-cpugraph-plugin/xfce4-cpugraph-plugin-1.0.1.ebuild
+++ b/xfce-extra/xfce4-cpugraph-plugin/xfce4-cpugraph-plugin-1.0.1.ebuild
@@ -1,11 +1,11 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/xfce-extra/xfce4-cpugraph-plugin/xfce4-cpugraph-plugin-1.0.1.ebuild,v 1.7 2011/04/23 17:34:03 ssuominen Exp $
+# $Header: /var/cvsroot/gentoo-x86/xfce-extra/xfce4-cpugraph-plugin/xfce4-cpugraph-plugin-1.0.1.ebuild,v 1.8 2011/05/19 20:42:04 ssuominen Exp $
-EAPI=3
+EAPI=4
inherit xfconf
-DESCRIPTION="Xfce's system load panel plug-in"
+DESCRIPTION="A system load plug-in for the Xfce panel"
HOMEPAGE="http://goodies.xfce.org/projects/panel-plugins/xfce4-cpugraph-plugin"
SRC_URI="mirror://xfce/src/panel-plugins/${PN}/1.0/${P}.tar.bz2"
@@ -14,19 +14,15 @@ SLOT="0"
KEYWORDS="alpha amd64 arm hppa ia64 ppc ppc64 sparc x86 ~x86-fbsd ~x86-freebsd ~amd64-linux ~ia64-linux ~x86-linux"
IUSE="debug"
-RDEPEND=">=xfce-base/libxfcegui4-4.3.20
- >=xfce-base/xfce4-panel-4.3.20
+RDEPEND=">=xfce-base/libxfcegui4-4.8
+ >=xfce-base/xfce4-panel-4.8
>=x11-libs/gtk+-2.12:2"
DEPEND="${RDEPEND}
- dev-util/pkgconfig
dev-util/intltool
+ dev-util/pkgconfig
sys-devel/gettext"
pkg_setup() {
- XFCONF=(
- --disable-dependency-tracking
- $(xfconf_use_debug)
- )
-
- DOCS="AUTHORS ChangeLog NEWS README"
+ XFCONF=( $(xfconf_use_debug) )
+ DOCS=( AUTHORS ChangeLog NEWS README )
}
diff --git a/xfce-extra/xfce4-dict/xfce4-dict-0.6.0.ebuild b/xfce-extra/xfce4-dict/xfce4-dict-0.6.0.ebuild
index 1e7b9fe4a1e0..e617e7b3bda9 100644
--- a/xfce-extra/xfce4-dict/xfce4-dict-0.6.0.ebuild
+++ b/xfce-extra/xfce4-dict/xfce4-dict-0.6.0.ebuild
@@ -1,11 +1,11 @@
-# Copyright 1999-2010 Gentoo Foundation
+# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/xfce-extra/xfce4-dict/xfce4-dict-0.6.0.ebuild,v 1.8 2010/12/18 19:56:14 ssuominen Exp $
+# $Header: /var/cvsroot/gentoo-x86/xfce-extra/xfce4-dict/xfce4-dict-0.6.0.ebuild,v 1.9 2011/05/19 20:46:27 ssuominen Exp $
-EAPI=3
+EAPI=4
inherit xfconf
-DESCRIPTION="plugin and stand-alone application to query dict.org"
+DESCRIPTION="A dict.org querying application and panel plug-in for the Xfce desktop"
HOMEPAGE="http://goodies.xfce.org/projects/applications/xfce4-dict"
SRC_URI="mirror://xfce/src/apps/${PN}/0.6/${P}.tar.bz2"
@@ -16,18 +16,14 @@ IUSE="debug"
RDEPEND=">=dev-libs/glib-2.6:2
>=x11-libs/gtk+-2.6:2
- >=xfce-base/libxfcegui4-4.4
- >=xfce-base/libxfce4util-4.4
- >=xfce-base/xfce4-panel-4.4"
+ >=xfce-base/libxfcegui4-4.8
+ >=xfce-base/libxfce4util-4.8
+ >=xfce-base/xfce4-panel-4.8"
DEPEND="${RDEPEND}
dev-util/intltool
dev-util/pkgconfig"
pkg_setup() {
- XFCONF=(
- --disable-dependency-tracking
- $(xfconf_use_debug)
- )
-
- DOCS="AUTHORS ChangeLog README"
+ XFCONF=( $(xfconf_use_debug) )
+ DOCS=( AUTHORS ChangeLog README )
}
diff --git a/xfce-extra/xfce4-fsguard-plugin/xfce4-fsguard-plugin-1.0.0.ebuild b/xfce-extra/xfce4-fsguard-plugin/xfce4-fsguard-plugin-1.0.0.ebuild
index 0586dab98d36..acdbf0c93716 100644
--- a/xfce-extra/xfce4-fsguard-plugin/xfce4-fsguard-plugin-1.0.0.ebuild
+++ b/xfce-extra/xfce4-fsguard-plugin/xfce4-fsguard-plugin-1.0.0.ebuild
@@ -1,11 +1,11 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/xfce-extra/xfce4-fsguard-plugin/xfce4-fsguard-plugin-1.0.0.ebuild,v 1.8 2011/04/23 17:37:47 ssuominen Exp $
+# $Header: /var/cvsroot/gentoo-x86/xfce-extra/xfce4-fsguard-plugin/xfce4-fsguard-plugin-1.0.0.ebuild,v 1.9 2011/05/19 20:43:22 ssuominen Exp $
-EAPI=3
+EAPI=4
inherit xfconf
-DESCRIPTION="Filesystem guard panel plugin"
+DESCRIPTION="A filesystem guard plug-in for the Xfce panel"
HOMEPAGE="http://goodies.xfce.org/projects/panel-plugins/xfce4-fsguard-plugin"
SRC_URI="mirror://xfce/src/panel-plugins/${PN}/1.0/${P}.tar.bz2"
@@ -15,19 +15,13 @@ KEYWORDS="alpha amd64 arm hppa ia64 ppc ppc64 sparc x86 ~x86-fbsd ~x86-freebsd ~
IUSE=""
RDEPEND=">=x11-libs/gtk+-2.6:2
- >=xfce-base/xfce4-panel-4.4
- >=xfce-base/libxfcegui4-4.4
- >=xfce-base/libxfce4util-4.4"
+ >=xfce-base/xfce4-panel-4.8
+ >=xfce-base/libxfcegui4-4.8
+ >=xfce-base/libxfce4util-4.8"
DEPEND="${RDEPEND}
- dev-util/pkgconfig
- dev-util/intltool"
+ dev-util/intltool
+ dev-util/pkgconfig"
pkg_setup() {
- # $(xfconf_use_debug) removed because the package is still using
- # deprecated libxfcegui4 functions. restore when the package has
- # been migrated to libxfce4ui.
- XFCONF=(
- --disable-dependency-tracking
- )
- DOCS="AUTHORS ChangeLog NEWS README"
+ DOCS=( AUTHORS ChangeLog NEWS README )
}
diff --git a/xfce-extra/xfce4-notes-plugin/xfce4-notes-plugin-1.7.7.ebuild b/xfce-extra/xfce4-notes-plugin/xfce4-notes-plugin-1.7.7.ebuild
index da84d654bcb3..4140daee81fe 100644
--- a/xfce-extra/xfce4-notes-plugin/xfce4-notes-plugin-1.7.7.ebuild
+++ b/xfce-extra/xfce4-notes-plugin/xfce4-notes-plugin-1.7.7.ebuild
@@ -1,8 +1,8 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/xfce-extra/xfce4-notes-plugin/xfce4-notes-plugin-1.7.7.ebuild,v 1.10 2011/04/23 17:41:24 ssuominen Exp $
+# $Header: /var/cvsroot/gentoo-x86/xfce-extra/xfce4-notes-plugin/xfce4-notes-plugin-1.7.7.ebuild,v 1.11 2011/05/19 20:48:10 ssuominen Exp $
-EAPI=3
+EAPI=4
inherit xfconf
DESCRIPTION="Xfce4 panel sticky notes plugin"
@@ -16,23 +16,16 @@ IUSE=""
RDEPEND=">=dev-libs/glib-2.16:2
>=x11-libs/gtk+-2.18:2
- >=xfce-base/libxfcegui4-4.4
- >=xfce-base/libxfce4util-4.4
- >=xfce-base/xfce4-panel-4.4
- >=xfce-base/xfconf-4.6
+ >=xfce-base/libxfcegui4-4.8
+ >=xfce-base/libxfce4util-4.8
+ >=xfce-base/xfce4-panel-4.8
+ >=xfce-base/xfconf-4.8
dev-libs/libunique:1"
DEPEND="${RDEPEND}
dev-util/pkgconfig
dev-util/intltool"
pkg_setup() {
- # $(xfconf_use_debug) removed because the package is still using
- # deprecated libxfcegui4 functions. restore when the package has
- # been migrated to libxfce4ui.
- XFCONF=(
- --disable-dependency-tracking
- --disable-static
- )
-
- DOCS="AUTHORS ChangeLog NEWS README"
+ XFCONF=( --disable-static )
+ DOCS=( AUTHORS ChangeLog NEWS README )
}
diff --git a/xfce-extra/xfce4-screenshooter/xfce4-screenshooter-1.7.9-r1.ebuild b/xfce-extra/xfce4-screenshooter/xfce4-screenshooter-1.7.9-r1.ebuild
index 4c98fd605a9a..9ce643f6614f 100644
--- a/xfce-extra/xfce4-screenshooter/xfce4-screenshooter-1.7.9-r1.ebuild
+++ b/xfce-extra/xfce4-screenshooter/xfce4-screenshooter-1.7.9-r1.ebuild
@@ -1,8 +1,8 @@
-# Copyright 1999-2010 Gentoo Foundation
+# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/xfce-extra/xfce4-screenshooter/xfce4-screenshooter-1.7.9-r1.ebuild,v 1.11 2010/11/03 22:44:23 ssuominen Exp $
+# $Header: /var/cvsroot/gentoo-x86/xfce-extra/xfce4-screenshooter/xfce4-screenshooter-1.7.9-r1.ebuild,v 1.12 2011/05/19 20:38:52 ssuominen Exp $
-EAPI=3
+EAPI=4
EAUTORECONF=yes
inherit xfconf
@@ -18,28 +18,22 @@ IUSE="debug"
RDEPEND=">=x11-libs/gtk+-2.14:2
>=dev-libs/glib-2.16:2
>=net-libs/libsoup-2.26.0
- >=xfce-base/xfce4-panel-4.4
- >=xfce-base/libxfce4util-4.4
- >=xfce-base/libxfcegui4-4.4"
+ >=xfce-base/xfce4-panel-4.8
+ >=xfce-base/libxfce4util-4.8
+ >=xfce-base/libxfcegui4-4.8"
DEPEND="${RDEPEND}
dev-util/intltool
dev-util/pkgconfig"
pkg_setup() {
PATCHES=( "${FILESDIR}"/${P}-fix-segfault-at-startup.patch )
-
- XFCONF=(
- --disable-dependency-tracking
- $(xfconf_use_debug)
- )
-
- DOCS="AUTHORS ChangeLog NEWS README TODO"
+ XFCONF=( $(xfconf_use_debug) )
+ DOCS=( AUTHORS ChangeLog NEWS README TODO )
}
src_prepare() {
sed -i \
-e "s:\$(datadir)/xfce4/doc:\$(datadir)/doc/${PF}/html:" \
Makefile.am || die
-
xfconf_src_prepare
}