summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--app-forensics/afflib/ChangeLog7
-rw-r--r--app-forensics/afflib/afflib-3.5.2.ebuild43
-rw-r--r--app-forensics/foremost/ChangeLog7
-rw-r--r--app-forensics/foremost/foremost-1.5.6.ebuild35
-rw-r--r--app-forensics/libewf/ChangeLog7
-rw-r--r--app-forensics/libewf/libewf-20091108.ebuild45
-rw-r--r--app-forensics/magicrescue/ChangeLog7
-rw-r--r--app-forensics/magicrescue/magicrescue-1.1.8.ebuild28
-rw-r--r--app-forensics/tct/ChangeLog7
-rw-r--r--app-forensics/tct/tct-1.19.ebuild85
10 files changed, 266 insertions, 5 deletions
diff --git a/app-forensics/afflib/ChangeLog b/app-forensics/afflib/ChangeLog
index 8255e9ae95ed..2cec045e52d7 100644
--- a/app-forensics/afflib/ChangeLog
+++ b/app-forensics/afflib/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-forensics/afflib
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-forensics/afflib/ChangeLog,v 1.6 2009/08/06 14:32:11 ssuominen Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-forensics/afflib/ChangeLog,v 1.7 2009/11/08 12:01:39 patrick Exp $
+
+*afflib-3.5.2 (08 Nov 2009)
+
+ 08 Nov 2009; Patrick Lauer <patrick@gentoo.org> +afflib-3.5.2.ebuild:
+ Bump
06 Aug 2009; Samuli Suominen <ssuominen@gentoo.org> afflib-3.3.4.ebuild,
+files/afflib-3.3.4-glibc-2.10.patch:
diff --git a/app-forensics/afflib/afflib-3.5.2.ebuild b/app-forensics/afflib/afflib-3.5.2.ebuild
new file mode 100644
index 000000000000..962b0ca05ea7
--- /dev/null
+++ b/app-forensics/afflib/afflib-3.5.2.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-forensics/afflib/afflib-3.5.2.ebuild,v 1.1 2009/11/08 12:01:39 patrick Exp $
+
+inherit eutils
+
+DESCRIPTION="Library that implements the AFF image standard"
+HOMEPAGE="http://www.afflib.org/"
+SRC_URI="http://www.afflib.org/downloads/${P}.tar.gz"
+
+LICENSE="BSD-4"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~hppa ~ppc ~s390 ~sparc ~x86"
+IUSE="ewf fuse ncurses python qemu readline s3 threads"
+
+DEPEND="
+ ewf? ( app-forensics/libewf )
+ fuse? ( sys-fs/fuse )
+ ncurses? ( sys-libs/ncurses )
+ python? ( dev-lang/python )
+ readline? ( sys-libs/readline )
+ s3? ( net-misc/curl dev-libs/expat )
+ sys-libs/zlib
+ dev-libs/openssl"
+RDEPEND=${DEPEND}
+
+src_compile() {
+ econf \
+ $(use_enable fuse) \
+ $(use_enable ewf libewf) \
+ $(use_enable python) \
+ $(use_enable qemu) \
+ $(use_enable s3) \
+ $(use_enable threads threading)
+ emake || die "build failed"
+}
+
+src_install() {
+ emake install DESTDIR="${D}" || die "install failed"
+ use s3 || {
+ rm -f "${D}/usr/bin/s3"
+ }
+}
diff --git a/app-forensics/foremost/ChangeLog b/app-forensics/foremost/ChangeLog
index e3d4b488f753..7d3aa4037e0c 100644
--- a/app-forensics/foremost/ChangeLog
+++ b/app-forensics/foremost/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-forensics/foremost
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-forensics/foremost/ChangeLog,v 1.15 2009/09/13 22:33:55 patrick Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-forensics/foremost/ChangeLog,v 1.16 2009/11/08 11:56:46 patrick Exp $
+
+*foremost-1.5.6 (08 Nov 2009)
+
+ 08 Nov 2009; Patrick Lauer <patrick@gentoo.org> +foremost-1.5.6.ebuild:
+ Bump
13 Sep 2009; Patrick Lauer <patrick@gentoo.org> foremost-0.69.ebuild,
foremost-1.5.5.ebuild:
diff --git a/app-forensics/foremost/foremost-1.5.6.ebuild b/app-forensics/foremost/foremost-1.5.6.ebuild
new file mode 100644
index 000000000000..ac728a5ffdbe
--- /dev/null
+++ b/app-forensics/foremost/foremost-1.5.6.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-forensics/foremost/foremost-1.5.6.ebuild,v 1.1 2009/11/08 11:56:46 patrick Exp $
+
+inherit eutils toolchain-funcs
+
+DESCRIPTION="A console program to recover files based on their headers and footers"
+HOMEPAGE="http://foremost.sourceforge.net/"
+#SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+# starting to hate sf.net ...
+SRC_URI="http://foremost.sourceforge.net/pkg/foremost-1.5.6.tar.gz"
+
+KEYWORDS="~ppc ~x86 ~amd64"
+IUSE=""
+LICENSE="public-domain"
+SLOT="0"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}/${PN}-1.4-config-location.patch"
+}
+
+src_compile() {
+ emake RAW_FLAGS="${CFLAGS} -Wall" RAW_CC="$(tc-getCC) -DVERSION=\\\"${PV}\\\"" \
+ CONF=/etc || die "emake failed"
+}
+
+src_install() {
+ dobin foremost
+ #doman foremost.1
+ insinto /etc
+ doins foremost.conf
+ dodoc README CHANGES
+}
diff --git a/app-forensics/libewf/ChangeLog b/app-forensics/libewf/ChangeLog
index 2dd1911f5e21..bc0e32547e2c 100644
--- a/app-forensics/libewf/ChangeLog
+++ b/app-forensics/libewf/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-forensics/libewf
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-forensics/libewf/ChangeLog,v 1.5 2009/05/01 18:58:38 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-forensics/libewf/ChangeLog,v 1.6 2009/11/08 11:54:19 patrick Exp $
+
+*libewf-20091108 (08 Nov 2009)
+
+ 08 Nov 2009; Patrick Lauer <patrick@gentoo.org> +libewf-20091108.ebuild:
+ Bump
01 May 2009; Raúl Porcel <armin76@gentoo.org> libewf-20090209.ebuild:
Add ~arm/~s390 wrt #224121
diff --git a/app-forensics/libewf/libewf-20091108.ebuild b/app-forensics/libewf/libewf-20091108.ebuild
new file mode 100644
index 000000000000..5cf5d19f8de7
--- /dev/null
+++ b/app-forensics/libewf/libewf-20091108.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-forensics/libewf/libewf-20091108.ebuild,v 1.1 2009/11/08 11:54:19 patrick Exp $
+
+inherit eutils autotools
+
+MY_P=${P/libewf/libewf-beta}
+
+DESCRIPTION="Implementation of the EWF (SMART and EnCase) image format"
+HOMEPAGE="http://libewf.sourceforge.net"
+SRC_URI="mirror://sourceforge/libewf/${MY_P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~hppa ~ppc ~s390 ~sparc ~x86"
+# upstream bug #2597171, pyewf has implicit declarations
+#IUSE="debug python rawio unicode"
+IUSE="debug rawio unicode"
+
+DEPEND="
+ sys-libs/e2fsprogs-libs
+ sys-libs/zlib
+ dev-libs/openssl"
+RDEPEND="${DEPEND}"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ eautoreconf
+}
+
+src_compile() {
+ econf \
+ $(use_enable unicode wide-character-type) \
+ $(use_enable rawio raw-access) \
+ $(use_enable debug verbose-output) \
+ $(use_enable debug debug-output)
+ emake
+}
+
+src_install() {
+ emake install DESTDIR="${D}"
+ dodoc AUTHORS ChangeLog NEWS README documents/*.txt
+ doman manuals/*.1 manuals/*.3
+}
diff --git a/app-forensics/magicrescue/ChangeLog b/app-forensics/magicrescue/ChangeLog
index 3eec556d3243..ca72e90dae34 100644
--- a/app-forensics/magicrescue/ChangeLog
+++ b/app-forensics/magicrescue/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-forensics/magicrescue
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-forensics/magicrescue/ChangeLog,v 1.10 2009/09/13 22:35:05 patrick Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-forensics/magicrescue/ChangeLog,v 1.11 2009/11/08 11:49:52 patrick Exp $
+
+*magicrescue-1.1.8 (08 Nov 2009)
+
+ 08 Nov 2009; Patrick Lauer <patrick@gentoo.org> +magicrescue-1.1.8.ebuild:
+ Bump
13 Sep 2009; Patrick Lauer <patrick@gentoo.org>
magicrescue-1.1.4-r1.ebuild:
diff --git a/app-forensics/magicrescue/magicrescue-1.1.8.ebuild b/app-forensics/magicrescue/magicrescue-1.1.8.ebuild
new file mode 100644
index 000000000000..466998b97b88
--- /dev/null
+++ b/app-forensics/magicrescue/magicrescue-1.1.8.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-forensics/magicrescue/magicrescue-1.1.8.ebuild,v 1.1 2009/11/08 11:49:52 patrick Exp $
+
+inherit eutils toolchain-funcs
+
+DESCRIPTION="Find deleted files in block devices"
+HOMEPAGE="http://jbj.rapanden.dk/magicrescue/"
+SRC_URI="http://jbj.rapanden.dk/magicrescue/release/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE=""
+
+DEPEND=""
+RDEPEND=""
+
+src_compile() {
+ CC="$(tc-getCC)" ./configure --prefix=/usr || die "configure script failed"
+ emake || die "emake failed"
+}
+
+src_install() {
+ dodir /usr
+ make PREFIX="${D}/usr" install || die "make install failed"
+ mv "${D}/usr/man" "${D}/usr/share"
+}
diff --git a/app-forensics/tct/ChangeLog b/app-forensics/tct/ChangeLog
index 5abac383a8fe..449fc73bd06e 100644
--- a/app-forensics/tct/ChangeLog
+++ b/app-forensics/tct/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-forensics/tct
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-forensics/tct/ChangeLog,v 1.16 2009/04/30 17:37:17 patrick Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-forensics/tct/ChangeLog,v 1.17 2009/11/08 11:46:46 patrick Exp $
+
+*tct-1.19 (08 Nov 2009)
+
+ 08 Nov 2009; Patrick Lauer <patrick@gentoo.org> +tct-1.19.ebuild:
+ Bump
30 Apr 2009; Patrick Lauer <patrick@gentoo.org> tct-1.18-r1.ebuild:
Adding ~amd64 keyword
diff --git a/app-forensics/tct/tct-1.19.ebuild b/app-forensics/tct/tct-1.19.ebuild
new file mode 100644
index 000000000000..e4e822db3f62
--- /dev/null
+++ b/app-forensics/tct/tct-1.19.ebuild
@@ -0,0 +1,85 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-forensics/tct/tct-1.19.ebuild,v 1.1 2009/11/08 11:46:46 patrick Exp $
+
+inherit eutils toolchain-funcs
+
+DESCRIPTION="The Coroner's Toolkit - a collection of tools to aide in gathering and analyzing forensic data on a UNIX system"
+HOMEPAGE="http://www.porcupine.org/forensics/tct.html"
+SRC_URI="http://www.porcupine.org/forensics/${P}.tar.gz"
+
+LICENSE="IBM as-is"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE=""
+
+DEPEND=">=dev-lang/perl-5.0004
+ >=sys-apps/sed-4"
+RDEPEND="${DEPEND}
+ dev-perl/DateManip"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ sed -i "s:^\(CC.*= \).*:\1$(tc-getCC):" Makefile || die "sed CC failed"
+ sed -i "s:\$(OPT) \$(DEBUG):${CFLAGS}:" */*/Makefile \
+ || die "sed CFLAGS failed"
+
+ epatch "${FILESDIR}/tct-1.15-gentoo.diff"
+}
+
+src_install() {
+ # bins/libs
+ into /usr/lib/tct
+ dobin bin/* || die "bin installation failed"
+
+ exeinto /usr/lib/tct
+ doexe reconfig || die "reconfig installation failed"
+
+ insinto /usr/lib/tct/lib
+ doins lib/*.pl || die "lib installation failed"
+
+ exeinto /usr/lib/tct/extras
+ doexe extras/bdf extras/ils2mac extras/realpath extras/entropy/entropy \
+ extras/findkey/findkey || die "extras installation failed"
+
+ # config
+ insinto /etc/tct
+ doins conf/* || die "conf installation failed"
+
+ # docs
+ newdoc extras/README README.extras || die "newdoc failed"
+ dodoc docs/* Beware CHANGES INSTALL OS-NOTES README.FIRST \
+ TODO* additional-resources bibliography help-recovering-file \
+ help-when-broken-into quick-start || die "doc installation failed"
+
+ # these manual pages are provided by other packages
+ rm -f man/man1/{file,md5,icat,ils,lastcomm,timeout}.1
+ rm -f man/man5/magic.5
+ doman man/*/* || die "man installation failed"
+
+ # setup dirs/symlinks
+ keepdir /var/log/tct
+
+ dosym /etc/tct /usr/lib/tct/conf || die "dosym failed"
+
+ keepdir /var/lib/tct
+ dosym /var/lib/tct /usr/lib/tct/data || die "dosym failed"
+
+ # all binaries except the following are meant for internal use
+ local bin
+ dodir /usr/sbin
+ for bin in grave-robber lazarus mactime unrm; do
+ dosym /usr/lib/tct/bin/${bin} /usr/sbin/${bin} \
+ || die "dosym ${bin} failed"
+ done
+}
+
+pkg_postinst() {
+ elog "The authors of The Coroner's Toolkit highly recommend"
+ elog "installing sys-process/lsof for use by the toolkit."
+ elog
+ elog "Please read the README and quickstart files installed"
+ elog "in /usr/share/doc/${PF} before using The Coroner's Toolkit."
+}