summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-db/libpq/ChangeLog8
-rw-r--r--dev-db/libpq/files/digest-libpq-8.1.31
-rw-r--r--dev-db/libpq/files/libpq-8.1.3-gentoo.patch47
-rw-r--r--dev-db/libpq/libpq-8.1.3.ebuild109
-rw-r--r--dev-db/postgresql/ChangeLog10
-rw-r--r--dev-db/postgresql/files/digest-postgresql-8.1.33
-rw-r--r--dev-db/postgresql/files/postgresql-8.1.3-gentoo.patch39
-rw-r--r--dev-db/postgresql/files/postgresql-8.1.3-sh.patch34
-rw-r--r--dev-db/postgresql/files/postgresql.conf-8.1.314
-rw-r--r--dev-db/postgresql/files/postgresql.init-8.1.363
-rw-r--r--dev-db/postgresql/postgresql-8.1.3.ebuild225
11 files changed, 551 insertions, 2 deletions
diff --git a/dev-db/libpq/ChangeLog b/dev-db/libpq/ChangeLog
index 0baa5a26e9b2..2496db858a72 100644
--- a/dev-db/libpq/ChangeLog
+++ b/dev-db/libpq/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-db/libpq
# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-db/libpq/ChangeLog,v 1.43 2006/02/04 17:23:28 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-db/libpq/ChangeLog,v 1.44 2006/02/14 19:07:58 nakano Exp $
+
+*libpq-8.1.3 (14 Feb 2006)
+
+ 14 Feb 2006; Masatomo Nakano <nakano@gentoo.org>
+ +files/libpq-8.1.3-gentoo.patch, +libpq-8.1.3.ebuild:
+ Version bump.
04 Feb 2006; Aron Griffis <agriffis@gentoo.org> libpq-8.0.4.ebuild:
Mark 8.0.4 stable on alpha
diff --git a/dev-db/libpq/files/digest-libpq-8.1.3 b/dev-db/libpq/files/digest-libpq-8.1.3
new file mode 100644
index 000000000000..b5f549d62c59
--- /dev/null
+++ b/dev-db/libpq/files/digest-libpq-8.1.3
@@ -0,0 +1 @@
+MD5 4b9466e42b7951d7ec7be4455f64b13f postgresql-base-8.1.3.tar.bz2 8044411
diff --git a/dev-db/libpq/files/libpq-8.1.3-gentoo.patch b/dev-db/libpq/files/libpq-8.1.3-gentoo.patch
new file mode 100644
index 000000000000..2eff3bb4a535
--- /dev/null
+++ b/dev-db/libpq/files/libpq-8.1.3-gentoo.patch
@@ -0,0 +1,47 @@
+diff -Naru postgresql-8.1.3.org/src/Makefile.shlib postgresql-8.1.3/src/Makefile.shlib
+--- postgresql-8.1.3.org/src/Makefile.shlib 2005-11-12 20:26:09.000000000 +0000
++++ postgresql-8.1.3/src/Makefile.shlib 2005-11-12 20:28:28.000000000 +0000
+@@ -363,10 +363,10 @@
+ install-lib: install-lib-static install-lib-shared
+
+ install-lib-static: lib$(NAME).a
+- $(INSTALL_STLIB) $< $(DESTDIR)$(libdir)/lib$(NAME).a
++ $(INSTALL_STLIB) $< $(DESTDIR)$(libdir)/lib$(NAME_STATIC_LIB).a
+ ifeq ($(PORTNAME), darwin)
+ cd $(DESTDIR)$(libdir) && \
+- ranlib lib$(NAME).a
++ ranlib lib$(NAME_STATIC_LIB).a
+ endif
+
+ ifeq ($(enable_shared), yes)
+diff -Naru postgresql-8.1.3.org/src/interfaces/libpq/Makefile postgresql-8.1.3/src/interfaces/libpq/Makefile
+--- postgresql-8.1.3.org/src/interfaces/libpq/Makefile 2005-11-12 20:26:09.000000000 +0000
++++ postgresql-8.1.3/src/interfaces/libpq/Makefile 2005-11-12 20:28:02.000000000 +0000
+@@ -20,6 +20,8 @@
+ SO_MINOR_VERSION= 1
+ DLTYPE= library
+
++NAME_STATIC_LIB= pq-$(SO_MAJOR_VERSION)
++
+ override CPPFLAGS := -DFRONTEND -I$(srcdir) $(CPPFLAGS) -I$(top_builddir)/src/port
+ ifneq ($(PORTNAME), win32)
+ override CFLAGS += $(PTHREAD_CFLAGS)
+@@ -135,7 +137,7 @@
+ $(INSTALL_DATA) $(srcdir)/libpq-fe.h $(DESTDIR)$(includedir)
+ $(INSTALL_DATA) $(srcdir)/libpq-int.h $(DESTDIR)$(includedir_internal)
+ $(INSTALL_DATA) $(srcdir)/pqexpbuffer.h $(DESTDIR)$(includedir_internal)
+- $(INSTALL_DATA) $(srcdir)/pg_service.conf.sample $(DESTDIR)$(datadir)/pg_service.conf.sample
++ $(INSTALL_DATA) $(srcdir)/pg_service.conf.sample $(DESTDIR)$(datadir)/pg_service-${SO_MAJOR_VERSION}.conf.sample
+
+ installdirs:
+ $(mkinstalldirs) $(DESTDIR)$(libdir) $(DESTDIR)$(includedir) $(DESTDIR)$(includedir_internal)
+diff -Naru postgresql-8.1.3.org/src/interfaces/libpq/nls.mk postgresql-8.1.3/src/interfaces/libpq/nls.mk
+--- postgresql-8.1.3.org/src/interfaces/libpq/nls.mk 2005-11-12 20:26:09.000000000 +0000
++++ postgresql-8.1.3/src/interfaces/libpq/nls.mk 2005-11-12 20:28:02.000000000 +0000
+@@ -1,5 +1,5 @@
+ # $PostgreSQL: pgsql/src/interfaces/libpq/nls.mk,v 1.20 2005/01/14 08:57:06 petere Exp $
+-CATALOG_NAME := libpq
++CATALOG_NAME := libpq-4
+ AVAIL_LANGUAGES := af cs de es fr hr it ko nb pl pt_BR ru sk sl sv tr zh_CN zh_TW
+ GETTEXT_FILES := fe-auth.c fe-connect.c fe-exec.c fe-lobj.c fe-misc.c fe-protocol2.c fe-protocol3.c fe-secure.c
+ GETTEXT_TRIGGERS:= libpq_gettext pqInternalNotice:2
diff --git a/dev-db/libpq/libpq-8.1.3.ebuild b/dev-db/libpq/libpq-8.1.3.ebuild
new file mode 100644
index 000000000000..c2c7242acc1c
--- /dev/null
+++ b/dev-db/libpq/libpq-8.1.3.ebuild
@@ -0,0 +1,109 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-db/libpq/libpq-8.1.3.ebuild,v 1.1 2006/02/14 19:07:58 nakano Exp $
+
+inherit eutils gnuconfig flag-o-matic toolchain-funcs
+
+DESCRIPTION="Libraries of postgresql"
+HOMEPAGE="http://www.postgresql.org/"
+MY_P="postgresql-${PV}"
+SRC_URI="mirror://postgresql/source/v${PV}/postgresql-base-${PV}.tar.bz2"
+
+LICENSE="POSTGRESQL"
+SLOT="4"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
+IUSE="ssl nls pam readline zlib kerberos"
+
+S=${WORKDIR}/${MY_P}
+DEPEND="virtual/libc
+ sys-devel/autoconf
+ >=sys-libs/ncurses-5.2
+ >=sys-devel/bison-1.875
+ zlib? ( >=sys-libs/zlib-1.1.3 )
+ readline? ( >=sys-libs/readline-4.1 )
+ ssl? ( >=dev-libs/openssl-0.9.6-r1 )
+ nls? ( sys-devel/gettext )
+ kerberos? ( virtual/krb5 )"
+RDEPEND="virtual/libc
+ zlib? ( >=sys-libs/zlib-1.1.3 )
+ ssl? ( >=dev-libs/openssl-0.9.6-r1 )
+ kerberos? ( virtual/krb5 )"
+
+MAKEOPTS="${MAKEOPTS} -j1"
+
+pkg_preinst() {
+ # removing wrong symlink which is created by previous ebuild.
+ if [ -L ${ROOT}/usr/include/libpq ]; then
+ rm ${ROOT}/usr/include/libpq
+ fi
+}
+
+src_unpack() {
+ unpack ${A}
+ epatch ${FILESDIR}/${P}-gentoo.patch
+}
+
+src_compile() {
+ filter-flags -ffast-math -feliminate-dwarf2-dups
+
+ local myconf
+ use ssl && myconf="$myconf --with-openssl"
+ use nls && myconf="$myconf --enable-nls"
+ use pam && myconf="$myconf --with-pam"
+ use readline || myconf="$myconf --without-readline"
+ use zlib || myconf="$myconf --without-zlib"
+ use kerberos && myconf="$myconf --with-krb5"
+
+ # these are the only working CFLAGS I could get on ppc, so locking them
+ # down, anything more aggressive fails (i.e. -mcpu or -Ox)
+ # Gerk - Nov 26, 2002
+ use ppc && CFLAGS="-pipe -fsigned-char"
+
+ # Detect mips systems properly
+ gnuconfig_update
+
+ ./configure --prefix=/usr \
+ --include=/usr/include/postgresql/libpq-${SLOT} \
+ --mandir=/usr/share/man \
+ --host=${CHOST} \
+ --with-docdir=/usr/share/doc/${PF} \
+ --libdir=/usr/$(get_libdir) \
+ --enable-depend \
+ $myconf || die
+
+ cd ${S}/src/interfaces/libpq
+ emake LD="$(tc-getLD) $(get_abi_LDFLAGS)" || die
+}
+
+src_install() {
+ cd ${S}/src/interfaces/libpq
+ make DESTDIR=${D} LIBDIR=${D}/usr/$(get_libdir) install || die
+
+ cd ${S}/src/include
+ make DESTDIR=${D} install || die
+
+ cd ${S}
+ dodoc README HISTORY COPYRIGHT INSTALL
+
+ dosym libpq-${SLOT}.a /usr/$(get_libdir)/libpq.a
+
+ for f in ${D}/usr/include/postgresql/libpq-${SLOT}/*.h
+ do
+ dosym postgresql/libpq-${SLOT}/$(basename $f) /usr/include/
+ done
+
+ dodir /usr/include/libpq
+ for f in ${D}/usr/include/postgresql/libpq-${SLOT}/libpq/*.h
+ do
+ dosym ../postgresql/libpq-${SLOT}/libpq/$(basename $f) /usr/include/libpq/
+ done
+
+ cd ${D}/usr/include/postgresql/libpq-${SLOT}
+ for f in $(find * -name '*.h' -print) ; do
+ destdir=$(dirname $f)
+ if [ ! -d "${D}/usr/include/postgresql/${destdir}" ]; then
+ dodir /usr/include/postgresql/${destdir}
+ fi
+ dosym /usr/include/postgresql/libpq-${SLOT}/${f} /usr/include/postgresql/${destdir}/
+ done
+}
diff --git a/dev-db/postgresql/ChangeLog b/dev-db/postgresql/ChangeLog
index 1c8e3ccd214b..84eeb3019845 100644
--- a/dev-db/postgresql/ChangeLog
+++ b/dev-db/postgresql/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for dev-db/postgresql
# Copyright 2002-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-db/postgresql/ChangeLog,v 1.257 2006/02/04 17:43:27 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-db/postgresql/ChangeLog,v 1.258 2006/02/14 19:12:20 nakano Exp $
+
+*postgresql-8.1.3 (14 Feb 2006)
+
+ 14 Feb 2006; Masatomo Nakano <nakano@gentoo.org>
+ +files/postgresql.conf-8.1.3, +files/postgresql.init-8.1.3,
+ +files/postgresql-8.1.3-gentoo.patch, +files/postgresql-8.1.3-sh.patch,
+ +postgresql-8.1.3.ebuild:
+ Version bump.
04 Feb 2006; Aron Griffis <agriffis@gentoo.org> postgresql-8.0.4.ebuild:
Mark 8.0.4 stable on alpha
diff --git a/dev-db/postgresql/files/digest-postgresql-8.1.3 b/dev-db/postgresql/files/digest-postgresql-8.1.3
new file mode 100644
index 000000000000..6437c3b9167d
--- /dev/null
+++ b/dev-db/postgresql/files/digest-postgresql-8.1.3
@@ -0,0 +1,3 @@
+MD5 4b9466e42b7951d7ec7be4455f64b13f postgresql-base-8.1.3.tar.bz2 8044411
+MD5 9ca0b7f6b4c2edcd51b9995d4e3a8a42 postgresql-docs-8.1.3.tar.bz2 2467558
+MD5 ad1dd1d66c9c608180418375e36aafcb postgresql-opt-8.1.3.tar.bz2 144608
diff --git a/dev-db/postgresql/files/postgresql-8.1.3-gentoo.patch b/dev-db/postgresql/files/postgresql-8.1.3-gentoo.patch
new file mode 100644
index 000000000000..942617ae0d08
--- /dev/null
+++ b/dev-db/postgresql/files/postgresql-8.1.3-gentoo.patch
@@ -0,0 +1,39 @@
+diff -Naru postgresql-8.1.3.org/src/interfaces/Makefile postgresql-8.1.3/src/interfaces/Makefile
+--- postgresql-8.1.3.org/src/interfaces/Makefile 2004-04-20 01:33:51.000000000 +0100
++++ postgresql-8.1.3/src/interfaces/Makefile 2005-05-09 21:59:15.000000000 +0100
+@@ -12,7 +12,7 @@
+ top_builddir = ../..
+ include $(top_builddir)/src/Makefile.global
+
+-DIRS := libpq ecpg
++DIRS := ecpg
+
+ ALLDIRS := $(DIRS)
+
+diff -Naru postgresql-8.1.3.org/src/Makefile postgresql-8.1.3/src/Makefile
+--- postgresql-8.1.3.org/src/Makefile 2005-01-13 18:23:21.000000000 +0000
++++ postgresql-8.1.3/src/Makefile 2005-05-09 21:59:54.000000000 +0100
+@@ -18,7 +18,6 @@
+ $(MAKE) -C timezone $@
+ $(MAKE) -C backend $@
+ $(MAKE) -C backend/utils/mb/conversion_procs $@
+- $(MAKE) -C include $@
+ $(MAKE) -C interfaces $@
+ $(MAKE) -C bin $@
+ $(MAKE) -C pl $@
+@@ -47,7 +46,6 @@
+ $(MAKE) -C port $@
+ $(MAKE) -C timezone $@
+ $(MAKE) -C backend $@
+- $(MAKE) -C include $@
+ $(MAKE) -C interfaces $@
+ $(MAKE) -C bin $@
+ $(MAKE) -C pl $@
+@@ -61,7 +59,6 @@
+ -$(MAKE) -C port $@
+ -$(MAKE) -C timezone $@
+ -$(MAKE) -C backend $@
+- -$(MAKE) -C include $@
+ -$(MAKE) -C interfaces $@
+ -$(MAKE) -C bin $@
+ -$(MAKE) -C pl $@
diff --git a/dev-db/postgresql/files/postgresql-8.1.3-sh.patch b/dev-db/postgresql/files/postgresql-8.1.3-sh.patch
new file mode 100644
index 000000000000..fc59d52af0e8
--- /dev/null
+++ b/dev-db/postgresql/files/postgresql-8.1.3-sh.patch
@@ -0,0 +1,34 @@
+--- src/include/storage/s_lock.h~ 2005-01-01 07:03:42.000000000 +0900
++++ src/include/storage/s_lock.h 2005-08-17 23:09:19.000000000 +0900
+@@ -239,6 +239,31 @@
+ #endif /* __s390__ || __s390x__ */
+
+
++#if defined(__sh__)
++#define HAS_TEST_AND_SET
++
++typedef unsigned char slock_t;
++
++#define TAS(lock) tas(lock)
++
++static __inline__ int
++tas(volatile slock_t *lock)
++{
++ register int _res = 1;
++
++ __asm__ __volatile__(
++ "tas.b @%1\n\t"
++ "movt %0\n\t"
++ "xor #1,%0"
++: "=z"(_res)
++: "r"(lock)
++: "t","memory");
++ return _res;
++}
++
++#endif /* __sh__ */
++
++
+ #if defined(__sparc__)
+ #define HAS_TEST_AND_SET
+
diff --git a/dev-db/postgresql/files/postgresql.conf-8.1.3 b/dev-db/postgresql/files/postgresql.conf-8.1.3
new file mode 100644
index 000000000000..e8dab3e4c827
--- /dev/null
+++ b/dev-db/postgresql/files/postgresql.conf-8.1.3
@@ -0,0 +1,14 @@
+# PostgreSQL's Database Directory
+PGDATA=/var/lib/postgresql/data
+
+# Logfile path: (NOTE: This must be uid/gid owned by the value of $PGUSER!)
+PGLOG=/var/lib/postgresql/data/postgresql.log
+
+# Run the PostgreSQL user as:
+PGUSER=postgres
+
+# Extra options to run postmaster with.
+# If you want to enable TCP/IP for PostgreSQL, add -i to the following:
+# PGOPTS="-N 1024 -B 2048 -i"
+PGOPTS=""
+
diff --git a/dev-db/postgresql/files/postgresql.init-8.1.3 b/dev-db/postgresql/files/postgresql.init-8.1.3
new file mode 100644
index 000000000000..4ca1baaefada
--- /dev/null
+++ b/dev-db/postgresql/files/postgresql.init-8.1.3
@@ -0,0 +1,63 @@
+#!/sbin/runscript
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-db/postgresql/files/postgresql.init-8.1.3,v 1.1 2006/02/14 19:12:20 nakano Exp $
+
+opts="${opts} reload"
+
+depend() {
+ use net
+}
+
+checkconfig() {
+ if [ ! -d $PGDATA ]; then
+ eerror "directory not found: $PGDATA"
+ eerror "You should create PGDATA directory first."
+ return 1
+ fi
+}
+
+start() {
+ checkconfig || return 1
+
+ ebegin "Starting PostgreSQL"
+ if [ -f $PGDATA/postmaster.pid ]; then
+ rm $PGDATA/postmaster.pid
+ fi
+ su - $PGUSER -c "/usr/bin/pg_ctl start -D '$PGDATA' -s -l '$PGLOG' -o '$PGOPTS'"
+
+ while :
+ do
+ cnt=$(($cnt + 1))
+ if [ -f "$PGDATA/postmaster.pid" ]; then
+ ret=0
+ break
+ fi
+
+ if [ $cnt -eq 30 ]; then
+ eerror "Please see log file: $PGLOG"
+ ret=1
+ break
+ fi
+ sleep 1
+ done
+ eend $ret
+}
+
+stop() {
+ ebegin "Stopping PostgreSQL"
+ su - $PGUSER -c "/usr/bin/pg_ctl stop -D '$PGDATA' -s -m fast"
+ eend $?
+}
+
+svc_restart() {
+ ebegin "Restarting PostgreSQL"
+ su - $PGUSER -c "/usr/bin/pg_ctl restart -D '$PGDATA' -s -m fast -l '$PGLOG' -o '$PGOPTS'"
+ eend $?
+}
+
+reload() {
+ ebegin "Reloading PostgreSQL configuration"
+ su - $PGUSER -c "/usr/bin/pg_ctl reload -D '$PGDATA' -s"
+ eend $?
+}
diff --git a/dev-db/postgresql/postgresql-8.1.3.ebuild b/dev-db/postgresql/postgresql-8.1.3.ebuild
new file mode 100644
index 000000000000..0e0068382c3d
--- /dev/null
+++ b/dev-db/postgresql/postgresql-8.1.3.ebuild
@@ -0,0 +1,225 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-db/postgresql/postgresql-8.1.3.ebuild,v 1.1 2006/02/14 19:12:20 nakano Exp $
+
+inherit eutils gnuconfig flag-o-matic multilib toolchain-funcs
+
+DESCRIPTION="sophisticated Object-Relational DBMS."
+HOMEPAGE="http://www.postgresql.org/"
+#P_HIERPG="hier-Pg8.0.1-0.5.4"
+SRC_URI="mirror://postgresql/source/v${PV}/${PN}-base-${PV}.tar.bz2
+ mirror://postgresql/source/v${PV}/${PN}-opt-${PV}.tar.bz2
+ doc? ( mirror://postgresql/source/v${PV}/${PN}-docs-${PV}.tar.bz2 )"
+# pg-hier? ( http://gppl.moonbone.ru/${P_HIERPG}.diff.gz )"
+
+LICENSE="POSTGRESQL"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
+#IUSE="ssl nls python tcltk perl libg++ pam readline xml2 zlib doc selinux kerberos pg-intdatetime pg-hier"
+IUSE="ssl nls python tcltk perl libg++ pam readline xml2 zlib doc selinux kerberos pg-intdatetime"
+
+DEPEND="virtual/libc
+ =dev-db/libpq-8.1.3*
+ sys-devel/autoconf
+ >=sys-libs/ncurses-5.2
+ >=sys-devel/bison-1.875
+ zlib? ( >=sys-libs/zlib-1.1.3 )
+ readline? ( >=sys-libs/readline-4.1 )
+ tcltk? ( >=dev-lang/tcl-8 >=dev-lang/tk-8.3.3-r1 )
+ perl? ( >=dev-lang/perl-5.6.1-r2 )
+ python? ( >=dev-lang/python-2.2 dev-python/egenix-mx-base )
+ ssl? ( >=dev-libs/openssl-0.9.6-r1 )
+ xml2? ( dev-libs/libxml2 dev-libs/libxslt dev-util/pkgconfig )
+ nls? ( sys-devel/gettext )
+ kerberos? ( virtual/krb5 )"
+RDEPEND="virtual/libc
+ =dev-db/libpq-8.1.3*
+ zlib? ( >=sys-libs/zlib-1.1.3 )
+ tcltk? ( >=dev-lang/tcl-8 )
+ perl? ( >=dev-lang/perl-5.6.1-r2 )
+ python? ( >=dev-lang/python-2.2 )
+ selinux? ( sec-policy/selinux-postgresql )
+ ssl? ( >=dev-libs/openssl-0.9.6-r1 )
+ xml2? ( dev-libs/libxml2 dev-libs/libxslt )
+ kerberos? ( virtual/krb5 )"
+
+PG_DIR="/var/lib/postgresql"
+
+pkg_setup() {
+ if [ -f ${PG_DIR}/data/PG_VERSION ] ; then
+ PG_MAJOR=`cat ${PG_DIR}/data/PG_VERSION | cut -f1 -d.`
+ PG_MINOR=`cat ${PG_DIR}/data/PG_VERSION | cut -f2 -d.`
+ if [ ${PG_MAJOR} -lt 8 ] || [ ${PG_MAJOR} -eq 8 -a ${PG_MINOR} -lt 1 ] ; then
+ eerror "Postgres ${PV} cannot upgrade your existing databases, you must"
+ eerror "use pg_dump to export your existing databases to a file, and then"
+ eerror "pg_restore to import them when you have upgraded completely."
+ eerror "You must remove your entire database directory to continue."
+ eerror "(database directory = ${PG_DIR})."
+ exit 1
+ fi
+ fi
+ enewgroup postgres 70 \
+ || die "problem adding group postgres"
+ enewuser postgres 70 /bin/bash /var/lib/postgresql postgres \
+ || die "problem adding user postgres"
+}
+
+src_unpack() {
+ unpack ${A} || die
+ cd ${S}
+# use pg-hier && epatch ${WORKDIR}/${P_HIERPG}.diff
+ epatch ${FILESDIR}/${P}-gentoo.patch
+ epatch ${FILESDIR}/${P}-sh.patch
+}
+
+src_compile() {
+ filter-flags -ffast-math -feliminate-dwarf2-dups
+
+ local myconf
+ use tcltk && myconf="--with-tcl"
+ use python && myconf="$myconf --with-python"
+ use perl && myconf="$myconf --with-perl"
+ use ssl && myconf="$myconf --with-openssl"
+ use nls && myconf="$myconf --enable-nls"
+ use libg++ && myconf="$myconf --with-CXX"
+ use pam && myconf="$myconf --with-pam"
+ use readline || myconf="$myconf --without-readline"
+ use zlib || myconf="$myconf --without-zlib"
+ use kerberos && myconf="$myconf --with-krb5"
+ use pg-intdatetime && myconf="$myconf --enable-integer-datetimes"
+
+ # these are the only working CFLAGS I could get on ppc, so locking them
+ # down, anything more aggressive fails (i.e. -mcpu or -Ox)
+ # Gerk - Nov 26, 2002
+ use ppc && CFLAGS="-pipe -fsigned-char"
+
+ # Detect mips systems properly
+ gnuconfig_update
+
+ ./configure --prefix=/usr \
+ --mandir=/usr/share/man \
+ --host=${CHOST} \
+ --with-docdir=/usr/share/doc/${PF} \
+ --libdir=/usr/$(get_libdir) \
+ --enable-depend \
+ $myconf || die
+
+ make LD="$(tc-getLD) $(get_abi_LDFLAGS)" || die
+ cd contrib
+ make LD="$(tc-getLD) $(get_abi_LDFLAGS)" || die
+ if use xml2; then
+ cd xml2
+ make LD="$(tc-getLD) $(get_abi_LDFLAGS)" || die
+ fi
+}
+
+src_install() {
+ if use perl; then
+ mv ${S}/src/pl/plperl/Makefile ${S}/src/pl/plperl/Makefile_orig
+ sed -e "s:(INST_DYNAMIC) /usr/lib:(INST_DYNAMIC) ${D}/usr/lib:" \
+ ${S}/src/pl/plperl/Makefile_orig > ${S}/src/pl/plperl/Makefile
+ mv ${S}/src/pl/plperl/GNUmakefile ${S}/src/pl/plperl/GNUmakefile_orig
+ sed -e "s:\$(DESTDIR)\$(plperl_installdir):\$(plperl_installdir):" \
+ ${S}/src/pl/plperl/GNUmakefile_orig > ${S}/src/pl/plperl/GNUmakefile
+ fi
+
+ make DESTDIR=${D} LIBDIR=${D}/usr/lib install || die
+# make DESTDIR=${D} install-all-headers || die
+ cd ${S}/contrib
+ make DESTDIR=${D} LIBDIR=${D}/usr/lib install || die
+ if use xml2; then
+ cd ${S}/contrib/xml2
+ make DESTDIR=${D} LIBDIR=${D}/usr/lib install || die
+ fi
+ cd ${S}
+ dodoc README HISTORY COPYRIGHT INSTALL
+ dodoc contrib/adddepend/*
+
+ exeinto /usr/bin
+
+ cd ${S}/doc
+ dodoc FAQ* README.* TODO bug.template
+ if use doc; then
+ cd ${S}/doc
+ docinto FAQ_html
+ dodoc src/FAQ/*
+ docinto sgml
+ dodoc src/sgml/*.{sgml,dsl}
+ docinto sgml/ref
+ dodoc src/sgml/ref/*.sgml
+ docinto TODO.detail
+ dodoc TODO.detail/*
+ fi
+
+ cd ${S}
+ exeinto /etc/init.d/
+ newexe ${FILESDIR}/postgresql.init-${PV} postgresql || die
+
+ insinto /etc/conf.d/
+ newins ${FILESDIR}/postgresql.conf-${PV} postgresql || die
+
+ rm ${D}/usr/include/postgres_ext.h
+}
+
+pkg_postinst() {
+ einfo "Make sure the postgres user in /etc/passwd has an account setup with /bin/bash as the shell"
+
+ einfo ""
+ einfo "Execute the following command when you want to setup the initial database environment."
+ einfo "emerge --config =${PF}"
+ einfo ""
+ einfo "autovacuum function, which was in contrib, has moved to main PostgreSQL function from 8.1."
+ einfo "You can enable it in postgresql.conf."
+ einfo ""
+}
+
+pkg_config() {
+ einfo "Creating the data directory ..."
+ mkdir -p ${PG_DIR}/data
+ chown -Rf postgres:postgres ${PG_DIR}
+ chmod 700 ${PG_DIR}/data
+
+ einfo "Initializing the database ..."
+ if [ -f ${PG_DIR}/data/PG_VERSION ] ; then
+ eerror "Postgres ${PV} cannot upgrade your existing databases."
+ eerror "You must remove your entire database directory to continue."
+ eerror "(database directory = ${PG_DIR})."
+ exit 1
+ else
+ local SEM=`sysctl -n kernel.sem | cut -f-3`
+ local SEMMNI=`sysctl -n kernel.sem | cut -f4`
+ local SEMMNI_MIN=`expr \( ${MAX_CONNECTIONS} + 15 \) / 16`
+ local SHMMAX=`sysctl -n kernel.shmmax`
+ local SHMMAX_MIN=`expr 250000 + 8200 \* 1000 + 14200 \* 100`
+
+ if [ ${SEMMNI} -lt ${SEMMNI_MIN} ]; then
+ eerror "The current value of SEMMNI is too low"
+ eerror "for postgresql to run ${MAX_CONNECTIONS} connections"
+ eerror "Temporary setting this value to ${SEMMNI_MIN} while creating the initial database."
+ echo ${SEM} ${SEMMNI_MIN} > /proc/sys/kernel/sem
+ fi
+ su postgres -c "/usr/bin/initdb --pgdata ${PG_DIR}/data"
+
+ if [ ! `sysctl -n kernel.sem | cut -f4` -eq ${SEMMNI} ] ; then
+ echo ${SEM} ${SEMMNI} > /proc/sys/kernel/sem
+ ewarn "Restoring the SEMMNI value to the previous value"
+ ewarn "Please edit the last value of kernel.sem in /etc/sysctl.conf"
+ ewarn "and set it to at least ${SEMMNI_MIN}"
+ ewarn ""
+ ewarn " kernel.sem = ${SEM} ${SEMMNI_MIN}"
+ ewarn ""
+ fi
+
+ if [ ${SHMMAX} -lt ${SHMMAX_MIN} ]; then
+ eerror "The current value of SHMMAX is too low for postgresql to run."
+ eerror "Please edit /etc/sysctl.conf and set this value to at least ${SHMMAX_MIN}."
+ eerror ""
+ eerror " kernel.shmmax = ${SHMMAX_MIN}"
+ eerror ""
+
+ fi
+ einfo ""
+ einfo "You can use /etc/init.d/postgresql script to run PostgreSQL instead of pg_ctl."
+ einfo ""
+ fi
+}