summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--media-plugins/xmms-extra/xmms-extra-0.1.ebuild10
-rw-r--r--media-plugins/xmms-fmradio/xmms-fmradio-1.5.ebuild6
-rw-r--r--media-plugins/xmms-shell/xmms-shell-0.99.0-r1.ebuild25
3 files changed, 15 insertions, 26 deletions
diff --git a/media-plugins/xmms-extra/xmms-extra-0.1.ebuild b/media-plugins/xmms-extra/xmms-extra-0.1.ebuild
index 0e53bf87b829..a74cc897dc3c 100644
--- a/media-plugins/xmms-extra/xmms-extra-0.1.ebuild
+++ b/media-plugins/xmms-extra/xmms-extra-0.1.ebuild
@@ -1,19 +1,19 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-plugins/xmms-extra/xmms-extra-0.1.ebuild,v 1.1 2003/04/18 22:10:28 vladimir Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-plugins/xmms-extra/xmms-extra-0.1.ebuild,v 1.2 2003/04/25 14:13:54 vapier Exp $
-DESCRIPTION="xmms-extra is a collection of plugins to xmms"
+DESCRIPTION="extra collection of plugins for xmms"
HOMEPAGE="http://www.xmms.org/files/plugins/xmms-extra/"
SRC_URI="http://www.xmms.org/files/plugins/xmms-extra/${P}.tar.gz"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~x86"
-IUSE=""
-RDEPEND=">=xmms-1.2.7"
+
+RDEPEND=">=media-sound/xmms-1.2.7"
src_compile() {
- econf
+ econf || die
emake || die
}
diff --git a/media-plugins/xmms-fmradio/xmms-fmradio-1.5.ebuild b/media-plugins/xmms-fmradio/xmms-fmradio-1.5.ebuild
index 299bd7676fa4..a1496fe58b8b 100644
--- a/media-plugins/xmms-fmradio/xmms-fmradio-1.5.ebuild
+++ b/media-plugins/xmms-fmradio/xmms-fmradio-1.5.ebuild
@@ -1,12 +1,10 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-plugins/xmms-fmradio/xmms-fmradio-1.5.ebuild,v 1.1 2003/02/12 13:00:06 seemant Exp $
-
-IUSE=""
+# $Header: /var/cvsroot/gentoo-x86/media-plugins/xmms-fmradio/xmms-fmradio-1.5.ebuild,v 1.2 2003/04/25 14:14:13 vapier Exp $
MY_P=${P/fmr/FMR}
S=${WORKDIR}/${MY_P}
-DESCRIPTION="XMMS-FMRadio is a radio tuner Plugin for XMMS"
+DESCRIPTION="radio tuner Plugin for XMMS"
HOMEPAGE="http://silicone.free.fr/xmms-FMRadio/"
SRC_URI="http://silicone.free.fr/xmms-FMRadio/${MY_P}.tgz"
diff --git a/media-plugins/xmms-shell/xmms-shell-0.99.0-r1.ebuild b/media-plugins/xmms-shell/xmms-shell-0.99.0-r1.ebuild
index 0e3224ff20f8..6ec107618127 100644
--- a/media-plugins/xmms-shell/xmms-shell-0.99.0-r1.ebuild
+++ b/media-plugins/xmms-shell/xmms-shell-0.99.0-r1.ebuild
@@ -1,20 +1,18 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-plugins/xmms-shell/xmms-shell-0.99.0-r1.ebuild,v 1.5 2003/02/13 13:04:28 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-plugins/xmms-shell/xmms-shell-0.99.0-r1.ebuild,v 1.6 2003/04/25 14:15:10 vapier Exp $
-IUSE="readline"
-
-
-S=${WORKDIR}/${P}
-DESCRIPTION="XMMS-Shell is a simple utility to control XMMS externally."
+DESCRIPTION="simple utility to control XMMS externally"
SRC_URI="http://download.sourceforge.net/xmms-shell/${P}.tar.gz"
HOMEPAGE="http://www.loganh.com/xmms-shell/"
-DEPEND=">=media-sound/xmms-1.2.7
- readline? ( >=sys-libs/readline-4.1 )"
SLOT="0"
LICENSE="GPL-2"
KEYWORDS="x86 ppc"
+IUSE="readline"
+
+DEPEND=">=media-sound/xmms-1.2.7
+ readline? ( >=sys-libs/readline-4.1 )"
src_unpack() {
unpack ${A}
@@ -23,18 +21,11 @@ src_unpack() {
}
src_compile() {
- local myconf
-
- use readline \
- && myconf="${myconf} --with-readline" \
- || myconf="${myconf} --without-readline"
-
- econf ${myconf} || die "./configure failed"
+ econf `use_with readline` || die
emake || die
}
-src_install () {
+src_install() {
make DESTDIR=${D} install || die
-
dodoc AUTHORS README
}