summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--sys-apps/acl/ChangeLog7
-rw-r--r--sys-apps/acl/acl-2.2.13-r2.ebuild10
-rw-r--r--sys-apps/attr/ChangeLog5
-rw-r--r--sys-apps/attr/attr-2.4.7-r1.ebuild8
4 files changed, 15 insertions, 15 deletions
diff --git a/sys-apps/acl/ChangeLog b/sys-apps/acl/ChangeLog
index 6297a3493b6e..7ec9d2c63019 100644
--- a/sys-apps/acl/ChangeLog
+++ b/sys-apps/acl/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for sys-apps/acl
-# Copyright 2002-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/acl/ChangeLog,v 1.21 2003/12/04 22:18:16 agriffis Exp $
+# Copyright 2002-2004 Gentoo Technologies, Inc.; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/acl/ChangeLog,v 1.22 2004/02/21 23:26:09 weeve Exp $
+
+ 21 Feb 2004; Jason Wever <weeve@gentoo.org> acl-2.2.13-r2.ebuild:
+ Changed sparc fix so now it's an actual fix rather than a workaround.
04 Dec 2003; <agriffis@gentoo.org> acl-2.2.13-r2.ebuild:
Stable on alpha, sparc, ia64 to support vim-6.2-r5
diff --git a/sys-apps/acl/acl-2.2.13-r2.ebuild b/sys-apps/acl/acl-2.2.13-r2.ebuild
index 090d006bfc78..4b9bdff638e8 100644
--- a/sys-apps/acl/acl-2.2.13-r2.ebuild
+++ b/sys-apps/acl/acl-2.2.13-r2.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/acl/acl-2.2.13-r2.ebuild,v 1.3 2003/12/04 22:18:16 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/acl/acl-2.2.13-r2.ebuild,v 1.4 2004/02/21 23:26:09 weeve Exp $
S=${WORKDIR}/${P}
DESCRIPTION="Access control list utilities, libraries and headers"
@@ -19,6 +19,7 @@ DEPEND="${RDEPEND} sys-devel/autoconf"
src_compile() {
OPTIMIZER="${CFLAGS}"
DEBUG=-DNDEBUG
+ [ `use sparc` ] && unset PLATFORM
autoconf || die
@@ -35,11 +36,6 @@ src_compile() {
sed -e 's:^PKG_\(.*\)_DIR = \(.*\)$:PKG_\1_DIR = ${DESTDIR}\2:' \
-e 's:-O1::' -i include/builddefs || die "failed to update builddefs"
- if [ "${ARCH}" = "sparc" ]; then
- sed -i -e 's/sparc.*$/linux/' include/builddefs || \
- die "failed to update builddefs for sparc"
- fi
-
emake || die
}
diff --git a/sys-apps/attr/ChangeLog b/sys-apps/attr/ChangeLog
index 7dec2ce453dd..73c15c670137 100644
--- a/sys-apps/attr/ChangeLog
+++ b/sys-apps/attr/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for sys-apps/attr
# Copyright 2002-2004 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/attr/ChangeLog,v 1.25 2004/01/10 18:47:11 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/attr/ChangeLog,v 1.26 2004/02/21 23:30:05 weeve Exp $
+
+ 21 Feb 2004; Jason Wever <weeve@gentoo.org> attr-2.4.7-r1.ebuild:
+ Changed sparc fix so now it's an actual fix rather than a workaround.
10 Jan 2004; Aron Griffis <agriffis@gentoo.org> attr-2.4.7-r1.ebuild:
stable on alpha
diff --git a/sys-apps/attr/attr-2.4.7-r1.ebuild b/sys-apps/attr/attr-2.4.7-r1.ebuild
index 0d057eff447a..1978a538b38e 100644
--- a/sys-apps/attr/attr-2.4.7-r1.ebuild
+++ b/sys-apps/attr/attr-2.4.7-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/attr/attr-2.4.7-r1.ebuild,v 1.11 2004/01/25 00:29:08 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/attr/attr-2.4.7-r1.ebuild,v 1.12 2004/02/21 23:30:05 weeve Exp $
inherit eutils
@@ -46,17 +46,15 @@ src_compile() {
fi
local myconf="`use_enable nls gettext`"
+ [ `use sparc` ] && unset PLATFORM
econf ${myconf} || die
+
sed -i \
-e 's:^PKG_\(.*\)_DIR = \(.*\)$:PKG_\1_DIR = ${DESTDIR}\2:' \
-e 's:-O1::' -e 's:../$(INSTALL) -S \(.*\) $(PKG_.*_DIR)/\(.*$\)::' \
include/builddefs
- if [ "${ARCH}" = "sparc" ]; then
- sed -i -e 's/sparc.*$/linux/' include/builddefs
- fi
-
make || die
}