summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-admin/system-config-printer-gnome/files/system-config-printer-gnome-1.2.3-split.patch')
-rw-r--r--app-admin/system-config-printer-gnome/files/system-config-printer-gnome-1.2.3-split.patch143
1 files changed, 143 insertions, 0 deletions
diff --git a/app-admin/system-config-printer-gnome/files/system-config-printer-gnome-1.2.3-split.patch b/app-admin/system-config-printer-gnome/files/system-config-printer-gnome-1.2.3-split.patch
new file mode 100644
index 000000000000..0bc5dbc6cbc7
--- /dev/null
+++ b/app-admin/system-config-printer-gnome/files/system-config-printer-gnome-1.2.3-split.patch
@@ -0,0 +1,143 @@
+diff -ru ../system-config-printer-1.2.3/Makefile.am ./Makefile.am
+--- ../system-config-printer-1.2.3/Makefile.am 2010-06-24 17:49:35.000000000 +0200
++++ ./Makefile.am 2010-06-30 06:09:00.986506862 +0200
+@@ -2,76 +2,8 @@
+
+ SUBDIRS=po
+
+-EXPORT_MODULES= \
+- cupshelpers/__init__.py \
+- cupshelpers/cupshelpers.py \
+- cupshelpers/ppds.py \
+- cupshelpers/openprinting.py
+-
+-### Automake hooks for Distutils.
+-# The distutils module doesn't understand srcdir != builddir,
+-# so we copy in, along with the cupshelpers modules, into
+-# the builddir for 'all', 'install-exec', and 'clean' hooks.
+-.stamp-distutils-in-builddir: setup.py $(EXPORT_MODULES)
+- if [ "$(top_srcdir)" != "$(top_builddir)" ]; then \
+- cp $(top_srcdir)/setup.py .; \
+- mkdir cupshelpers; \
+- for file in $(EXPORT_MODULES); do \
+- cp $(top_srcdir)/$$file $$file; \
+- done; \
+- fi
+- touch .stamp-distutils-in-builddir
+-
+-dist-hook: mk-ChangeLog
+-.PHONE: mk-ChangeLog
+-mk-ChangeLog:
+- if test -d .git; then \
+- $(top_srcdir)/gitlog-to-changelog \
+- --since=2009-05-01 -- --no-merges \
+- > $(distdir)/cl ; \
+- mv -f $(distdir)/cl $(distdir)/ChangeLog ; \
+- fi
+-
+-config.py: config.py.in Makefile
+- sed \
+- -e "s|\@prefix\@|$(prefix)|" \
+- -e "s|\@datadir\@|$(datadir)|" \
+- -e "s|\@localedir\@|$(localedir)|" \
+- -e "s|\@VERSION\@|$(VERSION)|" \
+- -e "s|\@PACKAGE\@|$(PACKAGE)|" \
+- $< > $@
+-
+-# Use distutils to build the module.
+-all-local: .stamp-distutils-in-builddir config.py
+- $(PYTHON) setup.py build
+-
+-# Use distutils to install the module.
+-install-exec-local: .stamp-distutils-in-builddir
+- $(PYTHON) setup.py install --prefix=$(DESTDIR)$(prefix)
+-
+-# Uninstall the module, crossing our fingers that we know enough
+-# about how distutils works to do this. Unfortunately, distutils
+-# doesn't provide a way to do this itself.
+-uninstall-local:
+- rm -f $(DESTDIR)/$(pythondir)/cupshelpers*.egg-info
+- for file in $(EXPORT_MODULES); do \
+- rm -f $(DESTDIR)/$(pythondir)/$$file*; \
+- done
+-
+-# Tell distutils to clean up.
+-clean-local:
+- -$(PYTHON) setup.py clean --all
+- if [ "$(top_srcdir)" != "$(top_builddir)" ]; then \
+- rm -f setup.py; \
+- for file in $(EXPORT_MODULES); do \
+- rm -f $$file*; \
+- done; \
+- fi
+- rm -f .stamp-distutils-in-builddir
+-
+ nobase_pkgdata_SCRIPTS= \
+ check-device-ids.py \
+- pysmb.py \
+ system-config-printer.py \
+ troubleshoot/__init__.py \
+ applet.py
+@@ -82,9 +14,7 @@
+ asyncipp.py \
+ asyncpk1.py \
+ authconn.py \
+- config.py \
+ cupspk.py \
+- debug.py \
+ dnssdresolve.py \
+ errordialogs.py \
+ HIG.py \
+@@ -95,23 +25,14 @@
+ gtkinklevel.py \
+ gtkspinner.py \
+ installdriver.py \
+- installpackage.py \
+ jobviewer.py \
+- monitor.py \
+ options.py \
+ optionwidgets.py \
+- PhysicalDevice.py \
+- ppdippstr.py \
+ ppdsloader.py \
+- probe_printer.py \
+ gtk_label_autowrap.py \
+- SearchCriterion.py \
+- smburi.py \
+- statereason.py \
+ timedops.py \
+ ToolbarSearchEntry.py \
+ userdefault.py \
+- XmlHelper.py \
+ ui/AboutDialog.glade \
+ ui/ConnectDialog.glade \
+ ui/ConnectingDialog.glade \
+@@ -156,28 +77,10 @@
+ system-config-printer \
+ system-config-printer-applet
+
+-if UDEV_RULES
+-udevrulesdir=$(sysconfdir)/udev/rules.d
+-udevrules_DATA=udev/70-printers.rules
+-udev_udev_configure_printer_SOURCES=\
+- udev/udev-configure-printer.c
+-udev_udev_configure_printer_LDADD=-lcups -ludev -lusb $(GLIB_LIBS)
+-udevhelperdir=$(sysconfdir)/udev
+-udevhelper_PROGRAMS=\
+- udev/udev-configure-printer
+-udevhelper_SCRIPTS=\
+- udev/udev-add-printer
+-endif
+-
+ man_MANS= \
+ man/system-config-printer.1 \
+ man/system-config-printer-applet.1
+
+-dbus_DATA = \
+- newprinternotification.conf \
+- printerdriversinstaller.conf
+-dbusdir = $(sysconfdir)/dbus-1/system.d/
+-
+ desktop_DATA =\
+ system-config-printer.desktop \
+ print-applet.desktop \