summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-arch/createrepo/createrepo-0.10.3.ebuild')
-rw-r--r--app-arch/createrepo/createrepo-0.10.3.ebuild9
1 files changed, 7 insertions, 2 deletions
diff --git a/app-arch/createrepo/createrepo-0.10.3.ebuild b/app-arch/createrepo/createrepo-0.10.3.ebuild
index 5c62c13689e0..01ad5c53db68 100644
--- a/app-arch/createrepo/createrepo-0.10.3.ebuild
+++ b/app-arch/createrepo/createrepo-0.10.3.ebuild
@@ -1,13 +1,13 @@
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-arch/createrepo/createrepo-0.10.3.ebuild,v 1.1 2014/12/25 11:03:49 alonbl Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-arch/createrepo/createrepo-0.10.3.ebuild,v 1.2 2014/12/25 11:12:05 alonbl Exp $
EAPI=5
PYTHON_COMPAT=( python2_7 )
PYTHON_REQ_USE='xml'
-inherit python-single-r1 bash-completion-r1
+inherit python-single-r1 bash-completion-r1 eutils
DESCRIPTION="Creates a common rpm-metadata repository"
HOMEPAGE="http://createrepo.baseurl.org/"
@@ -35,6 +35,11 @@ pkg_setup() {
python_export PYTHON_SITEDIR
}
+src_prepare() {
+ epatch "${FILESDIR}/${P}-ten-changelog-limit.patch"
+ epatch "${FILESDIR}/${P}-pkglist.patch"
+}
+
src_compile() {
:
}